]> git.pld-linux.org Git - packages/Eterm.git/commitdiff
- added imlib patch, define MEMSET to fix build with current imlib2 and libast
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 9 Feb 2023 18:02:56 +0000 (19:02 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 9 Feb 2023 18:02:56 +0000 (19:02 +0100)
Eterm-imlib.patch [new file with mode: 0644]
Eterm.spec

diff --git a/Eterm-imlib.patch b/Eterm-imlib.patch
new file mode 100644 (file)
index 0000000..863b717
--- /dev/null
@@ -0,0 +1,40 @@
+--- Eterm-0.9.6/src/pixmap.h.orig      2009-01-06 10:05:36.000000000 +0100
++++ Eterm-0.9.6/src/pixmap.h   2023-02-09 18:05:38.752800740 +0100
+@@ -221,7 +221,7 @@ _XFUNCPROTOBEGIN
+ extern const char *get_image_type(unsigned char);
+ extern unsigned char image_mode_any(unsigned char);
+ #ifdef PIXMAP_SUPPORT
+-extern const char *imlib_strerror(Imlib_Load_Error);
++extern const char *imlib_load_strerror(Imlib_Load_Error);
+ extern unsigned short parse_pixmap_ops(char *);
+ extern unsigned short set_pixmap_scale(const char *, pixmap_t *);
+ extern unsigned char check_image_ipc(unsigned char);
+--- Eterm-0.9.6/src/pixmap.c.orig      2011-03-16 07:09:23.000000000 +0100
++++ Eterm-0.9.6/src/pixmap.c   2023-02-09 18:06:11.255957989 +0100
+@@ -172,7 +172,7 @@ image_mode_any(unsigned char mode)
+ #ifdef PIXMAP_SUPPORT
+ const char *
+-imlib_strerror(Imlib_Load_Error err)
++imlib_load_strerror(Imlib_Load_Error err)
+ {
+     switch (err) {
+         case IMLIB_LOAD_ERROR_NONE:
+@@ -1447,7 +1447,7 @@ load_image(const char *file, simage_t *s
+         if (f) {
+             im = imlib_load_image_with_error_return(f, &im_err);
+             if (!im) {
+-                libast_print_error("Unable to load image file \"%s\" -- %s\n", file, imlib_strerror(im_err));
++                libast_print_error("Unable to load image file \"%s\" -- %s\n", file, imlib_load_strerror(im_err));
+                 return 0;
+             } else {
+                 reset_simage(simg, (RESET_IMLIB_IM | RESET_PMAP_PIXMAP | RESET_PMAP_MASK));
+@@ -2178,7 +2178,7 @@ set_icon_pixmap(char *filename, XWMHints
+             temp_im = imlib_load_image_with_error_return(icon_path, &im_err);
+             if (!temp_im) {
+-                libast_print_error("Unable to load icon file \"%s\" -- %s\n", icon_path, imlib_strerror(im_err));
++                libast_print_error("Unable to load icon file \"%s\" -- %s\n", icon_path, imlib_load_strerror(im_err));
+             } else {
+                 /* If we're going to render the image anyway, might as well be nice and give it to the WM in a size it likes. */
+                 if (XGetIconSizes(Xdisplay, Xroot, &icon_sizes, &count)) {
index e7ebd49d6808cc7f258a2ea1dff545b4453601a2..52817f1fb52ec9fb1ce13ebdf6f12e4bfbdb191c 100644 (file)
@@ -28,6 +28,7 @@ Source4:      gnome-eterm.png
 Patch0:                %{name}-am_fix.patch
 Patch1:                %{name}-keys-theme.patch
 Patch2:                %{name}-ac_am.patch
+Patch3:                %{name}-imlib.patch
 URL:           http://www.eterm.org/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -91,6 +92,8 @@ użytkownikom zarządców okien innych niż Enlightenment.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+
 find themes/ -name "*.cfg*" -exec \
        sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
 
@@ -98,7 +101,10 @@ find themes/ -name "*.cfg*" -exec \
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
+# libast 0.8.0 no longer defines MEMSET
+CPPFLAGS="%{rpmcppflags} -DMEMSET=memset"
 %configure \
        --disable-static        \
        --enable-shared         \
This page took 0.137468 seconds and 4 git commands to generate.