]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- BR: xorg-lib-libXt-devel
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es.UTF-8):      Terminal para Enlightenment
14 Summary(pl.UTF-8):      Terminal dla Enlightenmenta
15 Summary(pt_BR.UTF-8):   Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.4
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  b8869ee9c9b9516231af9eefa595cee3
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 URL:            http://www.eterm.org/
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  automake
33 BuildRequires:  freetype1-devel
34 BuildRequires:  imlib2-devel >= 1.0.3
35 BuildRequires:  libast-devel >= 0.6
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel
39 BuildRequires:  pcre-devel
40 BuildRequires:  screen
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  twin-devel
43 BuildRequires:  utempter-devel
44 BuildRequires:  xorg-lib-libXt-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Eterm is a color vt102 terminal emulator intended as an xterm(1)
49 replacement for users who want a term program integrated with
50 Enlightenment, or simply want a little more "eye candy". Eterm uses
51 Imlib for advanced graphic abilities.
52
53 %description -l es.UTF-8
54 Eterm es un emulador de terminal vt102 con soporte para colores,
55 desarrollado como un sustituto para el emulador xterm, para los
56 usuarios que deseen un emulador de terminal integrado con la
57 iluminación, o simplemente deseen algo más agradable visualmente. El
58 emulador Eterm usa Imlib para trabajar con gráficos.
59
60 %description -l pl.UTF-8
61 Eterm jest kolorowym emulatorem terminala vt102 mogącym być
62 zamiennikiem xterm(1) dla użytkowników chcących mieć program
63 terminalowy zintegrowany z zarządcą okienek o nazwie Enlightenment lub
64 dla tych którzy chcą mieć trochę bardziej urozmaicony wygląd tego typu
65 programu. Eterm używa biblioteki IMlib do zaawansowanego operowania na
66 grafice.
67
68 %description -l pt_BR.UTF-8
69 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
70 suporte a cores, desenvolvido para ser um substituto para o xterm,
71 para os usuários que queiram um emulador de terminal integrado com o
72 Enlightenment, ou simplesmente queiram algo mais agradável para os
73 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
74
75 %package -n Esetroot
76 Summary:        Utility to set root pixmap
77 Summary(pl.UTF-8):      Aplikacja ustawiająca tło nadrzędnego okna
78 Group:          X11/Window Managers/Tools
79  
80 %description -n Esetroot
81 This program enables non-Enlightenment users to use
82 pseudotransparency.
83
84 %description -n Esetroot -l pl.UTF-8
85 Program ten umożliwia korzystanie z pseudoprzezroczystości
86 użytkownikom zarządców okien innych niż Enlightenment.
87
88 %prep
89 %setup -q -a1
90 %patch0 -p1
91 %patch1 -p1
92 find themes/ -name "*.cfg*" -exec \
93         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --disable-static        \
102         --enable-shared         \
103         --enable-escreen        \
104         --enable-etwin          \
105         --enable-escreen-fx     \
106         --enable-profile        \
107         --enable-trans          \
108 %if %{with mmx}
109         --enable-mmx            \
110 %else
111         --disable-mmx           \
112 %endif
113 %if %{with sse2}
114         --enable-sse2           \
115 %else
116         --disable-sse2          \
117 %endif
118         --enable-utmp           \
119         --enable-auto-encoding  \
120         --enable-multi-charset  \
121         --disable-stack-trace   \
122         --enable-name-reporting-escapes \
123         --without-debugging
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
135 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc doc/*.html ReleaseNotes* ChangeLog
146 %attr(755,root,root) %{_bindir}/Eterm
147 %attr(755,root,root) %{_bindir}/Etbg
148 %attr(755,root,root) %{_bindir}/Etcolors
149 %attr(755,root,root) %{_bindir}/Ettable
150 %attr(755,root,root) %{_bindir}/Etbg_update_list
151 %attr(755,root,root) %{_bindir}/Etsearch
152 %attr(755,root,root) %{_libdir}/lib*.so
153 %{_libdir}/lib*.la
154 %{_mandir}/man1/*
155 %{_datadir}/Eterm
156 %{_desktopdir}/*.desktop
157 %{_pixmapsdir}/*
158
159 %files -n Esetroot
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/Esetroot
162 %attr(755,root,root) %{_bindir}/kEsetroot
163  
This page took 0.068615 seconds and 3 git commands to generate.