]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- added -ac_am.patch (fix build)
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es.UTF-8):      Terminal para Enlightenment
14 Summary(pl.UTF-8):      Terminal dla Enlightenmenta
15 Summary(pt_BR.UTF-8):   Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.4
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  b8869ee9c9b9516231af9eefa595cee3
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 Patch2:         %{name}-ac_am.patch
31 URL:            http://www.eterm.org/
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake
34 BuildRequires:  freetype1-devel
35 BuildRequires:  imlib2-devel >= 1.0.3
36 BuildRequires:  libast-devel >= 0.6
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel
40 BuildRequires:  pcre-devel
41 BuildRequires:  screen
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  twin-devel
44 BuildRequires:  utempter-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Eterm is a color vt102 terminal emulator intended as an xterm(1)
50 replacement for users who want a term program integrated with
51 Enlightenment, or simply want a little more "eye candy". Eterm uses
52 Imlib for advanced graphic abilities.
53
54 %description -l es.UTF-8
55 Eterm es un emulador de terminal vt102 con soporte para colores,
56 desarrollado como un sustituto para el emulador xterm, para los
57 usuarios que deseen un emulador de terminal integrado con la
58 iluminación, o simplemente deseen algo más agradable visualmente. El
59 emulador Eterm usa Imlib para trabajar con gráficos.
60
61 %description -l pl.UTF-8
62 Eterm jest kolorowym emulatorem terminala vt102 mogącym być
63 zamiennikiem xterm(1) dla użytkowników chcących mieć program
64 terminalowy zintegrowany z zarządcą okienek o nazwie Enlightenment lub
65 dla tych którzy chcą mieć trochę bardziej urozmaicony wygląd tego typu
66 programu. Eterm używa biblioteki IMlib do zaawansowanego operowania na
67 grafice.
68
69 %description -l pt_BR.UTF-8
70 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
71 suporte a cores, desenvolvido para ser um substituto para o xterm,
72 para os usuários que queiram um emulador de terminal integrado com o
73 Enlightenment, ou simplesmente queiram algo mais agradável para os
74 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
75
76 %package -n Esetroot
77 Summary:        Utility to set root pixmap
78 Summary(pl.UTF-8):      Aplikacja ustawiająca tło nadrzędnego okna
79 Group:          X11/Window Managers/Tools
80  
81 %description -n Esetroot
82 This program enables non-Enlightenment users to use
83 pseudotransparency.
84
85 %description -n Esetroot -l pl.UTF-8
86 Program ten umożliwia korzystanie z pseudoprzezroczystości
87 użytkownikom zarządców okien innych niż Enlightenment.
88
89 %prep
90 %setup -q -a1
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 find themes/ -name "*.cfg*" -exec \
95         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
96
97 %build
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --disable-static        \
104         --enable-shared         \
105         --enable-escreen        \
106         --enable-etwin          \
107         --enable-escreen-fx     \
108         --enable-profile        \
109         --enable-trans          \
110 %if %{with mmx}
111         --enable-mmx            \
112 %else
113         --disable-mmx           \
114 %endif
115 %if %{with sse2}
116         --enable-sse2           \
117 %else
118         --disable-sse2          \
119 %endif
120         --enable-utmp           \
121         --enable-auto-encoding  \
122         --enable-multi-charset  \
123         --disable-stack-trace   \
124         --enable-name-reporting-escapes \
125         --without-debugging
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
136 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
137 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc doc/*.html ReleaseNotes* ChangeLog
148 %attr(755,root,root) %{_bindir}/Eterm
149 %attr(755,root,root) %{_bindir}/Etbg
150 %attr(755,root,root) %{_bindir}/Etcolors
151 %attr(755,root,root) %{_bindir}/Ettable
152 %attr(755,root,root) %{_bindir}/Etbg_update_list
153 %attr(755,root,root) %{_bindir}/Etsearch
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_mandir}/man1/*
157 %{_datadir}/Eterm
158 %{_desktopdir}/*.desktop
159 %{_pixmapsdir}/*
160
161 %files -n Esetroot
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/Esetroot
164 %attr(755,root,root) %{_bindir}/kEsetroot
165  
This page took 0.04072 seconds and 3 git commands to generate.