]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
69ac95fd8841a19b8773c1cbeb4d413481663efd
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es.UTF-8):      Terminal para Enlightenment
14 Summary(pl.UTF-8):      Terminal dla Enlightenmenta
15 Summary(pt_BR.UTF-8):   Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.4
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  b8869ee9c9b9516231af9eefa595cee3
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 Patch2:         %{name}-ac_am.patch
31 URL:            http://www.eterm.org/
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake
34 BuildRequires:  freetype1-devel
35 BuildRequires:  imlib2-devel >= 1.0.3
36 BuildRequires:  libast-devel >= 0.6
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel
40 BuildRequires:  pcre-devel
41 BuildRequires:  screen
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  twin-devel
44 BuildRequires:  utempter-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Eterm is a color vt102 terminal emulator intended as an xterm(1)
50 replacement for users who want a term program integrated with
51 Enlightenment, or simply want a little more "eye candy". Eterm uses
52 Imlib for advanced graphic abilities.
53
54 %description -l es.UTF-8
55 Eterm es un emulador de terminal vt102 con soporte para colores,
56 desarrollado como un sustituto para el emulador xterm, para los
57 usuarios que deseen un emulador de terminal integrado con la
58 iluminación, o simplemente deseen algo más agradable visualmente. El
59 emulador Eterm usa Imlib para trabajar con gráficos.
60
61 %description -l pl.UTF-8
62 Eterm jest kolorowym emulatorem terminala vt102 mogącym być
63 zamiennikiem xterm(1) dla użytkowników chcących mieć program
64 terminalowy zintegrowany z zarządcą okienek o nazwie Enlightenment lub
65 dla tych którzy chcą mieć trochę bardziej urozmaicony wygląd tego typu
66 programu. Eterm używa biblioteki IMlib do zaawansowanego operowania na
67 grafice.
68
69 %description -l pt_BR.UTF-8
70 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
71 suporte a cores, desenvolvido para ser um substituto para o xterm,
72 para os usuários que queiram um emulador de terminal integrado com o
73 Enlightenment, ou simplesmente queiram algo mais agradável para os
74 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
75
76 %package -n Esetroot
77 Summary:        Utility to set root pixmap
78 Summary(pl.UTF-8):      Aplikacja ustawiająca tło nadrzędnego okna
79 Group:          X11/Window Managers/Tools
80 Provides:       WallpaperChanger
81
82 %description -n Esetroot
83 This program enables non-Enlightenment users to use
84 pseudotransparency.
85
86 %description -n Esetroot -l pl.UTF-8
87 Program ten umożliwia korzystanie z pseudoprzezroczystości
88 użytkownikom zarządców okien innych niż Enlightenment.
89
90 %prep
91 %setup -q -a1
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 find themes/ -name "*.cfg*" -exec \
96         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --disable-static        \
105         --enable-shared         \
106         --enable-escreen        \
107         --enable-etwin          \
108         --enable-escreen-fx     \
109         --enable-profile        \
110         --enable-trans          \
111 %if %{with mmx}
112         --enable-mmx            \
113 %else
114         --disable-mmx           \
115 %endif
116 %if %{with sse2}
117         --enable-sse2           \
118 %else
119         --disable-sse2          \
120 %endif
121         --enable-utmp           \
122         --enable-auto-encoding  \
123         --enable-multi-charset  \
124         --disable-stack-trace   \
125         --enable-name-reporting-escapes \
126         --without-debugging
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
137 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
138 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc doc/*.html ReleaseNotes* ChangeLog
149 %attr(755,root,root) %{_bindir}/Eterm
150 %attr(755,root,root) %{_bindir}/Etbg
151 %attr(755,root,root) %{_bindir}/Etcolors
152 %attr(755,root,root) %{_bindir}/Ettable
153 %attr(755,root,root) %{_bindir}/Etbg_update_list
154 %attr(755,root,root) %{_bindir}/Etsearch
155 %attr(755,root,root) %{_libdir}/lib*.so
156 %{_libdir}/lib*.la
157 %{_mandir}/man1/*
158 %{_datadir}/Eterm
159 %{_desktopdir}/*.desktop
160 %{_pixmapsdir}/*
161
162 %files -n Esetroot
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/Esetroot
165 %attr(755,root,root) %{_bindir}/kEsetroot
This page took 0.03023 seconds and 2 git commands to generate.