]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- removed transparent margins
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es):    Terminal para Enlightenment
14 Summary(pl):    Terminal dla Enlightenmenta
15 Summary(pt_BR): Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.4
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  b8869ee9c9b9516231af9eefa595cee3
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 URL:            http://www.eterm.org/
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  automake
33 BuildRequires:  freetype1-devel
34 BuildRequires:  imlib2-devel >= 1.0.3
35 BuildRequires:  libast-devel >= 0.6
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel
39 BuildRequires:  pcre-devel
40 BuildRequires:  screen
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  twin-devel
43 BuildRequires:  utempter-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Eterm is a color vt102 terminal emulator intended as an xterm(1)
48 replacement for users who want a term program integrated with
49 Enlightenment, or simply want a little more "eye candy". Eterm uses
50 Imlib for advanced graphic abilities.
51
52 %description -l es
53 Eterm es un emulador de terminal vt102 con soporte para colores,
54 desarrollado como un sustituto para el emulador xterm, para los
55 usuarios que deseen un emulador de terminal integrado con la
56 iluminación, o simplemente deseen algo más agradable visualmente. El
57 emulador Eterm usa Imlib para trabajar con gráficos.
58
59 %description -l pl
60 Eterm jest kolorowym emulatorem terminala vt102 mog±cym byæ
61 zamiennikiem xterm(1) dla u¿ytkowników chc±cych mieæ program
62 terminalowy zintegrowany z zarz±dc± okienek o nazwie Enlightenment lub
63 dla tych którzy chc± mieæ trochê bardziej urozmaicony wygl±d tego typu
64 programu. Eterm u¿ywa biblioteki IMlib do zaawansowanego operowania na
65 grafice.
66
67 %description -l pt_BR
68 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
69 suporte a cores, desenvolvido para ser um substituto para o xterm,
70 para os usuários que queiram um emulador de terminal integrado com o
71 Enlightenment, ou simplesmente queiram algo mais agradável para os
72 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
73
74 %package -n Esetroot
75 Summary:        Utility to set root pixmap
76 Summary(pl):    Aplikacja ustawiaj±ca t³o nadrzêdnego okna
77 Group:          X11/Window Managers/Tools
78  
79 %description -n Esetroot
80 This program enables non-Enlightenment users to use
81 pseudotransparency.
82
83 %description -n Esetroot -l pl
84 Program ten umo¿liwia korzystanie z pseudoprzezroczysto¶ci
85 u¿ytkownikom zarz±dców okien innych ni¿ Enlightenment.
86
87 %prep
88 %setup -q -a1
89 %patch0 -p1
90 %patch1 -p1
91 find themes/ -name "*.cfg*" -exec \
92         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         --disable-static        \
101         --enable-shared         \
102         --enable-escreen        \
103         --enable-etwin          \
104         --enable-escreen-fx     \
105         --enable-profile        \
106         --enable-trans          \
107 %if %{with mmx}
108         --enable-mmx            \
109 %else
110         --disable-mmx           \
111 %endif
112 %if %{with sse2}
113         --enable-sse2           \
114 %else
115         --disable-sse2          \
116 %endif
117         --enable-utmp           \
118         --enable-auto-encoding  \
119         --enable-multi-charset  \
120         --disable-stack-trace   \
121         --enable-name-reporting-escapes \
122         --without-debugging
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc doc/*.html ReleaseNotes* ChangeLog
145 %attr(755,root,root) %{_bindir}/Eterm
146 %attr(755,root,root) %{_bindir}/Etbg
147 %attr(755,root,root) %{_bindir}/Etcolors
148 %attr(755,root,root) %{_bindir}/Ettable
149 %attr(755,root,root) %{_bindir}/Etbg_update_list
150 %attr(755,root,root) %{_bindir}/Etsearch
151 %attr(755,root,root) %{_libdir}/lib*.so
152 %{_libdir}/lib*.la
153 %{_mandir}/man1/*
154 %{_datadir}/Eterm
155 %{_desktopdir}/*.desktop
156 %{_pixmapsdir}/*
157
158 %files -n Esetroot
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/Esetroot
161 %attr(755,root,root) %{_bindir}/kEsetroot
162  
This page took 0.089501 seconds and 3 git commands to generate.