]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- updated to 0.9.12, updated am patch DirectFB-0_9_12-1 STABLE
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Sep 2002 18:16:41 +0000 (18:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added -static package
- added libmpeg3 and swf provides as subpackages (because of deps)
- really enabled mmx
- added tutorials to doc

Changed files:
    DirectFB-am.patch -> 1.2
    DirectFB.spec -> 1.21

DirectFB-am.patch
DirectFB.spec

index 622da3f180bef89ccd6e90e37799a77d06e825b2..b5908830bc6116bce984ca9700a4736d3e0f62b7 100644 (file)
---- DirectFB-0.9.10/configure.in.wiget Fri Apr 12 18:46:58 2002
-+++ DirectFB-0.9.10/configure.in       Fri Apr 26 12:25:54 2002
-@@ -107,6 +107,7 @@
-     ;;
- esac
+--- DirectFB-0.9.12/configure.in.orig  Mon Jun 10 13:39:16 2002
++++ DirectFB-0.9.12/configure.in       Sun Sep  1 01:29:59 2002
+@@ -62,6 +62,7 @@
+ AC_PROG_MAKE_SET
+ AC_HEADER_STDC
+ AC_C_CONST
 +AM_PROG_AS
- if test "x$have_x86" = xon; then
- ##
- ## HACK HACK HACK automake uses @AS@ like a gcc
-@@ -198,17 +199,17 @@
- dnl Test for libjpeg
-   JPEG=no
--  AC_ARG_ENABLE(jpeg, [  --enable-jpeg           build JPEG image provider [default=yes]], enable_jpeg="$enableval", enable_jpeg=yes)
-+  AC_ARG_ENABLE(jpeg, [  --enable-jpeg           build JPEG image provider [default=yes]], [enable_jpeg="$enableval"], [enable_jpeg=yes])
-   if test x$enable_jpeg = xyes; then
-     if test -z "$LIBJPEG"; then
-       AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
--        jpeg_ok=yes,
--        jpeg_ok=no)
-+        [jpeg_ok=yes],
-+        [jpeg_ok=no])
-       if test "$jpeg_ok" = yes; then
-         AC_CHECK_HEADER(jpeglib.h,
--        jpeg_ok=yes,
--          jpeg_ok=no)
-+        [jpeg_ok=yes],
-+          [jpeg_ok=no])
-         if test "$jpeg_ok" = yes; then
-         JPEG=yes
-         LIBJPEG='-ljpeg'
-@@ -223,32 +224,32 @@
-     fi
-   fi
--  AM_CONDITIONAL(JPEG_PROVIDER, test x$JPEG = xyes)
-+  AM_CONDITIONAL(JPEG_PROVIDER, [test x$JPEG = xyes])
  
- dnl Test for libpng and libz
-   PNG=no
--  AC_ARG_ENABLE(png, [  --enable-png            build PNG image provider [default=yes]], enable_png="$enableval", enable_png=yes)
-+  AC_ARG_ENABLE(png, [  --enable-png            build PNG image provider [default=yes]], [enable_png="$enableval"], [enable_png=yes])
-   if test x$enable_png = xyes; then
+ AC_PATH_PROGS(PERL, perl5 perl)
  
+@@ -259,23 +260,23 @@
    dnl Test for libz
      if test -z "$LIBZ"; then
--      AC_CHECK_LIB(z, gzsetparams,
-+      AC_CHECK_LIB(z, gzsetparams,[
-         AC_CHECK_HEADER(zlib.h,
--        LIBZ='-lz',
--        AC_MSG_WARN([*** libz header files not found. PNG image provider will not be built.])),
--        AC_MSG_WARN([*** libz not found. PNG image provider will not be built.]))
-+        [LIBZ='-lz'],
-+        [AC_MSG_WARN([*** libz header files not found. PNG image provider will not be built.])])],
-+        [AC_MSG_WARN([*** libz not found. PNG image provider will not be built.])])
+       AC_CHECK_LIB(z, gzsetparams,
+-        AC_CHECK_HEADER(zlib.h,
++        [AC_CHECK_HEADER(zlib.h,
+         LIBZ='-lz',
+-        AC_MSG_WARN([
+-*** libz header files not found. PNG image provider will not be built.])),
+-        AC_MSG_WARN([
+-*** libz not found. PNG image provider will not be built.]))
++        [AC_MSG_WARN([
++*** libz header files not found. PNG image provider will not be built.])])],
++        [AC_MSG_WARN([
++*** libz not found. PNG image provider will not be built.])])
      fi
  
    dnl Test for libpng
      if test -z "$LIBPNG" && test -n "$LIBZ"; then
        AC_CHECK_LIB(png, png_read_info,
 -        AC_CHECK_HEADER(png.h,
--        png_ok=yes,
--        AC_MSG_WARN([*** PNG header files not found. PNG image provider will not be built.])),
--        AC_MSG_WARN([*** PNG library not found. PNG image provider will not be built.]), $LIBZ -lm)
 +        [AC_CHECK_HEADER(png.h,
-+        [png_ok=yes],
-+        [AC_MSG_WARN([*** PNG header files not found. PNG image provider will not be built.])])],
-+        [AC_MSG_WARN([*** PNG library not found. PNG image provider will not be built.])], $LIBZ -lm)
+         png_ok=yes,
+-        AC_MSG_WARN([
+-*** PNG header files not found. PNG image provider will not be built.])),
+-        AC_MSG_WARN([
+-*** PNG library not found. PNG image provider will not be built.]), $LIBZ -lm)
++        [AC_MSG_WARN([
++*** PNG header files not found. PNG image provider will not be built.])])],
++        [AC_MSG_WARN([
++*** PNG library not found. PNG image provider will not be built.])], $LIBZ -lm)
        if test "$png_ok" = yes; then
          AC_MSG_CHECKING([for png_structp in png.h])
          AC_TRY_COMPILE([#include <png.h>],
-@@ -256,7 +257,7 @@
-          png_infop info;
-          png_colorp cmap;
-          png_create_read_struct;],
--          png_ok=yes, png_ok=no)
-+          [png_ok=yes], [png_ok=no])
-         AC_MSG_RESULT($png_ok)
-         if test "$png_ok" = yes; then
-         PNG=yes
-@@ -276,7 +277,7 @@
- dnl Allow to disable GIF support
--  AC_ARG_ENABLE(gif, [  --enable-gif            build GIF image provider [default=yes]], enable_gif="$enableval", enable_gif=yes)
-+  AC_ARG_ENABLE(gif, [  --enable-gif            build GIF image provider [default=yes]], [enable_gif="$enableval"], [enable_gif=yes])
-  
-   AM_CONDITIONAL(GIF_PROVIDER, test x$enable_gif = xyes)
-@@ -323,11 +324,11 @@
-   if test -z "$LIBFLASH"; then
+@@ -363,13 +364,13 @@
+   if test x$enable_flash = xyes; then
      AC_CHECK_LIB(flash, FlashGetInfo,
 -      AC_CHECK_HEADER(flash.h,
--      FLASH=yes
--      LIBFLASH='-lflash',
--      AC_MSG_WARN([*** libflash headers not found -- SWF media provider will not be built.])),
--      AC_MSG_WARN([*** libflash not found -- SWF media provider will not be built.]), $LIBJPEG $LIBZ -lm)
 +      [AC_CHECK_HEADER(flash.h,
-+      [FLASH=yes
-+      LIBFLASH='-lflash'],
-+      [AC_MSG_WARN([*** libflash headers not found -- SWF media provider will not be built.])])],
-+      [AC_MSG_WARN([*** libflash not found -- SWF media provider will not be built.])], [$LIBJPEG $LIBZ -lm])
+       FLASH=yes
+       LIBFLASH='-lflash',
+-      AC_MSG_WARN([
+-*** libflash headers not found -- Flash media provider will not be built.])),
+-      AC_MSG_WARN([
+-*** libflash not found -- Flash media provider will not be built.]), $LIBJPEG $LIBZ -lm)
++      [AC_MSG_WARN([
++*** libflash headers not found -- Flash media provider will not be built.])])],
++      [AC_MSG_WARN([
++*** libflash not found -- Flash media provider will not be built.])], $LIBJPEG $LIBZ -lm)
    fi
  
  AM_CONDITIONAL(FLASH_PROVIDER, test x$FLASH = xyes)
-@@ -360,8 +361,8 @@
-   yes
- #endif
- ], ati=yes, 
--  ati=no
--  AC_MSG_WARN(*** ATI Rage 128 gfxdriver will not be built.))
-+  [ati=no
-+  AC_MSG_WARN([*** ATI Rage 128 gfxdriver will not be built.])])
- AM_CONDITIONAL(GFX_ATI, test x$ati = xyes)
+@@ -381,13 +382,13 @@
+   if test x$enable_mpeg3 = xyes; then
+     AC_CHECK_LIB(mpeg3, mpeg3_open,
+-      AC_CHECK_HEADER(libmpeg3.h,
++      [AC_CHECK_HEADER(libmpeg3.h,
+         MPEG3=yes
+         LIBMPEG3='-lmpeg3',
+-        AC_MSG_WARN([
+-*** libmpeg3 headers not found -- Libmpeg3 video provider will not be built.])),
+-      AC_MSG_WARN([
+-*** libmpeg3 not found -- Libmpeg3 video provider will not be build.]), -lm -lpthread)
++        [AC_MSG_WARN([
++*** libmpeg3 headers not found -- Libmpeg3 video provider will not be built.])])],
++      [AC_MSG_WARN([
++*** libmpeg3 not found -- Libmpeg3 video provider will not be build.])], -lm -lpthread)
+   fi
  
-@@ -373,8 +374,8 @@
+ AM_CONDITIONAL(LIBMPEG3_PROVIDER, test x$MPEG3 = xyes)
+@@ -415,9 +416,9 @@
    yes
  #endif
  ], matrox=yes, 
 -  matrox=no  
--  AC_MSG_WARN(*** Matrox G200/400 gfxdriver will not be built.))
 +  [matrox=no  
-+  AC_MSG_WARN([*** Matrox G200/400 gfxdriver will not be built.])])
+   AC_MSG_WARN([
+-*** Matrox G200/400/450/550 gfxdriver will not be built.]))
++*** Matrox G200/400/450/550 gfxdriver will not be built.])])
  
  AM_CONDITIONAL(GFX_MATROX, test x$matrox = xyes)
  
-@@ -386,8 +387,8 @@
+@@ -429,9 +430,9 @@
    yes
  #endif
  ], tdfx=yes, 
 -  tdfx=no  
--  AC_MSG_WARN(*** 3DFX Voodoo/Banshee gfxdriver will not be built.))
 +  [tdfx=no  
-+  AC_MSG_WARN([*** 3DFX Voodoo/Banshee gfxdriver will not be built.])])
+   AC_MSG_WARN([
+-*** 3DFX Voodoo/Banshee gfxdriver will not be built.]))
++*** 3DFX Voodoo/Banshee gfxdriver will not be built.])])
  
  AM_CONDITIONAL(GFX_TDFX, test x$tdfx = xyes)
  
-@@ -399,8 +400,8 @@
+@@ -443,9 +444,9 @@
    yes
  #endif
  ], nvidia=yes, 
 -  nvidia=no  
--  AC_MSG_WARN(*** nVidia RIVA TNT gfxdriver will not be built.))
 +  [nvidia=no  
-+  AC_MSG_WARN([*** nVidia RIVA TNT gfxdriver will not be built.])])
+   AC_MSG_WARN([
+-*** nVidia RIVA TNT gfxdriver will not be built.]))
++*** nVidia RIVA TNT gfxdriver will not be built.])])
  
  AM_CONDITIONAL(GFX_NVIDIA, test x$nvidia = xyes)
  
-@@ -410,22 +411,22 @@
+@@ -457,9 +458,9 @@
+   yes
+ #endif
+ ], savage=yes,
+-  savage=no   
++  [savage=no   
+   AC_MSG_WARN([
+-*** Savage gfxdriver will not be built.]))
++*** Savage gfxdriver will not be built.])])
+ AM_CONDITIONAL(GFX_SAVAGE, test x$savage = xyes)
+@@ -469,25 +470,25 @@
  
  
  dnl Test for H3600 Touchscreen support
 -AC_CHECK_HEADER( [linux/h3600_ts.h], h3600_ts=yes, h3600_ts=no  
--  AC_MSG_WARN(*** H3600 Touchscreen driver will not be built.))
 +AC_CHECK_HEADER( [linux/h3600_ts.h], h3600_ts=yes, [h3600_ts=no  
-+  AC_MSG_WARN([*** H3600 Touchscreen driver will not be built.])])
+   AC_MSG_WARN([
+-*** H3600 Touchscreen driver will not be built.]))
++*** H3600 Touchscreen driver will not be built.])])
  
  AM_CONDITIONAL(H3600_TS, test x$h3600_ts = xyes)
  
  
  dnl Test for SonyPI Jogdial support
 -AC_CHECK_HEADER( [linux/sonypi.h], sonypi=yes, sonypi=no  
--  AC_MSG_WARN(*** SonyPI Jogdial driver will not be built.))
 +AC_CHECK_HEADER( [linux/sonypi.h], sonypi=yes, [sonypi=no  
-+  AC_MSG_WARN([*** SonyPI Jogdial driver will not be built.])])
+   AC_MSG_WARN([
+-*** SonyPI Jogdial driver will not be built.]))
++*** SonyPI Jogdial driver will not be built.])])
  
  AM_CONDITIONAL(SONYPI, test x$sonypi = xyes)
  
  
  dnl Test for DBox2 Remote support
 -AC_CHECK_HEADER( [dbox/fp.h], dbox2remote=yes, dbox2remote=no
--  AC_MSG_WARN(*** DBox2 Remote driver will not be built.))
 +AC_CHECK_HEADER( [dbox/fp.h], dbox2remote=yes, [dbox2remote=no
-+  AC_MSG_WARN([*** DBox2 Remote driver will not be built.])])
+   AC_MSG_WARN([
+-*** DBox2 Remote driver will not be built.]))
++*** DBox2 Remote driver will not be built.])])
  
  AM_CONDITIONAL(DBOX2REMOTE, test x$dbox2remote = xyes)
  
+@@ -496,11 +496,11 @@
+ DFB_CFLAGS="$DFB_CFLAGS $DFB_INTERNAL_CFLAGS"
+ DFB_CXXFLAGS="$DFB_CFLAGS"
+-if test x$cflags_set != xset ; then
++if test "x$cflags_set" != "xset" ; then
+   DFB_CFLAGS="$DFB_CFLAGS $CFLAGS"
+ fi
+-if test x$cxxflags_set != xset ; then
++if test "x$cxxflags_set" != "xset" ; then
+   DFB_CXXFLAGS="$DFB_CXXFLAGS $CXXFLAGS"
+ fi
index fd9e3df7ce3a81555011304652e516f108656b8f..53e2d5aeac10ee1377329ebfc79d84f702e1e647 100644 (file)
@@ -1,19 +1,24 @@
 Summary:       DirectFB - Hardware graphics acceleration
 Summary(pl):   DirectFB - Wspomaganie grafiki
 Name:          DirectFB
-Version:       0.9.10
+Version:       0.9.12
 Release:       1
 License:       GPL
 Group:         Libraries
 Source0:       http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
+Source1:       http://www.directfb.org/download/DirectFB/DFBTutorials-0.4.2.tar.gz
 Patch0:                %{name}-am.patch
 URL:           http://www.directfb.org/
-BuildRequires: libpng-devel >= 1.2.0
-BuildRequires: zlib-devel >= 1.1.3
-BuildRequires: libjpeg-devel >= 6b
-BuildRequires: freetype-devel >= 2.0.2
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: flash-devel
+BuildRequires: freetype-devel >= 2.0.2
+BuildRequires: gettext-devel
+BuildRequires: libjpeg-devel >= 6b
+BuildRequires: libmpeg3-devel
+BuildRequires: libpng-devel >= 1.2.0
+BuildRequires: libtool
+BuildRequires: zlib-devel >= 1.1.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -31,22 +36,62 @@ Requires:   %{name} = %{version}
 %description devel
 DirectFB header files.
 
-%description -l pl devel
+%description devel -l pl
 Pliki nag³ówkowe dla DirectFB.
 
+%package static
+Summary:       DirectFB static libraries
+Summary(pl):   Statyczne biblioteki DirectFB
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+
+%description static
+DirectFB static libraries.
+
+%description static -l pl
+Statyczne biblioteki DirectFB.
+
 %package doc
 Summary:       DirectFB - documentation
 Summary(pl):   DirectFB - dokumantacja
 Group:         Development/Libraries
 
 %description doc
-DirectFB documentation and examples.
+DirectFB documentation and tutorials.
+
+%description doc -l pl
+Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
+
+%package video-libmpeg3
+Summary:       MPEG video provider for DirectFB
+Summary(pl):   DirectFB - wtyczka dostarczaj±ca obraz MPEG
+Group:         Libraries
+Requires:      %{name} = %{version}
+
+%description video-libmpeg3
+This package contains MPEG (MPEG-1 and MPEG-2) video provider for
+DirectFB. It uses libmpeg3 library.
+
+%description video-libmpeg3 -l pl
+Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
+(MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3. 
+
+%package video-swf
+Summary:       ShockWave Flash video provider for DirectFB
+Summary(pl):   DirectFB - wtyczka dostarczaj±ca obraz ShockWave Flash
+Group:         Libraries
+Requires:      %{name} = %{version}
 
-%description -l pl doc
-Dokumentacja dla systemu DirectFB wraz z przyk³adami.
+%description video-swf
+This package contains SWF (ShockWave Flash) video provider for
+DirectFB. It uses flash library.
+
+%description video-swf -l pl
+Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± obraz SWF
+(ShockWave Flash) przy u¿yciu biblioteki flash.
 
 %prep
-%setup  -q
+%setup -q -a1
 %patch0 -p1
 
 %build
@@ -55,17 +100,21 @@ rm -f missing
 %{__gettextize}
 aclocal
 %{__autoconf}
-automake -a -c 
-if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
-       CPPFLAGS="`pkg-config libpng12 --cflags`"
-fi
-%configure CPPFLAGS="$CPPFLAGS" \
+%{__automake}
+# paths for libmpeg3 and libflash
+CPPFLAGS="-I/usr/include/libmpeg3 -I/usr/X11R6/include"
+LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
+%configure \
        --disable-maintainer-mode \
        --enable-shared \
+       --enable-static \
        --disable-fast-install \
        --disable-debug \
        --disable-avifile \
-       --enable-mmx 
+%ifarch i586 i686 athlon
+       --enable-mmx=on
+%endif
+# MMX is detected at runtime, so it's safe
 
 %{__make} RPM_OPT_FLAGS="%{rpmcflags}"
 
@@ -73,30 +122,58 @@ fi
 rm -rf $RPM_BUILD_ROOT
 %{__make} DESTDIR=$RPM_BUILD_ROOT install
 
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-%post devel -p /sbin/ldconfig
-%postun devel -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_libdir}/directfb
-%{_datadir}/directfb
+%dir %{_libdir}/directfb-%{version}
+%dir %{_libdir}/directfb-%{version}/gfxdrivers
+%attr(755,root,root) %{_libdir}/directfb-%{version}/gfxdrivers/*.??
+%dir %{_libdir}/directfb-%{version}/inputdrivers
+%attr(755,root,root) %{_libdir}/directfb-%{version}/inputdrivers/*.??
+%dir %{_libdir}/directfb-%{version}/interfaces
+%dir %{_libdir}/directfb-%{version}/interfaces/IDirectFBFont
+%attr(755,root,root) %{_libdir}/directfb-%{version}/interfaces/IDirectFBFont/*.??
+%dir %{_libdir}/directfb-%{version}/interfaces/IDirectFBImageProvider
+%attr(755,root,root) %{_libdir}/directfb-%{version}/interfaces/IDirectFBImageProvider/*.??
+%dir %{_libdir}/directfb-%{version}/interfaces/IDirectFBVideoProvider
+%attr(755,root,root) %{_libdir}/directfb-%{version}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.??
+%{_datadir}/directfb-%{version}
+%{_mandir}/man5/*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/directfb-config
-%{_includedir}/directfb.h
+%{_includedir}/directfb
 %{_includedir}/directfb-internal
 %{_pkgconfigdir}/*
 %{_libdir}/*.la
 %{_libdir}/*.so
 
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
+%{_libdir}/directfb-%{version}/gfxdrivers/*.a
+%{_libdir}/directfb-%{version}/inputdrivers/*.a
+%{_libdir}/directfb-%{version}/interfaces/*/*.a
+
 %files doc
 %defattr(644,root,root,755)
 %doc docs/html/*
+%{_examplesdir}/%{name}-%{version}
+
+%files video-libmpeg3
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/directfb-%{version}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.??
+
+%files video-swf
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/directfb-%{version}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.??
This page took 0.090914 seconds and 4 git commands to generate.