]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- added format patch (fixes build with -Werror=format-security)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Jul 2013 07:28:00 +0000 (09:28 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Jul 2013 07:28:00 +0000 (09:28 +0200)
- handle xine_vdpau plugin

DirectFB-format.patch [new file with mode: 0644]
DirectFB.spec

diff --git a/DirectFB-format.patch b/DirectFB-format.patch
new file mode 100644 (file)
index 0000000..52584c3
--- /dev/null
@@ -0,0 +1,65 @@
+--- DirectFB-1.7.0/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_openquicktime.c.orig       2013-07-09 00:23:17.000000000 +0200
++++ DirectFB-1.7.0/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_openquicktime.c    2013-07-21 08:45:13.711671545 +0200
+@@ -253,7 +253,7 @@
+           desc->caps |= DVSCAPS_VIDEO;
+      
+           snprintf( desc->video.encoding,
+-                    DFB_STREAM_DESC_ENCODING_LENGTH,
++                    DFB_STREAM_DESC_ENCODING_LENGTH, "%s",
+                     quicktime_video_compressor( data->file, 0 ) ? : "" );
+           desc->video.framerate = quicktime_frame_rate( data->file, 0 );
+           desc->video.aspect    = (double) quicktime_video_width( data->file, 0 ) /
+@@ -265,7 +265,7 @@
+           desc->caps |= DVSCAPS_AUDIO;
+           snprintf( desc->audio.encoding,
+-                    DFB_STREAM_DESC_ENCODING_LENGTH,
++                    DFB_STREAM_DESC_ENCODING_LENGTH, "%s",
+                     quicktime_audio_compressor( data->file, 0 ) ? : "" );
+           desc->audio.samplerate = quicktime_sample_rate( data->file, 0 );
+           desc->audio.channels   = quicktime_track_channels( data->file, 0 );
+--- DirectFB-1.7.0/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_xine.c.orig        2013-01-12 06:06:23.000000000 +0100
++++ DirectFB-1.7.0/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_xine.c     2013-07-21 08:48:00.479143131 +0200
+@@ -428,7 +428,7 @@
+           desc->caps |= DVSCAPS_VIDEO;
+      
+           snprintf( desc->video.encoding,
+-                    DFB_STREAM_DESC_ENCODING_LENGTH,
++                    DFB_STREAM_DESC_ENCODING_LENGTH, "%s",
+                     xine_get_meta_info( data->stream, XINE_META_INFO_VIDEOCODEC ) ?:"" );
+           desc->video.framerate = xine_get_stream_info( data->stream, 
+                                                         XINE_STREAM_INFO_FRAME_DURATION );
+@@ -444,7 +444,7 @@
+           desc->caps |= DVSCAPS_AUDIO;
+           snprintf( desc->audio.encoding,
+-                    DFB_STREAM_DESC_ENCODING_LENGTH,
++                    DFB_STREAM_DESC_ENCODING_LENGTH, "%s",
+                     xine_get_meta_info( data->stream, XINE_META_INFO_AUDIOCODEC ) ?:"" );
+           desc->audio.samplerate = xine_get_stream_info( data->stream,
+                                                          XINE_STREAM_INFO_AUDIO_SAMPLERATE );
+@@ -455,19 +455,19 @@
+      }
+                
+      snprintf( desc->title,
+-               DFB_STREAM_DESC_TITLE_LENGTH,
++               DFB_STREAM_DESC_TITLE_LENGTH, "%s",
+                xine_get_meta_info( data->stream, XINE_META_INFO_TITLE ) ?:"" );
+      snprintf( desc->author,
+-               DFB_STREAM_DESC_AUTHOR_LENGTH,
++               DFB_STREAM_DESC_AUTHOR_LENGTH, "%s",
+                xine_get_meta_info( data->stream, XINE_META_INFO_ARTIST ) ?:"" );
+      snprintf( desc->album,
+-               DFB_STREAM_DESC_ALBUM_LENGTH,
++               DFB_STREAM_DESC_ALBUM_LENGTH, "%s",
+                xine_get_meta_info( data->stream, XINE_META_INFO_ALBUM ) ?:"" );
+      snprintf( desc->genre,
+-               DFB_STREAM_DESC_GENRE_LENGTH,
++               DFB_STREAM_DESC_GENRE_LENGTH, "%s",
+                xine_get_meta_info( data->stream, XINE_META_INFO_GENRE ) ?:"" );
+      snprintf( desc->comment,
+-               DFB_STREAM_DESC_COMMENT_LENGTH,
++               DFB_STREAM_DESC_COMMENT_LENGTH, "%s",
+                xine_get_meta_info( data->stream, XINE_META_INFO_COMMENT ) ?:"" );
+      desc->year = atoi( xine_get_meta_info( data->stream, XINE_META_INFO_YEAR ) ?:"" );
index 971c6d1b319519dfa8eb45d5138e3dfed98ccc74..c2a11f51b81bb97dee32e087759f1a023629623a 100644 (file)
@@ -19,6 +19,9 @@
 %ifarch sh4
 %define                with_sh772x     1
 %endif
+%if %{without xine}
+%undefine      xine_vdpau
+%endif
 Summary:       DirectFB - Hardware graphics acceleration
 Summary(pl.UTF-8):     DirectFB - Wspomaganie grafiki
 Name:          DirectFB
@@ -42,6 +45,7 @@ Patch7:               %{name}-sh.patch
 Patch8:                %{name}-missing.patch
 Patch9:                %{name}-ffmpeg.patch
 Patch10:       %{name}-libmpeg3.patch
+Patch11:       %{name}-format.patch
 URL:           http://www.directfb.org/
 BuildRequires: Mesa-libEGL-devel
 BuildRequires: Mesa-libGLES-devel
@@ -918,6 +922,7 @@ Statyczna biblioteka sawman.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 # video drivers
 %{__sed} -i -e 's/checkfor_\(cle266\|cyber5k\|radeon\|savage\|unichrome\|vmware\)=no/checkfor_\1=yes/' configure.in
@@ -1321,6 +1326,9 @@ rm -rf $RPM_BUILD_ROOT
 %files video-xine
 %defattr(644,root,root,755)
 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_xine.so
+%if %{with xine_vdpau}
+%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_xine_vdpau.so
+%endif
 
 %files -n xine-output-video-dfb
 %defattr(644,root,root,755)
This page took 0.088001 seconds and 4 git commands to generate.