]> git.pld-linux.org Git - packages/DirectFB.git/blobdiff - DirectFB.spec
- gcc4 patch updated.
[packages/DirectFB.git] / DirectFB.spec
index 239da75838b323eeec066f5942486e2f560e5405..d0e8500fc88401ed29db1b1e74aa8b64db7fe3b4 100644 (file)
@@ -1,4 +1,19 @@
 #
+# TODO:
+#      - fix x86-64 int32<->ptr64 casts.
+#
+#      tree.c:88: warning: cast from pointer to integer of different size
+#      tree.c:102: warning: cast from pointer to integer of different size
+#      fonts.c:144: warning: cast to pointer from integer of different size
+#      fonts.c:211: warning: cast to pointer from integer of different size
+#      gfxcard.c:1451: warning: cast to pointer from integer of different size
+#      fbdev.c:459: warning: cast from pointer to integer of different size
+#      fbdev.c:578: warning: cast from pointer to integer of different size
+#      fbdev.c:708: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
+#
 # Conditional build:
 %bcond_with    multi           # build Multi-application core (requires working /dev/fusion*)
 #
@@ -6,7 +21,7 @@ Summary:       DirectFB - Hardware graphics acceleration
 Summary(pl):   DirectFB - Wspomaganie grafiki
 Name:          DirectFB
 Version:       0.9.24
-Release:       1
+Release:       1.1
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
@@ -18,6 +33,8 @@ Patch0:               %{name}-am.patch
 Patch1:                %{name}-pmake.patch
 Patch2:                %{name}-fix.patch
 Patch3:                %{name}-sh.patch
+Patch4:                %{name}-gcc4.patch
+Patch5:                %{name}-llh-ppc.patch
 URL:           http://www.directfb.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
@@ -37,6 +54,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dfbdir  %{_libdir}/directfb-%{version}
 
+%define                specflags       -fno-strict-aliasing
+
 %ifarch %{ix86}
 # gcc running out of registers with -O0 in generic_mmx.h
 %define                debugcflags     -O1 -g
@@ -53,7 +72,6 @@ Summary:      DirectFB - development package
 Summary(pl):   DirectFB - pliki nag³ówkowe
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      pkgconfig
 Requires:      zlib-devel >= 1.1.3
 
 %description devel
@@ -201,6 +219,8 @@ UWAGA: do dzia
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
@@ -224,7 +244,7 @@ UWAGA: do dzia
        --enable-voodoo \
        --enable-x11 \
        --enable-zlib \
-%ifarch %{ix86}
+%ifarch %{ix86} %{x8664}
 %ifnarch i386 i486
        --enable-mmx \
 %endif
@@ -233,7 +253,8 @@ UWAGA: do dzia
 %endif
 %endif
 
-%{__make}
+%{__make} \
+       X11_LIBS=%{_prefix}/X11R6/%{_lib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.035747 seconds and 4 git commands to generate.