]> git.pld-linux.org Git - packages/DirectFB.git/blobdiff - DirectFB.spec
- ppc/llh build fix.
[packages/DirectFB.git] / DirectFB.spec
index 47b16a8c3b35345fb1f1acc745847bb234077ed6..a784f6992765e6d62a3cb0f552a7800666f6b9b2 100644 (file)
@@ -1,27 +1,40 @@
 #
+# TODO:
+#      - fix x86-64 int32<->ptr64 casts.
+#
+#      tree.c:88: warning: cast from pointer to integer of different size
+#      tree.c:102: warning: cast from pointer to integer of different size
+#      fonts.c:144: warning: cast to pointer from integer of different size
+#      fonts.c:211: warning: cast to pointer from integer of different size
+#      gfxcard.c:1451: warning: cast to pointer from integer of different size
+#      fbdev.c:459: warning: cast from pointer to integer of different size
+#      fbdev.c:578: warning: cast from pointer to integer of different size
+#      fbdev.c:708: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
+#
 # Conditional build:
 %bcond_with    multi           # build Multi-application core (requires working /dev/fusion*)
 #
 Summary:       DirectFB - Hardware graphics acceleration
 Summary(pl):   DirectFB - Wspomaganie grafiki
 Name:          DirectFB
-Version:       0.9.23
+Version:       0.9.24
 Release:       1
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://www.directfb.org/download/DirectFB/%{name}-%{version}.tar.gz
-# Source0-md5: f52ee63851fe56ee494bcf09ef559bf3
-Source1:       http://www.directfb.org/download/DirectFB-extra/DFBTutorials-0.5.0.tar.gz
+Source0:       http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
+# Source0-md5: 1f4b56b20d4e6f5c6ceb15c1c4fd2ecd
+Source1:       http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
 # Source1-md5: 13e443a64bddd68835b574045d9025e9
 Patch0:                %{name}-am.patch
 Patch1:                %{name}-pmake.patch
 Patch2:                %{name}-fix.patch
-# missing files taken from DirectFB CVS
-Patch3:                %{name}-missing-files.patch
-Patch4:                %{name}-sh.patch
-Patch5:                %{name}-drivers.patch
-Patch6:                %{name}-segv.patch
+Patch3:                %{name}-sh.patch
+Patch4:                %{name}-gcc4.patch
+Patch5:                %{name}-llh-ppc.patch
 URL:           http://www.directfb.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
@@ -30,8 +43,8 @@ BuildRequires:        automake
 BuildRequires: freetype-devel >= 2.0.2
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.0
-BuildRequires: libvncserver-devel
 BuildRequires: libtool
+BuildRequires: libvncserver-devel
 %{?with_multi:BuildRequires:   linux-fusion-devel}
 BuildRequires: sed >= 4.0
 BuildRequires: sysfsutils-devel >= 1.3.0-3
@@ -41,6 +54,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dfbdir  %{_libdir}/directfb-%{version}
 
+%define                specflags       -fno-strict-aliasing
+
 %ifarch %{ix86}
 # gcc running out of registers with -O0 in generic_mmx.h
 %define                debugcflags     -O1 -g
@@ -177,9 +192,9 @@ with other devices connected to this port (mouse, modem etc.).
 %description input-elo -l pl
 Sterownik wej¶ciowy do touchscreenów ELO dla DirectFB.
 
-UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc nie
-nale¿y go instalowaæ, je¶li urz±dzenie ELO nie jest pod³±czone do tego
-portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
+UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
+nie nale¿y go instalowaæ, je¶li urz±dzenie ELO nie jest pod³±czone do
+tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
 pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
 
 %package input-mutouch
@@ -206,7 +221,6 @@ UWAGA: do dzia
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %build
 %{__libtoolize}
@@ -230,7 +244,7 @@ UWAGA: do dzia
        --enable-voodoo \
        --enable-x11 \
        --enable-zlib \
-%ifarch %{ix86}
+%ifarch %{ix86} %{x8664}
 %ifnarch i386 i486
        --enable-mmx \
 %endif
@@ -239,7 +253,8 @@ UWAGA: do dzia
 %endif
 %endif
 
-%{__make}
+%{__make} \
+       X11_LIBS=%{_prefix}/X11R6/%{_lib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.111918 seconds and 4 git commands to generate.