]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
4fcd7d11384e87c6e6594741edb27f94744dff9d
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 # _without_flash        - don't build FLASH support
4 # _without_mpg          - don't build support for MPG/MPEG3
5 #
6 Summary:        DirectFB - Hardware graphics acceleration
7 Summary(pl):    DirectFB - Wspomaganie grafiki
8 Name:           DirectFB
9 Version:        0.9.15
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
14 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
15 Patch0:         %{name}-am.patch
16 URL:            http://www.directfb.org/
17 #BuildRequires: SDL-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 %{!?_without_flash:BuildRequires:       flash-devel >= 0.4.10-5}
21 BuildRequires:  freetype-devel >= 2.0.2
22 BuildRequires:  libjpeg-devel >= 6b
23 %{!?_without_mpg:BuildRequires: libmpeg3-devel}
24 BuildRequires:  libpng-devel >= 1.0
25 BuildRequires:  libtool
26 BuildRequires:  zlib-devel >= 1.1.3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         dfbdir  %{_libdir}/directfb-%{version}
30
31 %description
32 DirectFB hardware graphics acceleration - libraries.
33
34 %description -l pl
35 Wspomaganie grafiki DirectFB - biblioteki.
36
37 %package devel
38 Summary:        DirectFB - development package
39 Summary(pl):    DirectFB - pliki nag³ówkowe
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}
42
43 %description devel
44 DirectFB header files.
45
46 %description devel -l pl
47 Pliki nag³ówkowe dla DirectFB.
48
49 %package static
50 Summary:        DirectFB static libraries
51 Summary(pl):    Statyczne biblioteki DirectFB
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}
54
55 %description static
56 DirectFB static libraries.
57
58 %description static -l pl
59 Statyczne biblioteki DirectFB.
60
61 %package doc
62 Summary:        DirectFB - documentation
63 Summary(pl):    DirectFB - dokumentacja
64 Group:          Development/Libraries
65
66 %description doc
67 DirectFB documentation and tutorials.
68
69 %description doc -l pl
70 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
71
72 %package font-ft2
73 Summary:        FreeType2 font provider for DirectFB
74 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
75 Group:          Libraries
76 Requires:       %{name} = %{version}
77
78 %description font-ft2
79 This package contains FreeType2 font provider for DirectFB.
80
81 %description font-ft2 -l pl
82 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
83 bibliotekê FreeType2.
84
85 %package image-jpeg
86 Summary:        JPEG image provider for DirectFB
87 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
88 Group:          Libraries
89 Requires:       %{name} = %{version}
90
91 %description image-jpeg
92 This package contains JPEG image provider for DirectFB.
93
94 %description image-jpeg -l pl
95 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
96
97 %package image-png
98 Summary:        PNG image provider for DirectFB
99 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
100 Group:          Libraries
101 Requires:       %{name} = %{version}
102
103 %description image-png
104 This package contains PNG image provider for DirectFB.
105
106 %description image-png -l pl
107 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
108
109 %package video-libmpeg3
110 Summary:        MPEG video provider for DirectFB
111 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
112 Group:          Libraries
113 Requires:       %{name} = %{version}
114
115 %description video-libmpeg3
116 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
117 DirectFB. It uses libmpeg3 library.
118
119 %description video-libmpeg3 -l pl
120 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
121 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3. 
122
123 %package video-swf
124 Summary:        ShockWave Flash video provider for DirectFB
125 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz ShockWave Flash
126 Group:          Libraries
127 Requires:       %{name} = %{version}
128
129 %description video-swf
130 This package contains SWF (ShockWave Flash) video provider for
131 DirectFB. It uses flash library.
132
133 %description video-swf -l pl
134 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± obraz SWF
135 (ShockWave Flash) przy u¿yciu biblioteki flash.
136
137 %prep
138 %setup -q -a1
139 %patch0 -p1
140
141 %build
142 rm -f missing
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147 # paths for libmpeg3 and libflash
148 CPPFLAGS="-I/usr/include/libmpeg3 -I/usr/X11R6/include"
149 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
150 # SDL core disabled (used directly, not through plugin - too many deps)
151 # MMX and SSE are detected at runtime, so it's safe to enable
152 %configure \
153         --disable-maintainer-mode \
154         --enable-shared \
155         --enable-static \
156         --disable-fast-install \
157         --disable-debug \
158         %{?_without_flash:--disable-flash} \
159         %{?_without_mpg:--disable-libmpeg3} \
160         --disable-avifile \
161         --disable-sdl \
162 %ifarch i586 i686 athlon
163         --enable-mmx \
164 %endif
165 %ifarch i686 athlon
166         --enable-sse
167 %endif
168
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 %{__make} DESTDIR=$RPM_BUILD_ROOT install
174
175 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
176 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/lib*.so.*.*
187 %dir %{dfbdir}
188 %dir %{dfbdir}/gfxdrivers
189 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.??
190 %dir %{dfbdir}/inputdrivers
191 %attr(755,root,root) %{dfbdir}/inputdrivers/*.??
192 %dir %{dfbdir}/interfaces
193 %dir %{dfbdir}/interfaces/IDirectFBFont
194 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.??
195 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
196 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.??
197 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.??
198 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
199 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.??
200 %{_datadir}/directfb-%{version}
201 %{_mandir}/man5/*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/directfb-config
206 %attr(755,root,root) %{_bindir}/directfb-csource
207 %{_includedir}/directfb
208 %{_includedir}/directfb-internal
209 %{_pkgconfigdir}/*
210 %{_libdir}/*.la
211 %{_libdir}/*.so
212 %{_mandir}/man1/directfb-csource.1*
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/lib*.a
217 %{dfbdir}/gfxdrivers/*.a
218 %{dfbdir}/inputdrivers/*.a
219 %{dfbdir}/interfaces/*/*.a
220
221 %files doc
222 %defattr(644,root,root,755)
223 %doc docs/html/*
224 %{_examplesdir}/%{name}-%{version}
225
226 %files font-ft2
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.??
229
230 %files image-jpeg
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.??
233
234 %files image-png
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.??
237
238 %if %{!?_without_mpg:1}%{?_without_mpg:0}
239 %files video-libmpeg3
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.??
242 %endif
243
244 %if %{!?_without_flash:1}%{?_without_flash:0}
245 %files video-swf
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.??
248 %endif
This page took 0.084795 seconds and 2 git commands to generate.