]> git.pld-linux.org Git - packages/DirectFB.git/blame - DirectFB.spec
- obsolete
[packages/DirectFB.git] / DirectFB.spec
CommitLineData
a86e3925 1#
e92bfe87
PS
2# TODO:
3# - fix x86-64 int32<->ptr64 casts.
4#
5# tree.c:88: warning: cast from pointer to integer of different size
6# tree.c:102: warning: cast from pointer to integer of different size
7# fonts.c:144: warning: cast to pointer from integer of different size
8# fonts.c:211: warning: cast to pointer from integer of different size
9# gfxcard.c:1451: warning: cast to pointer from integer of different size
10# fbdev.c:459: warning: cast from pointer to integer of different size
11# fbdev.c:578: warning: cast from pointer to integer of different size
12# fbdev.c:708: warning: cast from pointer to integer of different size
13# idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
14# idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
15# idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
16#
a86e3925 17# Conditional build:
8f1e72d3 18%bcond_with multi # build Multi-application core (requires working /dev/fusion*)
a86e3925 19#
7209bb84 20Summary: DirectFB - Hardware graphics acceleration
29dd91d0 21Summary(pl.UTF-8): DirectFB - Wspomaganie grafiki
b97730cd 22Name: DirectFB
b775b9bd
JB
23Version: 1.0.0
24Release: 1
75e7fed3 25Epoch: 1
dd531635 26License: LGPL v2+
c34d73d3 27Group: Libraries
3d874b33 28Source0: http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
b775b9bd 29# Source0-md5: ad746c49dc89ba6f99df71b17bbb1dc8
3d874b33 30Source1: http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
4474b793 31# Source1-md5: 13e443a64bddd68835b574045d9025e9
caa11f9b 32Patch0: %{name}-am.patch
c9a5c412 33Patch1: %{name}-pmake.patch
d9652db7 34Patch2: %{name}-fix.patch
b775b9bd
JB
35Patch3: %{name}-gcc4.patch
36Patch4: %{name}-llh-ppc.patch
37Patch5: %{name}-link.patch
7209bb84 38URL: http://www.directfb.org/
c61914f8 39BuildRequires: SDL-devel
134bb292 40BuildRequires: autoconf >= 2.52
7209bb84 41BuildRequires: automake
bb829f4a 42BuildRequires: freetype-devel >= 2.0.2
bb829f4a 43BuildRequires: libjpeg-devel >= 6b
b621b93e 44BuildRequires: libpng-devel >= 1.0
bb829f4a 45BuildRequires: libtool
1d67db3f 46BuildRequires: libvncserver-devel
b80e2d72 47%{?with_multi:BuildRequires: linux-fusion-devel >= 3.0}
d9652db7 48BuildRequires: sed >= 4.0
b737ab1d 49BuildRequires: sysfsutils-devel >= 1.3.0-3
b80e2d72 50BuildRequires: xorg-lib-libXext-devel
bb829f4a 51BuildRequires: zlib-devel >= 1.1.3
8e6b4a16 52%{?with_multi:Provides: DirectFB(multi)}
fa14e7e8 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
b97730cd 54
b775b9bd 55%define dfbdir %{_libdir}/directfb-1.0-0
b621b93e 56
e92bfe87
PS
57%define specflags -fno-strict-aliasing
58
1fc2240a
JB
59%ifarch %{ix86}
60# gcc running out of registers with -O0 in generic_mmx.h
61%define debugcflags -O1 -g
62%endif
63
b97730cd 64%description
7209bb84 65DirectFB hardware graphics acceleration - libraries.
b97730cd 66
50c27dbd 67%description -l pl.UTF-8
7209bb84 68Wspomaganie grafiki DirectFB - biblioteki.
b97730cd 69
340488a1 70%package devel
7209bb84 71Summary: DirectFB - development package
29dd91d0 72Summary(pl.UTF-8): DirectFB - pliki nagłówkowe
c34d73d3 73Group: Development/Libraries
d9652db7
JB
74Requires: %{name} = %{epoch}:%{version}-%{release}
75Requires: zlib-devel >= 1.1.3
055ea81c 76
340488a1 77%description devel
055ea81c 78DirectFB header files.
79
50c27dbd
JR
80%description devel -l pl.UTF-8
81Pliki nagłówkowe dla DirectFB.
340488a1 82
bb829f4a
JB
83%package static
84Summary: DirectFB static libraries
29dd91d0 85Summary(pl.UTF-8): Statyczne biblioteki DirectFB
bb829f4a 86Group: Development/Libraries
d9652db7 87Requires: %{name}-devel = %{epoch}:%{version}-%{release}
bb829f4a
JB
88
89%description static
90DirectFB static libraries.
91
50c27dbd 92%description static -l pl.UTF-8
bb829f4a
JB
93Statyczne biblioteki DirectFB.
94
340488a1 95%package doc
7209bb84 96Summary: DirectFB - documentation
29dd91d0 97Summary(pl.UTF-8): DirectFB - dokumentacja
f4c66141 98Group: Documentation
055ea81c 99
340488a1 100%description doc
bb829f4a
JB
101DirectFB documentation and tutorials.
102
50c27dbd 103%description doc -l pl.UTF-8
bb829f4a
JB
104Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
105
c61914f8
JB
106%package core-sdl
107Summary: SDL core system for DirectFB
29dd91d0 108Summary(pl.UTF-8): System SDL dla DirectFB
c61914f8 109Group: Libraries
d9652db7 110Requires: %{name} = %{epoch}:%{version}-%{release}
c61914f8
JB
111
112%description core-sdl
113This package contains SDL core system module for DirectFB.
114
50c27dbd
JR
115%description core-sdl -l pl.UTF-8
116Ten pakiet zawiera moduł systemu SDL dla DirectFB.
c61914f8 117
b737ab1d
JB
118%package core-vnc
119Summary: VNC core system for DirectFB
29dd91d0 120Summary(pl.UTF-8): System VNC dla DirectFB
b737ab1d
JB
121Group: Libraries
122Requires: %{name} = %{epoch}:%{version}-%{release}
123
124%description core-vnc
125This package contains VNC core system module for DirectFB.
126
50c27dbd
JR
127%description core-vnc -l pl.UTF-8
128Ten pakiet zawiera moduł systemu VNC dla DirectFB.
b737ab1d
JB
129
130%package core-x11
131Summary: X11 core system for DirectFB
29dd91d0 132Summary(pl.UTF-8): System X11 dla DirectFB
b737ab1d
JB
133Group: Libraries
134Requires: %{name} = %{epoch}:%{version}-%{release}
135
136%description core-x11
137This package contains X11 core system module for DirectFB.
138
50c27dbd
JR
139%description core-x11 -l pl.UTF-8
140Ten pakiet zawiera moduł systemu X11 dla DirectFB.
b737ab1d 141
b621b93e
JB
142%package font-ft2
143Summary: FreeType2 font provider for DirectFB
29dd91d0 144Summary(pl.UTF-8): DirectFB - wtyczka dostarczająca fonty poprzez FreeType2
b621b93e 145Group: Libraries
d9652db7 146Requires: %{name} = %{epoch}:%{version}-%{release}
b621b93e
JB
147
148%description font-ft2
149This package contains FreeType2 font provider for DirectFB.
150
50c27dbd
JR
151%description font-ft2 -l pl.UTF-8
152Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą fonty poprzez
153bibliotekę FreeType2.
b621b93e
JB
154
155%package image-jpeg
156Summary: JPEG image provider for DirectFB
29dd91d0 157Summary(pl.UTF-8): DirectFB - wtyczka dostarczająca grafikę JPEG
b621b93e 158Group: Libraries
d9652db7 159Requires: %{name} = %{epoch}:%{version}-%{release}
b621b93e
JB
160
161%description image-jpeg
162This package contains JPEG image provider for DirectFB.
163
50c27dbd
JR
164%description image-jpeg -l pl.UTF-8
165Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę JPEG.
b621b93e
JB
166
167%package image-png
168Summary: PNG image provider for DirectFB
29dd91d0 169Summary(pl.UTF-8): DirectFB - wtyczka dostarczająca grafikę PNG
b621b93e 170Group: Libraries
d9652db7 171Requires: %{name} = %{epoch}:%{version}-%{release}
b621b93e
JB
172
173%description image-png
174This package contains PNG image provider for DirectFB.
175
50c27dbd
JR
176%description image-png -l pl.UTF-8
177Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę PNG.
b621b93e 178
b775b9bd
JB
179%package input-dynapro
180Summary: Dynapro touchscreen input driver for DirectFB
181Summary(pl): Sterownik wejściowy do touchscreenów Dynapro dla DirectFB
182Group: Libraries
183Requires: %{name} = %{epoch}:%{version}-%{release}
184
185%description input-dynapro
186Dynapro touchscreen input driver for DirectFB.
187
188NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
189unless you don't have Dynapro device connected to this port. It can
190mess with other devices connected to this port (mouse, modem etc.).
191
192%description input-dynapro -l pl
193Sterownik wejściowy do touchscreenów Dynapro dla DirectFB.
194
195UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
196nie należy go instalować, jeśli urządzenie Dynapro nie jest podłączone
197do tego portu. Sterownik może utrudnić współpracę z innymi
198urządzeniami podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
199
639e9568
JB
200%package input-elo
201Summary: ELO touchscreen input driver for DirectFB
29dd91d0 202Summary(pl.UTF-8): Sterownik wejściowy do touchscreenów ELO dla DirectFB
639e9568
JB
203Group: Libraries
204Requires: %{name} = %{epoch}:%{version}-%{release}
205
206%description input-elo
207ELO touchscreen input driver for DirectFB.
208
209NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
b80e2d72
JB
210unless you have ELO device connected to this port. It can mess with
211other devices connected to this port (mouse, modem etc.).
639e9568 212
50c27dbd
JR
213%description input-elo -l pl.UTF-8
214Sterownik wejściowy do touchscreenów ELO dla DirectFB.
639e9568 215
50c27dbd
JR
216UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
217nie należy go instalować, jeśli urządzenie ELO nie jest podłączone do
218tego portu. Sterownik może utrudnić współpracę z innymi urządzeniami
219podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
639e9568 220
b775b9bd
JB
221%package input-gunze
222Summary: Gunze touchscreen input driver for DirectFB
223Summary(pl): Sterownik wejściowy do touchscreenów Gunze dla DirectFB
224Group: Libraries
225Requires: %{name} = %{epoch}:%{version}-%{release}
226
227%description input-gunze
228Gunze touchscreen input driver for DirectFB.
229
230NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
231unless you don't have Gunze device connected to this port. It can mess
232with other devices connected to this port (mouse, modem etc.).
233
234%description input-gunze -l pl
235Sterownik wejściowy do touchscreenów Gunze dla DirectFB.
236
237UWAGA: aktualnie używa zakodowanego na stałe portu /dev/ttyS0, więc
238nie należy go instalować, jeśli urządzenie Gunze nie jest podłączone
239do tego portu. Sterownik może utrudnić współpracę z innymi
240urządzeniami podłączonymi do /dev/ttyS0 (jak mysz, modem itp.).
241
639e9568
JB
242%package input-mutouch
243Summary: MuTouch touchscreen input driver for DirectFB
29dd91d0 244Summary(pl.UTF-8): Sterownik wejściowy do touchscreenów MuTouch dla DirectFB
639e9568
JB
245Group: Libraries
246Requires: %{name} = %{epoch}:%{version}-%{release}
247
248%description input-mutouch
249MuTouch touchscreen input driver for DirectFB.
250
b737ab1d 251NOTE: it needs "mut-device" setting in directfbrc in order to work.
639e9568 252
50c27dbd
JR
253%description input-mutouch -l pl.UTF-8
254Sterownik wejściowy do touchscreenów MuTouch dla DirectFB.
639e9568 255
50c27dbd 256UWAGA: do działania potrzebuje ustawienia "mut-device" w directfbrc.
639e9568 257
b775b9bd
JB
258%package input-ucb1x00
259Summary: UCB1x00 touchscreen input driver for DirectFB
260Summary(pl): Sterownik wejściowy do touchscreenów UCB1x00 dla DirectFB
261Group: Libraries
262Requires: %{name} = %{epoch}:%{version}-%{release}
263
264%description input-ucb1x00
265UCB1x00 touchscreen input driver for DirectFB.
266
267%description input-ucb1x00 -l pl
268Sterownik wejściowy do touchscreenów UCB1x00 dla DirectFB.
269
270%package input-wm97xx
271Summary: WM97xx touchscreen input driver for DirectFB
272Summary(pl): Sterownik wejściowy do touchscreenów WM97xx dla DirectFB
273Group: Libraries
274Requires: %{name} = %{epoch}:%{version}-%{release}
275
276%description input-wm97xx
277WM97xx touchscreen input driver for DirectFB.
278
279%description input-wm97xx -l pl
280Sterownik wejściowy do touchscreenów WM97xx dla DirectFB.
281
b97730cd 282%prep
bb829f4a 283%setup -q -a1
caa11f9b 284%patch0 -p1
6937d70e 285%patch1 -p1
d9652db7
JB
286%patch2 -p1
287%patch3 -p1
e92bfe87 288%patch4 -p1
63d32190 289%patch5 -p1
b97730cd 290
b97730cd 291%build
841e5017 292%{__libtoolize}
2206531f 293%{__aclocal}
4a64870b 294%{__autoconf}
bb829f4a 295%{__automake}
32d034f8 296# MMX and SSE are detected at runtime, so it's safe to enable
bb829f4a 297%configure \
d9652db7 298 %{!?debug:--disable-debug} \
055ea81c 299 --disable-maintainer-mode \
c61914f8 300 --enable-fast-install \
a86e3925 301 %{?with_multi:--enable-multi} \
c61914f8 302 --enable-sdl \
d9652db7
JB
303 --enable-shared \
304 --enable-static \
305 --enable-unique \
306 --enable-video4linux2 \
307 --enable-voodoo \
b737ab1d 308 --enable-x11 \
d9652db7 309 --enable-zlib \
e92bfe87 310%ifarch %{ix86} %{x8664}
98afd923 311%ifnarch i386 i486
32d034f8
JB
312 --enable-mmx \
313%endif
98afd923 314%ifnarch i386 i486 i586
b80e2d72 315 --enable-sse \
bb829f4a 316%endif
98afd923 317%endif
b775b9bd 318 --with-inputdrivers=dynapro,elo-input,gunze,joystick,keyboard,linuxinput,lirc,mutouch,penmount,ps2mouse,serialmouse,sonypijogdial,ucb1x00,wm97xx
303025bb 319
e92bfe87 320%{__make} \
b80e2d72
JB
321 X11_CFLAGS= \
322 X11_LIBS="-lX11 -lXext"
b97730cd 323
324%install
325rm -rf $RPM_BUILD_ROOT
b737ab1d 326install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_sysconfdir}}
c4ab922f
PG
327
328%{__make} install \
329 DESTDIR=$RPM_BUILD_ROOT
330
bb829f4a
JB
331cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
332
cc3bbc38 333touch $RPM_BUILD_ROOT%{_sysconfdir}/directfbrc
b737ab1d 334
7209bb84
JB
335%clean
336rm -rf $RPM_BUILD_ROOT
337
bb829f4a
JB
338%post -p /sbin/ldconfig
339%postun -p /sbin/ldconfig
b97730cd 340
b97730cd 341%files
303025bb 342%defattr(644,root,root,755)
0a93b064 343%doc AUTHORS ChangeLog NEWS README TODO
a86e3925
JB
344%attr(755,root,root) %{_bindir}/dfbdump
345%attr(755,root,root) %{_bindir}/dfbg
ac9e29cd 346%attr(755,root,root) %{_bindir}/dfbinfo
b80e2d72 347%attr(755,root,root) %{_bindir}/dfbinput
d9652db7 348%attr(755,root,root) %{_bindir}/dfblayer
b80e2d72 349%attr(755,root,root) %{_bindir}/dfbpenmount
d9652db7
JB
350%attr(755,root,root) %{_bindir}/dfbproxy
351%attr(755,root,root) %{_bindir}/dfbscreen
352%attr(755,root,root) %{_bindir}/dfbsummon
b775b9bd
JB
353%attr(755,root,root) %{_bindir}/mkdfiff
354%attr(755,root,root) %{_bindir}/mkdgiff
d9652db7
JB
355%attr(755,root,root) %{_bindir}/uwmdump
356%attr(755,root,root) %{_libdir}/libdirect-*.so.*.*.*
357%attr(755,root,root) %{_libdir}/libdirectfb-*.so.*.*.*
358%attr(755,root,root) %{_libdir}/libfusion-*.so.*.*.*
359%attr(755,root,root) %{_libdir}/libuniquewm-*.so.*.*.*
360%attr(755,root,root) %{_libdir}/libvoodoo-*.so.*.*.*
b621b93e
JB
361%dir %{dfbdir}
362%dir %{dfbdir}/gfxdrivers
41033e4b 363%attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
b621b93e 364%dir %{dfbdir}/inputdrivers
c61914f8
JB
365%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
366%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
d9652db7 367%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_linux_input.so
c61914f8 368%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
b775b9bd 369%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_penmount.so
c61914f8
JB
370%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
371%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
372%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
b621b93e 373%dir %{dfbdir}/interfaces
d9652db7
JB
374%dir %{dfbdir}/interfaces/IDirectFB
375%attr(755,root,root) %{dfbdir}/interfaces/IDirectFB/lib*.so
376%dir %{dfbdir}/interfaces/IDirectFBDataBuffer
377%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDataBuffer/lib*.so
378%dir %{dfbdir}/interfaces/IDirectFBDisplayLayer
379%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDisplayLayer/lib*.so
380%dir %{dfbdir}/interfaces/IDirectFBEventBuffer
381%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBEventBuffer/lib*.so
b621b93e 382%dir %{dfbdir}/interfaces/IDirectFBFont
41033e4b 383%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
b775b9bd 384%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dgiff.so
d9652db7
JB
385%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dispatcher.so
386%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_requestor.so
b621b93e 387%dir %{dfbdir}/interfaces/IDirectFBImageProvider
b775b9bd 388%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.so
d9652db7 389%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dispatcher.so
41033e4b 390%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
41033e4b 391%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
d9652db7
JB
392%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_requestor.so
393%dir %{dfbdir}/interfaces/IDirectFBInputDevice
394%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBInputDevice/lib*.so
395%dir %{dfbdir}/interfaces/IDirectFBPalette
396%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBPalette/lib*.so
397%dir %{dfbdir}/interfaces/IDirectFBScreen
398%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBScreen/lib*.so
399%dir %{dfbdir}/interfaces/IDirectFBSurface
400%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBSurface/lib*.so
b621b93e 401%dir %{dfbdir}/interfaces/IDirectFBVideoProvider
b775b9bd 402%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.so
41033e4b 403%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
d9652db7
JB
404%dir %{dfbdir}/interfaces/IDirectFBWindow
405%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBWindow/lib*.so
8457d9fb 406%dir %{dfbdir}/systems
407%attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
d9652db7
JB
408%dir %{dfbdir}/wm
409%attr(755,root,root) %{dfbdir}/wm/*.so
b775b9bd 410%{_datadir}/directfb-%{version}
b737ab1d 411%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/directfbrc
a86e3925 412%{_mandir}/man1/dfbg.1*
bb829f4a 413%{_mandir}/man5/*
340488a1 414
415%files devel
303025bb 416%defattr(644,root,root,755)
4996377e 417%attr(755,root,root) %{_bindir}/directfb-config
e9f43c92 418%attr(755,root,root) %{_bindir}/directfb-csource
d9652db7
JB
419%attr(755,root,root) %{_libdir}/libdirect.so
420%attr(755,root,root) %{_libdir}/libdirectfb.so
421%attr(755,root,root) %{_libdir}/libfusion.so
422%attr(755,root,root) %{_libdir}/libuniquewm.so
423%attr(755,root,root) %{_libdir}/libvoodoo.so
424%{_libdir}/libdirect.la
425%{_libdir}/libdirectfb.la
426%{_libdir}/libfusion.la
427%{_libdir}/libuniquewm.la
428%{_libdir}/libvoodoo.la
bb829f4a 429%{_includedir}/directfb
7b3020ed 430%{_includedir}/directfb-internal
d9652db7 431%{_pkgconfigdir}/*.pc
e9f43c92 432%{_mandir}/man1/directfb-csource.1*
055ea81c 433
bb829f4a
JB
434%files static
435%defattr(644,root,root,755)
436%{_libdir}/lib*.a
e9c71960
JB
437%{dfbdir}/gfxdrivers/*.[alo]*
438%{dfbdir}/inputdrivers/*.[alo]*
439%{dfbdir}/interfaces/*/*.[alo]*
440%{dfbdir}/systems/*.[alo]*
441%{dfbdir}/wm/*.[alo]*
bb829f4a 442
340488a1 443%files doc
303025bb 444%defattr(644,root,root,755)
201f3399 445%doc docs/html/*.{html,png}
bb829f4a
JB
446%{_examplesdir}/%{name}-%{version}
447
c61914f8
JB
448%files core-sdl
449%defattr(644,root,root,755)
450%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
451%attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
452
b737ab1d
JB
453%files core-vnc
454%defattr(644,root,root,755)
455%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_vncinput.so
456%attr(755,root,root) %{dfbdir}/systems/libdirectfb_vnc.so
457
458%files core-x11
459%defattr(644,root,root,755)
460%doc systems/x11/README
461%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_x11input.so
462%attr(755,root,root) %{dfbdir}/systems/libdirectfb_x11.so
463
b621b93e
JB
464%files font-ft2
465%defattr(644,root,root,755)
41033e4b 466%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
b621b93e
JB
467
468%files image-jpeg
469%defattr(644,root,root,755)
41033e4b 470%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
b621b93e
JB
471
472%files image-png
473%defattr(644,root,root,755)
41033e4b 474%attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
639e9568 475
b775b9bd
JB
476%files input-dynapro
477%defattr(644,root,root,755)
478%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_dynapro.so
479
639e9568
JB
480%files input-elo
481%defattr(644,root,root,755)
482%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_elo.so
483
b775b9bd
JB
484%files input-gunze
485%defattr(644,root,root,755)
486%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_gunze.so
487
639e9568
JB
488%files input-mutouch
489%defattr(644,root,root,755)
490%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_mutouch.so
b775b9bd
JB
491
492%files input-ucb1x00
493%defattr(644,root,root,755)
494%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ucb1x00_ts.so
495
496%files input-wm97xx
497%defattr(644,root,root,755)
498%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_wm97xx_ts.so
This page took 0.138614 seconds and 4 git commands to generate.