]> git.pld-linux.org Git - packages/DirectFB-extra.git/blob - DirectFB-extra.spec
b86765741f148b3bf03d576af704a942e244debf
[packages/DirectFB-extra.git] / DirectFB-extra.spec
1 #
2 # Conditional build:
3 %bcond_without  flash   # don't build FLASH video provider
4 %bcond_without  mpg     # don't build support for MPG/MPEG3
5 %bcond_without  swfdec  # don't build swfdec video provider
6 #
7 # broken currently (needs update for DirectFB 1.2.x)
8 %undefine       with_flash
9 # needs update for swfdec 0.6.x
10 %undefine       with_swfdec
11 Summary:        Additional providers and drivers for DirectFB
12 Summary(pl.UTF-8):      DirectFB - dodatkowe wtyczki i sterowniki do DirectFB
13 Name:           DirectFB-extra
14 Version:        1.2.0
15 %define subver  rc1
16 Release:        0.%{subver}.0.1
17 License:        LGPL v2+
18 Group:          Libraries
19 Source0:        http://www.directfb.org/downloads/Extras/%{name}-%{version}-%{subver}.tar.gz
20 # Source0-md5:  c3c160c167c20f320b0c0562168d0579
21 Patch0:         %{name}-acfix.patch
22 Patch1:         %{name}-mpeg3_open.patch
23 URL:            http://www.directfb.org/
24 BuildRequires:  DirectFB-devel >= 1:%{version}
25 BuildRequires:  FusionSound-devel >= 1.1.0
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake
28 BuildRequires:  ffmpeg-devel
29 %{?with_flash:BuildRequires:    gplflash-devel >= 0.4.10-5}
30 BuildRequires:  imlib2-devel
31 BuildRequires:  jasper-devel
32 %{?with_mpg:BuildRequires:      libmpeg3-devel}
33 BuildRequires:  libsvg-cairo-devel >= 0.1.6
34 BuildRequires:  libtool
35 BuildRequires:  openquicktime-devel
36 BuildRequires:  pkgconfig >= 1:0.9
37 %{?with_swfdec:BuildRequires:   swfdec-devel >= 0.5.0}
38 BuildRequires:  xine-lib-devel >= 2:1.0.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         dfbdir          %(pkg-config --variable=moduledir directfb-internal)
42
43 %description
44 This package contains additional image/video/font providers and
45 graphics/input drivers (currently Imlib2 image provider and
46 OpenQuicktime video provider).
47
48 %description -l pl.UTF-8
49 Ten pakiet zawiera dodatkowe wtyczki dostarczające grafikę, obraz i
50 fonty oraz sterowniki grafiki i wejściowe (aktualnie: wtyczkę
51 dostarczającą grafikę poprzez Imlib2 oraz wtyczkę dostarczającą obraz
52 OpenQuicktime).
53
54 %package -n DirectFB-image-bmp
55 Summary:        BMP image provider for DirectFB
56 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę BMP
57 Group:          Libraries
58 %requires_eq    DirectFB
59
60 %description -n DirectFB-image-bmp
61 This package contains BMP mage provider for DirectFB.
62
63 %description -n DirectFB-image-bmp -l pl.UTF-8
64 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę BMP.
65
66 %package -n DirectFB-image-imlib2
67 Summary:        Imlib2 image provider for DirectFB
68 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę poprzez Imlib2
69 Group:          Libraries
70 %requires_eq    DirectFB
71
72 %description -n DirectFB-image-imlib2
73 This package contains image provider based on Imlib2 for DirectFB.
74
75 %description -n DirectFB-image-imlib2 -l pl.UTF-8
76 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę poprzez
77 bibliotekę Imlib2.
78
79 %package -n DirectFB-image-jpeg2000
80 Summary:        JPEG-2000 image provider for DirectFB
81 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę JPEG-2000
82 Group:          Libraries
83 %requires_eq    DirectFB
84
85 %description -n DirectFB-image-jpeg2000
86 This package contains JPEG-2000 image provider.
87
88 %description -n DirectFB-image-jpeg2000 -l pl.UTF-8
89 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę
90 JPEG-2000.
91
92 %package -n DirectFB-image-mpeg2
93 Summary:        MPEG-2 image provider for DirectFB
94 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę MPEG-2
95 Group:          Libraries
96 %requires_eq    DirectFB
97
98 %description -n DirectFB-image-mpeg2
99 This package contains MPEG-2 image provider.
100
101 %description -n DirectFB-image-mpeg2 -l pl.UTF-8
102 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę MPEG-2.
103
104 %package -n DirectFB-image-pnm
105 Summary:        PNM image provider for DirectFB
106 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę PNM
107 Group:          Libraries
108 %requires_eq    DirectFB
109
110 %description -n DirectFB-image-pnm
111 This package contains PNM image provider. It supports PBM, PGM and PPM
112 formats (both ASCII and RAW).
113
114 %description -n DirectFB-image-pnm -l pl.UTF-8
115 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę PNM.
116 Obsługuje formaty PBM, PGM i PPM (zarówno ASCII, jak i binarne).
117
118 %package -n DirectFB-image-svg
119 Summary:        SVG image provider for DirectFB
120 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca grafikę SVG
121 Group:          Libraries
122 %requires_eq    DirectFB
123
124 %description -n DirectFB-image-svg
125 This package contains SVG image provider using Cairo library.
126
127 %description -n DirectFB-image-svg -l pl.UTF-8
128 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą grafikę SVG przy
129 użyciu biblioteki Cairo.
130
131 %package -n DirectFB-video-ffmpeg
132 Summary:        FFmpeg video provider for DirectFB
133 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz FFmpeg
134 Group:          Libraries
135 %requires_eq    DirectFB
136 %requires_eq    FusionSound
137
138 %description -n DirectFB-video-ffmpeg
139 DirectFB video provider using FFmpeg codecs.
140
141 %description -n DirectFB-video-ffmpeg -l pl.UTF-8
142 Ten pakiet zawiera wtyczkę dla DirectFB dostarczajacą obraz przy
143 użyciu kodeków FFmpeg.
144
145 %package -n DirectFB-video-libmpeg3
146 Summary:        MPEG video provider for DirectFB
147 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz MPEG
148 Group:          Libraries
149 %requires_eq    DirectFB
150
151 %description -n DirectFB-video-libmpeg3
152 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
153 DirectFB. It uses libmpeg3 library.
154
155 %description -n DirectFB-video-libmpeg3 -l pl.UTF-8
156 Ten pakiet zawiera wtyczkę dla DirectFB dostarczajacą obraz MPEG
157 (MPEG-1 i MPEG-2) przy użyciu biblioteki libmpeg3.
158
159 %package -n DirectFB-video-openquicktime
160 Summary:        OpenQuicktime video provider for DirectFB
161 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz OpenQuicktime
162 Group:          Libraries
163 %requires_eq    DirectFB
164
165 %description -n DirectFB-video-openquicktime
166 This package contains OpenQuicktime video provider for DirectFB. It
167 supports all RGB and YUV formats and does audio playback.
168
169 %description -n DirectFB-video-openquicktime -l pl.UTF-8
170 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą obraz
171 OpenQuicktime. Obsługuje wszystkie formaty RGB i YUV oraz odtwarza
172 dźwięk.
173
174 %package -n DirectFB-video-swf
175 Summary:        ShockWave Flash video provider for DirectFB
176 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz ShockWave Flash
177 Group:          Libraries
178 %requires_eq    DirectFB
179
180 %description -n DirectFB-video-swf
181 This package contains SWF (ShockWave Flash) video provider for
182 DirectFB. It uses flash library.
183
184 %description -n DirectFB-video-swf -l pl.UTF-8
185 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą obraz SWF
186 (ShockWave Flash) przy użyciu biblioteki flash.
187
188 %package -n DirectFB-video-swfdec
189 Summary:        ShockWave Flash video provider for DirectFB
190 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz ShockWave Flash
191 Group:          Libraries
192 %requires_eq    DirectFB
193
194 %description -n DirectFB-video-swfdec
195 This package contains SWF (ShockWave Flash) video provider for
196 DirectFB. It uses swfdec library.
197
198 %description -n DirectFB-video-swfdec -l pl.UTF-8
199 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą obraz SWF
200 (ShockWave Flash) przy użyciu biblioteki swfdec.
201
202 %package -n DirectFB-video-xine
203 Summary:        XINE video provider for DirectFB
204 Summary(pl.UTF-8):      DirectFB - wtyczka dostarczająca obraz XINE
205 Group:          Libraries
206 %requires_eq    DirectFB
207 %requires_eq    xine-lib
208
209 %description -n DirectFB-video-xine
210 This package contains video provider for DirectFB which uses XINE
211 library and plugins. It handles a wide range of video formats.
212
213 %description -n DirectFB-video-xine -l pl.UTF-8
214 Ten pakiet zawiera wtyczkę dla DirectFB dostarczającą obraz przy
215 użyciu biblioteki i wtyczek XINE. Obsługuje szeroki zakres formatów
216 obrazu.
217
218 %package -n xine-ui-dfb
219 Summary:        DirectFB-based XINE UI
220 Summary(pl.UTF-8):      Interfejs użytkownika XINE oparty na DirectFB
221 Group:          Applications/Multimedia
222 %requires_eq    DirectFB
223 Requires:       xine-lib >= 2:1.0-0.rc3
224
225 %description -n xine-ui-dfb
226 DirectFB-based XINE UI. This package contains also DirectFB video
227 output plugin for XINE.
228
229 %description -n xine-ui-dfb -l pl.UTF-8
230 Interfejs użytkownika XINE oparty na DirectFB. Zawiera także wtyczkę
231 wyjścia obrazu DirectFB dla XINE.
232
233 %prep
234 %setup -q -n %{name}-%{version}-%{subver}
235 %patch0 -p1
236 %patch1 -p1
237
238 %build
239 %{__libtoolize}
240 %{__aclocal}
241 %{__autoconf}
242 %{__autoheader}
243 %{__automake}
244 CPPFLAGS="-I/usr/include/libmpeg3"
245 %configure \
246         --disable-avifile \
247         %{?with_flash:--enable-flash} \
248         %{?with_mpg:--enable-libmpeg3} \
249         --enable-openquicktime \
250         %{!?with_swfdec:--disable-swfdec}
251
252 %{__make} \
253         FFMPEG_CFLAGS="-I/usr/include/libavcodec -I/usr/include/libavformat" \
254         MODULEDIR=%{dfbdir}
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT \
261         MODULEDIR=%{dfbdir}
262
263 rm -f $RPM_BUILD_ROOT%{dfbdir}/interfaces/*/*.la \
264         $RPM_BUILD_ROOT%{_libdir}/xine/plugins/*/*.la
265
266 %clean
267 rm -rf $RPM_BUILD_ROOT
268
269 %files -n DirectFB-image-bmp
270 %defattr(644,root,root,755)
271 %doc ChangeLog README
272 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_bmp.so
273
274 %files -n DirectFB-image-imlib2
275 %defattr(644,root,root,755)
276 %doc ChangeLog README
277 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_imlib2.so
278
279 %files -n DirectFB-image-jpeg2000
280 %defattr(644,root,root,755)
281 %doc ChangeLog README
282 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg2000.so
283
284 %files -n DirectFB-image-mpeg2
285 %defattr(644,root,root,755)
286 %doc ChangeLog README
287 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
288
289 %files -n DirectFB-image-pnm
290 %defattr(644,root,root,755)
291 %doc ChangeLog README
292 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_pnm.so
293
294 %files -n DirectFB-image-svg
295 %defattr(644,root,root,755)
296 %doc ChangeLog README
297 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_svg.so
298
299 %files -n DirectFB-video-ffmpeg
300 %defattr(644,root,root,755)
301 %doc ChangeLog README
302 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_ffmpeg.so
303
304 %if %{with mpg}
305 %files -n DirectFB-video-libmpeg3
306 %defattr(644,root,root,755)
307 %doc ChangeLog README
308 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
309 %endif
310
311 %files -n DirectFB-video-openquicktime
312 %defattr(644,root,root,755)
313 %doc ChangeLog README
314 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_openquicktime.so
315
316 %if %{with flash}
317 %files -n DirectFB-video-swf
318 %defattr(644,root,root,755)
319 %doc ChangeLog README
320 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swf.so
321 %endif
322
323 %if %{with swfdec}
324 %files -n DirectFB-video-swfdec
325 %defattr(644,root,root,755)
326 %doc ChangeLog README
327 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_swfdec.so
328 %endif
329
330 %files -n DirectFB-video-xine
331 %defattr(644,root,root,755)
332 %doc ChangeLog README
333 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_xine.so
334
335 %files -n xine-ui-dfb
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_bindir}/df_xine
338 %attr(755,root,root) %{_libdir}/xine/plugins/*/xineplug_vo_out_dfb.so
This page took 0.127259 seconds and 2 git commands to generate.