]> git.pld-linux.org Git - packages/DevIL.git/blob - DevIL.spec
- release 16 (by relup.sh)
[packages/DevIL.git] / DevIL.spec
1 #
2 # Conditional build:
3 %bcond_with     sse     # use SSE extension
4 %bcond_with     sse2    # use SSE2 extension
5 %bcond_with     sse3    # use SSE3 extension
6 #
7 %ifarch pentium3 pentium4 %{x8664}
8 %define with_sse        1
9 %endif
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 %define         manual_version  1.5.5
14 Summary:        Full featured image library
15 Summary(pl.UTF-8):      Biblioteka obsługi obrazów z mnóstwem funkcji
16 Name:           DevIL
17 Version:        1.7.8
18 Release:        16
19 License:        LGPL v2.1
20 Group:          Libraries
21 Source0:        http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
22 # Source0-md5:  7918f215524589435e5ec2e8736d5e1d
23 Source1:        http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
24 # Source1-md5:  6bb2ddfcbe09930c48ef84b8f99479fe
25 Source2:        http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
26 # Source2-md5:  eec6ae7a028a3f058bab1a6918428ed5
27 Patch0:         libpng14.patch
28 Patch1:         %{name}-squish.patch
29 Patch2:         %{name}-as-needed.patch
30 Patch3:         gcc5.patch
31 URL:            http://openil.sourceforge.net/
32 BuildRequires:  OpenEXR-devel
33 BuildRequires:  OpenGL-GLU-devel
34 BuildRequires:  SDL-devel >= 1.2.5
35 BuildRequires:  allegro-devel >= 4.1.16
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 BuildRequires:  jasper-devel
39 BuildRequires:  lcms-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libmng-devel
42 BuildRequires:  libpng-devel
43 BuildRequires:  libtiff-devel
44 BuildRequires:  libtool >= 2:1.5
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.533
47 BuildRequires:  squish-devel
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  unzip
50 BuildRequires:  xorg-lib-libXext-devel
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
54
55 %description
56 Developer's Image Library (DevIL) is a programmer's library to develop
57 applications with very powerful image loading capabilities, yet is
58 easy for a developer to learn and use. Ultimate control of images is
59 left to the developer, so unnecessary conversions, etc. are not
60 performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
61 load, save, convert, manipulate, filter and display a wide variety of
62 image formats.
63
64 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
65 .jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
66 .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
67
68 Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
69 .pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
70
71 %description -l pl.UTF-8
72 Developer's Image Library (DevIL) jest biblioteką programisty
73 pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
74 obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
75 Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
76 wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
77 potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
78 ładować, zapisywać, konwertować, manipulować, filtrować szeroki
79 wachlarz formatów plików graficznych.
80
81 W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
82 doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
83 pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
84
85 Obsługiwane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm,
86 pcx, pgm, png, ppm, raw, sgi, tga i tif.
87
88 %package devel
89 Summary:        DevIL development files
90 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DevIL
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       OpenEXR-devel
94 Requires:       jasper-devel
95 Requires:       lcms-devel
96 Requires:       libjpeg-devel
97 Requires:       libmng-devel
98 Requires:       libpng-devel
99 Requires:       libtiff-devel
100 Requires:       squish-devel
101
102 %description devel
103 DevIL development files (for IL and ILU libraries).
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe bibliotek DevIL (IL i ILU).
107
108 %package static
109 Summary:        Static DevIL libraries
110 Summary(pl.UTF-8):      Statyczne biblioteki DevIL
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static DevIL libraries (IL and ILU).
116
117 %description static -l pl.UTF-8
118 Statyczne biblioteki DevIL (IL i ILU).
119
120 %package ILUT
121 Summary:        DevIL ILUT library
122 Summary(pl.UTF-8):      Biblioteka DevIL ILUT
123 Group:          Libraries
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       SDL >= 1.2.5
126 Requires:       allegro >= 4.1.16
127
128 %description ILUT
129 DevIL ILUT library - connection to higher level libraries.
130
131 %description ILUT -l pl.UTF-8
132 Biblioteka DevIL ILUT - łącznik z bibliotekami wyższego poziomu.
133
134 %package ILUT-devel
135 Summary:        Development files for DevIL ILUT library
136 Summary(pl.UTF-8):      Pliki programistyczne biblioteki DevIL ILUT
137 Group:          Development/Libraries
138 Requires:       %{name}-ILUT = %{version}-%{release}
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       OpenGL-GLU-devel
141 Requires:       SDL-devel >= 1.2.5
142 Requires:       allegro-devel >= 4.1.16
143 Requires:       xorg-lib-libXext-devel
144
145 %description ILUT-devel
146 Development files for DevIL ILUT library.
147
148 %description ILUT-devel -l pl.UTF-8
149 Pliki programistyczne biblioteki DevIL ILUT.
150
151 %package ILUT-static
152 Summary:        Static DevIL ILUT library
153 Summary(pl.UTF-8):      Statyczna biblioteka DevIL ILUT
154 Group:          Development/Libraries
155 Requires:       %{name}-ILUT-devel = %{version}-%{release}
156
157 %description ILUT-static
158 Static DevIL ILUT library.
159
160 %description ILUT-static -l pl.UTF-8
161 Statyczna biblioteka DevIL ILUT.
162
163 %package doc
164 Summary:        DevIL documentation
165 Summary(pl.UTF-8):      Dokumentacja DevIL
166 Group:          Documentation
167
168 %description doc
169 DevIL documentation.
170
171 %description doc -l pl.UTF-8
172 Dokumentacja DevIL.
173
174 %prep
175 %setup -q -c -a1 -a2
176 %patch0 -p1
177 %patch1 -p1
178 %patch2 -p1
179 %patch3 -p1
180
181 %build
182 cd devil-%{version}
183 %{__libtoolize}
184 %{__aclocal} -I m4
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188 %configure \
189         --enable-ILU \
190         --enable-ILUT \
191         %{?debug:--disable-release} \
192         %{!?with_sse:--disable-sse} \
193         %{!?with_sse2:--disable-sse2} \
194         %{!?with_sse3:--disable-sse3}
195 %{__make}
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199
200 %{__make} -C devil-%{version} install \
201         DESTDIR=$RPM_BUILD_ROOT
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %post   devel -p /sbin/postshell
210 -/usr/sbin/fix-info-dir -c %{_infodir}
211
212 %postun devel -p /sbin/postshell
213 -/usr/sbin/fix-info-dir -c %{_infodir}
214
215 %files
216 %defattr(644,root,root,755)
217 %doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
218 %attr(755,root,root) %{_bindir}/ilur
219 %attr(755,root,root) %{_libdir}/libIL.so.*.*.*
220 %attr(755,root,root) %ghost %{_libdir}/libIL.so.1
221 %attr(755,root,root) %{_libdir}/libILU.so.*.*.*
222 %attr(755,root,root) %ghost %{_libdir}/libILU.so.1
223
224 %files devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libIL.so
227 %attr(755,root,root) %{_libdir}/libILU.so
228 %{_libdir}/libIL.la
229 %{_libdir}/libILU.la
230 %dir %{_includedir}/IL
231 %{_includedir}/IL/il.h
232 %{_includedir}/IL/ilu.h
233 %{_includedir}/IL/ilu_region.h
234 %{_pkgconfigdir}/IL.pc
235 %{_pkgconfigdir}/ILU.pc
236 %{_infodir}/DevIL_manual.info*
237
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/libIL.a
241 %{_libdir}/libILU.a
242
243 %files ILUT
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
246 %attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
247
248 %files ILUT-devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libILUT.so
251 %{_includedir}/IL/devil_cpp_wrapper.hpp
252 %{_includedir}/IL/ilut.h
253 %{_libdir}/libILUT.la
254 %{_pkgconfigdir}/ILUT.pc
255
256 %files ILUT-static
257 %defattr(644,root,root,755)
258 %{_libdir}/libILUT.a
259
260 %files doc
261 %defattr(644,root,root,755)
262 %doc DevIL*.pdf
This page took 0.063585 seconds and 3 git commands to generate.