]> git.pld-linux.org Git - packages/DJabberd.git/blob - DJabberd.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/DJabberd.git] / DJabberd.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DJabberd
6 Summary:        DJabberd - scalable, extensible Jabber/XMPP server
7 Summary(pl.UTF-8):      DJabberd - skalowalny, rozszerzalny serwer Jabbera/XMPP
8 Name:           DJabberd
9 Version:        0.83
10 Release:        0.4
11 # same as perl 
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  ce449b6ef429eb65ec03be4c8d19b1aa
16 Source1:        djabberd.conf
17 Source2:        djabberd-log.conf
18 URL:            http://search.cpan.org/dist/DJabberd/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Danga-Socke) >= 1.51
23 BuildRequires:  perl(Digest::HMAC_SHA1)
24 BuildRequires:  perl-Log-Log4perl
25 BuildRequires:  perl-Net-DNS >= 0.48
26 BuildRequires:  perl-Net-SSLeay
27 BuildRequires:  perl-XML-LibXML-SAX
28 BuildRequires:  perl-XML-SAX
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # this is mentioned in example component
34 %define         _noautoreq      'perl(DJabberd::Bot::Eliza)'
35
36 %description
37 DJabberd was the answer to LiveJournal's Jabber (XMPP) server needs.
38 It's a Jabber server where almost everything defers to hooks to be
39 implemented by plugins. It does the core spec itself (including SSL,
40 StartTLS, server-to-server, etc), but it doesn't come with any way to
41 do authentication or storage or rosters, etc. You'll need to go pick
42 up a plugin to do those.
43
44 %description -l pl.UTF-8
45 DJabberd to odpowiedź na potrzeby odnośnie serwera Jabbera (XMPP) dla
46 serwisu LiveJournal. Jest to serwer Jabbera, w którym prawie wszystko
47 jest przekazywane do uchwytów implementowanych przez wtyczki. Sam
48 serwer wykonuje podstawowe zadania (wraz z SSL, StartTLS, komunikacją
49 serwer-serwer), ale nie zawiera niczego do uwierzytelniania,
50 przechowywania danych czy rosterów - do wszystkiego trzeba dodać
51 wtyczkę.
52
53 %prep
54 %setup -q -n %{pdir}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT%{_sysconfdir}/djabberd
70 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/djabberd
71 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/djabberd/log.conf
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES
79 %attr(755,root,root) %{_bindir}/djabberd
80 %{perl_vendorlib}/DJabberd.pm
81 %{perl_vendorlib}/DJabberd
82 %dir %{_sysconfdir}/djabberd
83 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/djabberd/djabberd.conf
84 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/djabberd/log.conf
85 %{_mandir}/man3/*
This page took 0.027274 seconds and 3 git commands to generate.