]> git.pld-linux.org Git - packages/DJabberd.git/blob - DJabberd.spec
- df fix
[packages/DJabberd.git] / DJabberd.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DJabberd
7 Summary:        DJabberd - scalable, extensible Jabber/XMPP server
8 Summary(pl.UTF-8):      DJabberd - skalowalny, rozszerzalny serwer Jabbera/XMPP
9 Name:           DJabberd
10 Version:        0.83
11 Release:        0.4
12 # same as perl 
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DJabberd/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  ce449b6ef429eb65ec03be4c8d19b1aa
17 Source1:        djabberd.conf
18 Source2:        djabberd-log.conf
19 URL:            http://search.cpan.org/dist/DJabberd/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Danga-Socke) >= 1.51
24 BuildRequires:  perl(Digest::HMAC_SHA1)
25 BuildRequires:  perl-Log-Log4perl
26 BuildRequires:  perl-Net-DNS >= 0.48
27 BuildRequires:  perl-Net-SSLeay
28 BuildRequires:  perl-XML-LibXML-SAX
29 BuildRequires:  perl-XML-SAX
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # this is mentioned in example component
35 %define         _noautoreq      'perl(DJabberd::Bot::Eliza)'
36
37 %description
38 DJabberd was the answer to LiveJournal's Jabber (XMPP) server needs.
39 It's a Jabber server where almost everything defers to hooks to be
40 implemented by plugins. It does the core spec itself (including SSL,
41 StartTLS, server-to-server, etc), but it doesn't come with any way to
42 do authentication or storage or rosters, etc. You'll need to go pick
43 up a plugin to do those.
44
45 %description -l pl.UTF-8
46 DJabberd to odpowiedź na potrzeby odnośnie serwera Jabbera (XMPP) dla
47 serwisu LiveJournal. Jest to serwer Jabbera, w którym prawie wszystko
48 jest przekazywane do uchwytów implementowanych przez wtyczki. Sam
49 serwer wykonuje podstawowe zadania (wraz z SSL, StartTLS, komunikacją
50 serwer-serwer), ale nie zawiera niczego do uwierzytelniania,
51 przechowywania danych czy rosterów - do wszystkiego trzeba dodać
52 wtyczkę.
53
54 %prep
55 %setup -q -n %{pdir}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_sysconfdir}/djabberd
71 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/djabberd
72 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/djabberd/log.conf
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc CHANGES
80 %attr(755,root,root) %{_bindir}/djabberd
81 %{perl_vendorlib}/DJabberd.pm
82 %{perl_vendorlib}/DJabberd
83 %dir %{_sysconfdir}/djabberd
84 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/djabberd/djabberd.conf
85 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/djabberd/log.conf
86 %{_mandir}/man3/*
This page took 0.062674 seconds and 3 git commands to generate.