]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
- strict internal deps, BR: automake
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.20
5 Release:        2
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/DirectFB/%{name}-%{version}.tar.gz
9 # Source0-md5:  52a382bede1ef6ba041e0be8d73ff0a9
10 URL:            http://www.directfb.org/
11 BuildRequires:  DirectFB-devel >= %{version}
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  pkgconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
20 advantage is that the 'thiz' doesn't need to be passed as the first
21 argument of every interface function. Another feature is the usage of
22 exceptions. It's annoying having these error checking stuff with
23 growing deinitialization stacks. Most functions are 'void'. As soon as
24 a DirectFB function returns an error a DFBException is thrown.
25
26 %description -l pl
27 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
28 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
29 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
30 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym stosem
31 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
32 zwraca b³±d, rzucany jest wyj±tek DFBException.
33
34 %package devel
35 Summary:        DFB++ header files
36 Summary(pl):    Pliki nag³ówkowe DFB++
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for DFB++ library.
42
43 %description devel -l pl
44 Pliki nag³ówkowe biblioteki DFB++.
45
46 %package static
47 Summary:        DFB++ static library
48 Summary(pl):    Statyczna biblioteka DFB++
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 DFB++ static library.
54
55 %description static -l pl
56 Statyczna biblioteka DFB++.
57
58 %prep
59 %setup -q
60
61 %build
62 cp -f /usr/share/automake/config.sub .
63 %{__autoconf}
64 %configure \
65         --enable-static
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS ChangeLog README
86 %attr(755,root,root) %{_bindir}/dfbshow
87 %attr(755,root,root) %{_bindir}/dfbswitch
88 %attr(755,root,root) %{_libdir}/lib*.so.*.*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/dfb++-config
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %{_libdir}/lib*.la
95 %{_includedir}/dfb++
96 %{_pkgconfigdir}/*.pc
97 %{_examplesdir}/%{name}-%{version}
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/lib*.a
This page took 0.053028 seconds and 3 git commands to generate.