]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
- new
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.12
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/%{name}-%{version}.tar.gz
9 URL:            http://www.directfb.org/
10 BuildRequires:  DirectFB-devel
11 BuildRequires:  autoconf
12 BuildRequires:  libstdc++-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
17 advantage is that the 'thiz' doesn't need to be passed as the first
18 argument of every interface function. Another feature is the usage of
19 exceptions. It's annoying having these error checking stuff with
20 growing deinitialization stacks. Most functions are 'void'. As soon as
21 a DirectFB function returns an error a DFBException is thrown.
22                 
23 %description -l pl
24 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
25 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
26 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
27 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym stosem
28 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
29 zwraca b³±d, rzucany jest wyj±tek DFBException.
30
31 %package devel
32 Summary:        DFB++ header files
33 Summary(pl):    Pliki nag³ówkowe DFB++
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36
37 %description devel
38 Header files for DFB++ library.
39
40 %description devel -l pl
41 Pliki nag³ówkowe biblioteki DFB++.
42
43 %package static
44 Summary:        DFB++ static library
45 Summary(pl):    Statyczna biblioteka DFB++
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}
48
49 %description static
50 DFB++ static library.
51
52 %description static -l pl
53 Statyczna biblioteka DFB++.
54
55 %prep
56 %setup -q
57
58 %build
59 %{__autoconf}
60 %configure \
61         --enable-static
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog README
81 %attr(755,root,root) %{_libdir}/lib*.so.*.*
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/lib*.so
86 %attr(755,root,root) %{_libdir}/lib*.la
87 %attr(755,root,root) %{_bindir}/dfb++-config
88 %{_includedir}/dfb++
89 %{_pkgconfigdir}/*.pc
90 %{_examplesdir}/%{name}-%{version}
91
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/lib*.a
This page took 0.161616 seconds and 3 git commands to generate.