]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
- fixed source URL
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.13
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/DirectFB/%{name}-%{version}.tar.gz
9 URL:            http://www.directfb.org/
10 BuildRequires:  DirectFB-devel >= %{version}
11 BuildRequires:  autoconf
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  pkgconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
18 advantage is that the 'thiz' doesn't need to be passed as the first
19 argument of every interface function. Another feature is the usage of
20 exceptions. It's annoying having these error checking stuff with
21 growing deinitialization stacks. Most functions are 'void'. As soon as
22 a DirectFB function returns an error a DFBException is thrown.
23                 
24 %description -l pl
25 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
26 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
27 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
28 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym stosem
29 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
30 zwraca b³±d, rzucany jest wyj±tek DFBException.
31
32 %package devel
33 Summary:        DFB++ header files
34 Summary(pl):    Pliki nag³ówkowe DFB++
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}
37
38 %description devel
39 Header files for DFB++ library.
40
41 %description devel -l pl
42 Pliki nag³ówkowe biblioteki DFB++.
43
44 %package static
45 Summary:        DFB++ static library
46 Summary(pl):    Statyczna biblioteka DFB++
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}
49
50 %description static
51 DFB++ static library.
52
53 %description static -l pl
54 Statyczna biblioteka DFB++.
55
56 %prep
57 %setup -q
58
59 %build
60 %{__autoconf}
61 %configure \
62         --enable-static
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS ChangeLog README
82 %attr(755,root,root) %{_libdir}/lib*.so.*.*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/lib*.so
87 %attr(755,root,root) %{_libdir}/lib*.la
88 %attr(755,root,root) %{_bindir}/dfb++-config
89 %{_includedir}/dfb++
90 %{_pkgconfigdir}/*.pc
91 %{_examplesdir}/%{name}-%{version}
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/lib*.a
This page took 0.087347 seconds and 3 git commands to generate.