]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
39e89a401afb5a85422e5b8a42ae12e89ba6d28b
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.23
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/DirectFB-extra/%{name}-%{version}.tar.gz
9 # Source0-md5:  14cd1de1105e1eeb0349f672c74f41c0
10 URL:            http://www.directfb.org/index.php?path=Development/Projects/DFB++
11 BuildRequires:  DirectFB-devel >= 1:%{version}
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRequires:  pkgconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
21 advantage is that the 'thiz' doesn't need to be passed as the first
22 argument of every interface function. Another feature is the usage of
23 exceptions. It's annoying having these error checking stuff with
24 growing deinitialization stacks. Most functions are 'void'. As soon as
25 a DirectFB function returns an error a DFBException is thrown.
26
27 %description -l pl
28 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
29 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
30 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
31 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym siê stosem
32 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
33 zwraca b³±d, rzucany jest wyj±tek DFBException.
34
35 %package devel
36 Summary:        DFB++ header files
37 Summary(pl):    Pliki nag³ówkowe DFB++
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       DirectFB-devel >= 1:%{version}
41 Requires:       libstdc++-devel
42
43 %description devel
44 Header files for DFB++ library.
45
46 %description devel -l pl
47 Pliki nag³ówkowe biblioteki DFB++.
48
49 %package static
50 Summary:        DFB++ static library
51 Summary(pl):    Statyczna biblioteka DFB++
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 DFB++ static library.
57
58 %description static -l pl
59 Statyczna biblioteka DFB++.
60
61 %prep
62 %setup -q
63
64 %build
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71         --enable-static
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog README
92 %attr(755,root,root) %{_bindir}/dfbshow
93 %attr(755,root,root) %{_bindir}/dfbswitch
94 %attr(755,root,root) %{_libdir}/libdfb++-*.so.*.*.*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_bindir}/dfb++-config
99 %attr(755,root,root) %{_libdir}/libdfb++.so
100 %{_libdir}/libdfb++.la
101 %{_includedir}/dfb++
102 %{_pkgconfigdir}/*.pc
103 %{_examplesdir}/%{name}-%{version}
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libdfb++.a
This page took 0.061994 seconds and 2 git commands to generate.