]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
- R: pkgconfig for -devel
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl):    Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        0.9.23
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/download/DirectFB-extra/%{name}-%{version}.tar.gz
9 # Source0-md5:  14cd1de1105e1eeb0349f672c74f41c0
10 URL:            http://www.directfb.org/index.php?path=Development/Projects/DFB++
11 BuildRequires:  DirectFB-devel >= 1:%{version}
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRequires:  pkgconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
21 advantage is that the 'thiz' doesn't need to be passed as the first
22 argument of every interface function. Another feature is the usage of
23 exceptions. It's annoying having these error checking stuff with
24 growing deinitialization stacks. Most functions are 'void'. As soon as
25 a DirectFB function returns an error a DFBException is thrown.
26
27 %description -l pl
28 DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
29 u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
30 jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
31 wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym siê stosem
32 deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
33 zwraca b³±d, rzucany jest wyj±tek DFBException.
34
35 %package devel
36 Summary:        DFB++ header files
37 Summary(pl):    Pliki nag³ówkowe DFB++
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       DirectFB-devel >= 1:%{version}
41 Requires:       libstdc++-devel
42 Requires:       pkgconfig
43
44 %description devel
45 Header files for DFB++ library.
46
47 %description devel -l pl
48 Pliki nag³ówkowe biblioteki DFB++.
49
50 %package static
51 Summary:        DFB++ static library
52 Summary(pl):    Statyczna biblioteka DFB++
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 DFB++ static library.
58
59 %description static -l pl
60 Statyczna biblioteka DFB++.
61
62 %prep
63 %setup -q
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure \
72         --enable-static
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog README
93 %attr(755,root,root) %{_bindir}/dfbshow
94 %attr(755,root,root) %{_bindir}/dfbswitch
95 %attr(755,root,root) %{_libdir}/libdfb++-*.so.*.*.*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/dfb++-config
100 %attr(755,root,root) %{_libdir}/libdfb++.so
101 %{_libdir}/libdfb++.la
102 %{_includedir}/dfb++
103 %{_pkgconfigdir}/*.pc
104 %{_examplesdir}/%{name}-%{version}
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libdfb++.a
This page took 0.078537 seconds and 3 git commands to generate.