]> git.pld-linux.org Git - packages/CuraEngine.git/commitdiff
- up to 3.5.1 auto/th/CuraEngine-3.5.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 4 Nov 2018 13:12:26 +0000 (14:12 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 4 Nov 2018 13:12:26 +0000 (14:12 +0100)
CuraEngine-rpath.patch
CuraEngine-system-libs.patch [deleted file]
CuraEngine.spec

index 0b58acbdebb540aa3cc5cd01e4d508935506d099..105ac1e0af2e28b07d48a091a7933e16e2618477 100644 (file)
@@ -11,15 +11,14 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
 index c2316d6..1ec537d 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -21,8 +21,6 @@ if(APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "Clang")
-     set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -stdlib=libc++")
+@@ -21,7 +21,6 @@ if(APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ if(NOT DEFINED LIB_SUFFIX)
+     set(LIB_SUFFIX "")
  endif()
+-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
  
--set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
--
  set(CURA_ENGINE_VERSION "master" CACHE STRING "Version name of Cura")
  
- option(BUILD_TESTS OFF)
 -- 
 2.11.0
 
diff --git a/CuraEngine-system-libs.patch b/CuraEngine-system-libs.patch
deleted file mode 100644 (file)
index eb2d986..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 62ce7cbc96a52723e11adfda848211e03f6733ba Mon Sep 17 00:00:00 2001
-From: rpm-build <rpm-build>
-Date: Wed, 3 May 2017 14:04:17 +0200
-Subject: [PATCH 3/3] System libs
-
----
- CMakeLists.txt | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bc5cf85..07e4c41 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -46,9 +46,7 @@ if (ENABLE_OPENMP)
-     endif()
- endif()
--include_directories(${CMAKE_CURRENT_BINARY_DIR} libs)
--
--add_library(clipper STATIC libs/clipper/clipper.cpp)
-+include_directories(${CMAKE_CURRENT_BINARY_DIR})
- set(engine_SRCS # Except main.cpp.
-     src/bridge.cpp
-@@ -136,7 +134,7 @@ endif ()
- # Compiling CuraEngine itself.
- add_library(_CuraEngine ${engine_SRCS} ${engine_PB_SRCS}) #First compile all of CuraEngine as library, allowing this to be re-used for tests.
--target_link_libraries(_CuraEngine clipper)
-+target_link_libraries(_CuraEngine polyclipping)
- if (ENABLE_ARCUS)
-     target_link_libraries(_CuraEngine Arcus)
- endif ()
--- 
-2.11.0
-
index 55d94d03759628a808464081adced381ab66861a..dd6820d5df893ef0de6b5ddfb1f607a56b0ba52e 100644 (file)
@@ -5,16 +5,15 @@
 Summary:       Engine for processing 3D models into G-code instructions for 3D printers
 Summary(pl.UTF-8):     Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
 Name:          CuraEngine
-Version:       2.5.0
-Release:       3
+Version:       3.5.1
+Release:       1
 Epoch:         1
 License:       AGPL v3
 Group:         Applications/Engineering
 Source0:       https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 8d8de8f56fd5831b3b74e8946a26681e
+# Source0-md5: 54800673b165c69dff2978e7b7a58e70
 Patch0:                %{name}-rpath.patch
 Patch1:                %{name}-static-libstdcpp.patch
-Patch2:                %{name}-system-libs.patch
 URL:           https://github.com/Ultimaker/CuraEngine
 BuildRequires: cmake
 BuildRequires: libArcus-devel = %{version}
@@ -47,7 +46,6 @@ pakiecie cura.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 # bundled libraries
 rm -rf libs
@@ -60,6 +58,7 @@ rm -rf libs
 mkdir build
 cd build
 %cmake .. \
+       -DUSE_SYSTEM_LIBS:BOOL=ON \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
        -DCURA_ENGINE_VERSION:STRING=%{version}
 
This page took 0.124491 seconds and 4 git commands to generate.