]> git.pld-linux.org Git - packages/CuraEngine.git/blob - CuraEngine.spec
dd6820d5df893ef0de6b5ddfb1f607a56b0ba52e
[packages/CuraEngine.git] / CuraEngine.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Engine for processing 3D models into G-code instructions for 3D printers
6 Summary(pl.UTF-8):      Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
7 Name:           CuraEngine
8 Version:        3.5.1
9 Release:        1
10 Epoch:          1
11 License:        AGPL v3
12 Group:          Applications/Engineering
13 Source0:        https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  54800673b165c69dff2978e7b7a58e70
15 Patch0:         %{name}-rpath.patch
16 Patch1:         %{name}-static-libstdcpp.patch
17 URL:            https://github.com/Ultimaker/CuraEngine
18 BuildRequires:  cmake
19 BuildRequires:  libArcus-devel = %{version}
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  polyclipping-devel >= 6.1.2
22 BuildRequires:  protobuf-devel
23 %{?with_tests:BuildRequires:  python}
24 BuildRequires:  rapidjson-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 CuraEngine is a C++ console application for 3D printing G-code
29 generation. It has been made as a better and faster alternative to the
30 old Skeinforge engine.
31
32 This is just a console application for G-code generation. For a full
33 graphical application look at cura with is the graphical frontend for
34 CuraEngine.
35
36 %description -l pl.UTF-8
37 CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
38 dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
39 starego silnika Skeinforge.
40
41 To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
42 aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
43 pakiecie cura.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49
50 # bundled libraries
51 rm -rf libs
52 %{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
53
54 # The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
55 %{__sed} -i 's/"DEV"/"%{version}"/' src/settings/settings.h
56
57 %build
58 mkdir build
59 cd build
60 %cmake .. \
61         -DUSE_SYSTEM_LIBS:BOOL=ON \
62         -DBUILD_SHARED_LIBS:BOOL=OFF \
63         -DCURA_ENGINE_VERSION:STRING=%{version}
64
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc LICENSE README.md
81 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.072796 seconds and 2 git commands to generate.