]> git.pld-linux.org Git - packages/CuraEngine.git/blame - CuraEngine.spec
- CuraEngine "requires" stb library, but what it really wants is a single header,
[packages/CuraEngine.git] / CuraEngine.spec
CommitLineData
880c7dcc
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
fd41772a 5Summary: Engine for processing 3D models into G-code instructions for 3D printers
4b3b0a44 6Summary(pl.UTF-8): Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
fd41772a 7Name: CuraEngine
7eddc54f 8Version: 3.5.1
e36aaec0 9Release: 2
913bfb50 10Epoch: 1
4b3b0a44 11License: AGPL v3
fd41772a 12Group: Applications/Engineering
913bfb50 13Source0: https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
7eddc54f 14# Source0-md5: 54800673b165c69dff2978e7b7a58e70
e36aaec0
JR
15Source1: https://raw.githubusercontent.com/nothings/stb/master/stb_image.h
16# Source1-md5: 2a512ad9f82f104b8120e52babd37cc7
913bfb50
JR
17Patch0: %{name}-rpath.patch
18Patch1: %{name}-static-libstdcpp.patch
e36aaec0 19Patch2: local-stb.patch
880c7dcc 20URL: https://github.com/Ultimaker/CuraEngine
913bfb50
JR
21BuildRequires: cmake
22BuildRequires: libArcus-devel = %{version}
880c7dcc 23BuildRequires: libstdc++-devel
fd41772a 24BuildRequires: polyclipping-devel >= 6.1.2
913bfb50 25BuildRequires: protobuf-devel
fd41772a 26%{?with_tests:BuildRequires: python}
913bfb50 27BuildRequires: rapidjson-devel
880c7dcc 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fd41772a
AM
29
30%description
4b3b0a44 31CuraEngine is a C++ console application for 3D printing G-code
fd41772a
AM
32generation. It has been made as a better and faster alternative to the
33old Skeinforge engine.
34
35This is just a console application for G-code generation. For a full
36graphical application look at cura with is the graphical frontend for
4b3b0a44
JB
37CuraEngine.
38
39%description -l pl.UTF-8
40CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
41dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
42starego silnika Skeinforge.
43
44To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
45aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
46pakiecie cura.
fd41772a
AM
47
48%prep
49%setup -q
913bfb50
JR
50%patch0 -p1
51%patch1 -p1
e36aaec0
JR
52%patch2 -p1
53
54mkdir stb
55install %{SOURCE1} stb/
fd41772a 56
913bfb50 57# bundled libraries
e36aaec0 58%{__rm} -rf libs
4b3b0a44 59%{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
fd41772a 60
913bfb50 61# The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
4b3b0a44 62%{__sed} -i 's/"DEV"/"%{version}"/' src/settings/settings.h
fd41772a
AM
63
64%build
913bfb50
JR
65mkdir build
66cd build
4b3b0a44 67%cmake .. \
e36aaec0 68 -DStb_INCLUDE_DIRS:STRING="$(pwd)/.." \
7eddc54f 69 -DUSE_SYSTEM_LIBS:BOOL=ON \
913bfb50
JR
70 -DBUILD_SHARED_LIBS:BOOL=OFF \
71 -DCURA_ENGINE_VERSION:STRING=%{version}
72
73%{__make}
fd41772a
AM
74
75%{?with_tests:%{__make} test}
76
77%install
78rm -rf $RPM_BUILD_ROOT
913bfb50
JR
79
80%{__make} -C build install \
81 DESTDIR=$RPM_BUILD_ROOT
fd41772a
AM
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(644,root,root,755)
88%doc LICENSE README.md
89%attr(755,root,root) %{_bindir}/%{name}
This page took 0.084738 seconds and 4 git commands to generate.