]> git.pld-linux.org Git - packages/CuraEngine.git/blame - CuraEngine.spec
- release 2 (by relup.sh)
[packages/CuraEngine.git] / CuraEngine.spec
CommitLineData
880c7dcc
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
fd41772a
AM
5Summary: Engine for processing 3D models into G-code instructions for 3D printers
6Name: CuraEngine
913bfb50 7Version: 2.5.0
efa3bdeb 8Release: 2
913bfb50 9Epoch: 1
fd41772a
AM
10License: AGPLv3
11Group: Applications/Engineering
913bfb50
JR
12Source0: https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: 8d8de8f56fd5831b3b74e8946a26681e
14Patch0: %{name}-rpath.patch
15Patch1: %{name}-static-libstdcpp.patch
16Patch2: %{name}-system-libs.patch
880c7dcc 17URL: https://github.com/Ultimaker/CuraEngine
913bfb50
JR
18BuildRequires: cmake
19BuildRequires: libArcus-devel = %{version}
880c7dcc 20BuildRequires: libstdc++-devel
fd41772a 21BuildRequires: polyclipping-devel >= 6.1.2
913bfb50 22BuildRequires: protobuf-devel
fd41772a 23%{?with_tests:BuildRequires: python}
913bfb50 24BuildRequires: rapidjson-devel
880c7dcc 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fd41772a
AM
26
27%description
28%{name} is a C++ console application for 3D printing G-code
29generation. It has been made as a better and faster alternative to the
30old Skeinforge engine.
31
32This is just a console application for G-code generation. For a full
33graphical application look at cura with is the graphical frontend for
34%{name}.
35
36%prep
37%setup -q
913bfb50
JR
38%patch0 -p1
39%patch1 -p1
40%patch2 -p1
fd41772a 41
913bfb50
JR
42# bundled libraries
43rm -rf libs
44sed -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
fd41772a 45
913bfb50
JR
46# The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
47sed -i 's/"DEV"/"%{version}"/' src/settings/settings.h
fd41772a
AM
48
49%build
913bfb50
JR
50mkdir build
51cd build
52%{cmake} .. \
53 -DBUILD_SHARED_LIBS:BOOL=OFF \
54 -DCURA_ENGINE_VERSION:STRING=%{version}
55
56%{__make}
fd41772a
AM
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
913bfb50
JR
62
63%{__make} -C build install \
64 DESTDIR=$RPM_BUILD_ROOT
fd41772a
AM
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc LICENSE README.md
72%attr(755,root,root) %{_bindir}/%{name}
This page took 0.076787 seconds and 4 git commands to generate.