]> git.pld-linux.org Git - packages/CuraEngine.git/blame - CuraEngine.spec
- release 5
[packages/CuraEngine.git] / CuraEngine.spec
CommitLineData
880c7dcc
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
fd41772a 5Summary: Engine for processing 3D models into G-code instructions for 3D printers
4b3b0a44 6Summary(pl.UTF-8): Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
fd41772a 7Name: CuraEngine
5ed8cdd2 8Version: 4.5.0
6f629d4d 9Release: 5
913bfb50 10Epoch: 1
4b3b0a44 11License: AGPL v3
fd41772a 12Group: Applications/Engineering
4c96bf6b 13#Source0Download: https://github.com/Ultimaker/CuraEngine/releases
913bfb50 14Source0: https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
5ed8cdd2 15# Source0-md5: 63df14853c6a183acc1153176423c2a7
e36aaec0 16Source1: https://raw.githubusercontent.com/nothings/stb/master/stb_image.h
5ed8cdd2 17# Source1-md5: a1170ba8b5f36154a8b9859f17ee8470
913bfb50 18Patch0: %{name}-rpath.patch
84b0a036 19Patch1: %{name}-static-libstdcpp.patch
e36aaec0 20Patch2: local-stb.patch
880c7dcc 21URL: https://github.com/Ultimaker/CuraEngine
84b0a036 22BuildRequires: cmake >= 3.6.0
913bfb50 23BuildRequires: libArcus-devel = %{version}
4c96bf6b
JB
24BuildRequires: libgomp-devel
25BuildRequires: libstdc++-devel >= 6:4.7
fd41772a 26BuildRequires: polyclipping-devel >= 6.1.2
4c96bf6b
JB
27BuildRequires: protobuf-devel >= 3.0.0
28%{?with_tests:BuildRequires: python3 >= 1:3}
913bfb50 29BuildRequires: rapidjson-devel
880c7dcc 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fd41772a
AM
31
32%description
4b3b0a44 33CuraEngine is a C++ console application for 3D printing G-code
fd41772a
AM
34generation. It has been made as a better and faster alternative to the
35old Skeinforge engine.
36
37This is just a console application for G-code generation. For a full
38graphical application look at cura with is the graphical frontend for
4b3b0a44
JB
39CuraEngine.
40
41%description -l pl.UTF-8
42CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
43dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
44starego silnika Skeinforge.
45
46To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
47aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
48pakiecie cura.
fd41772a
AM
49
50%prep
51%setup -q
913bfb50 52%patch0 -p1
84b0a036 53%patch1 -p1
e36aaec0
JR
54%patch2 -p1
55
56mkdir stb
4c96bf6b 57cp -p %{SOURCE1} stb/
fd41772a 58
913bfb50 59# bundled libraries
e36aaec0 60%{__rm} -rf libs
4b3b0a44 61%{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
fd41772a 62
913bfb50 63# The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
5ed8cdd2 64%{__sed} -i 's/"DEV"/"%{version}"/' src/settings/Settings.h
fd41772a
AM
65
66%build
913bfb50
JR
67mkdir build
68cd build
4b3b0a44 69%cmake .. \
e36aaec0 70 -DStb_INCLUDE_DIRS:STRING="$(pwd)/.." \
7eddc54f 71 -DUSE_SYSTEM_LIBS:BOOL=ON \
913bfb50
JR
72 -DBUILD_SHARED_LIBS:BOOL=OFF \
73 -DCURA_ENGINE_VERSION:STRING=%{version}
74
75%{__make}
fd41772a
AM
76
77%{?with_tests:%{__make} test}
78
79%install
80rm -rf $RPM_BUILD_ROOT
913bfb50
JR
81
82%{__make} -C build install \
83 DESTDIR=$RPM_BUILD_ROOT
fd41772a
AM
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
4c96bf6b 90%doc README.md
fd41772a 91%attr(755,root,root) %{_bindir}/%{name}
This page took 0.06102 seconds and 4 git commands to generate.