]> git.pld-linux.org Git - packages/CodeIgniter.git/blob - CodeIgniter.spec
- initial
[packages/CodeIgniter.git] / CodeIgniter.spec
1 %define         php_min_version 5.2.4
2 %include        /usr/lib/rpm/macros.php
3 Summary:        A powerful PHP framework with a very small footprint
4 Name:           CodeIgniter
5 Version:        2.0.2
6 Release:        0.5
7 License:        other
8 Group:          Development/Languages/PHP
9 Source0:        http://www.codeigniter.com/download_files/reactor/%{name}_%{version}.zip
10 # Source0-md5:  e75bab8cf27d2fb2483c5bb61b85a524
11 Source1:        INSTALL-PLD.txt
12 URL:            http://www.kohanaframework.org/
13 BuildRequires:  rpm-php-pearprov >= 4.3
14 BuildRequires:  rpmbuild(macros) >= 1.461
15 BuildRequires:  sed >= 4.0
16 BuildRequires:  unzip
17 Requires:       php-common >= 4:%{php_min_version}
18 Requires:       php-ctype
19 Requires:       php-date
20 Requires:       php-hash
21 Requires:       php-mbstring
22 Requires:       php-mysql
23 Requires:       php-pcre
24 Requires:       php-session
25 Requires:       php-simplexml
26 Requires:       php-spl
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _appdir         %{_datadir}/%{name}
31
32 %description
33 CodeIgniter is a powerful PHP framework with a very small footprint,
34 built for PHP coders who need a simple and elegant toolkit to create
35 full-featured web applications. If you're a developer who lives in the
36 real world of shared hosting accounts and clients with deadlines, and
37 if you're tired of ponderously large and thoroughly undocumented
38 frameworks.
39
40 %prep
41 %setup -q -n %{name}_%{version}
42 %{__sed} -i 's,\$application_folder.*=.*,$application_folder = "PLEASE SET TO CORRECT PATH";,' index.php
43 %{__sed} -i '59 s,\$system_path.*=.*,$system_path = "/usr/share/CodeIgniter"\;, ' index.php
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_appdir}
49 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
50
51 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
52 cp -r user_guide/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %banner -e %{name} <<-EOF
60 Please read INSTALL-PLD.txt to know how can use the users the installed CodeIgniter!
61 EOF
62
63 %files
64 %defattr(644,root,root,755)
65 %doc %{_docdir}/%{name}-%{version}
66 %{_appdir}
This page took 0.036009 seconds and 3 git commands to generate.