]> git.pld-linux.org Git - packages/CodeIgniter.git/blob - CodeIgniter.spec
inline sed, especially with line numbers, is not reliable. patch it
[packages/CodeIgniter.git] / CodeIgniter.spec
1 %define         php_min_version 5.2.4
2 %include        /usr/lib/rpm/macros.php
3 Summary:        A powerful PHP framework with a very small footprint
4 Name:           CodeIgniter
5 Version:        2.1.2
6 Release:        0.9
7 License:        other
8 Group:          Development/Languages/PHP
9 Source0:        http://www.codeigniter.com/download_files/reactor/%{name}_%{version}.zip
10 # Source0-md5:  c7a2980dff2774c97bd38bfbf450d8d5
11 Source1:        INSTALL-PLD.txt
12 Source2:        codeigniter-install
13 Patch0:         pld.patch
14 URL:            http://codeigniter.com/
15 BuildRequires:  rpm-php-pearprov >= 4.3
16 BuildRequires:  rpmbuild(macros) >= 1.461
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  unzip
19 Requires:       php(core) >= %{php_min_version}
20 Requires:       php(ctype)
21 Requires:       php(date)
22 Requires:       php(hash)
23 Requires:       php(mbstring)
24 Requires:       php(mysql)
25 Requires:       php(pcre)
26 Requires:       php(session)
27 Requires:       php(simplexml)
28 Requires:       php(spl)
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _appdir         %{_datadir}/%{name}
33
34 %description
35 CodeIgniter is a powerful PHP framework with a very small footprint,
36 built for PHP coders who need a simple and elegant toolkit to create
37 full-featured web applications. If you're a developer who lives in the
38 real world of shared hosting accounts and clients with deadlines, and
39 if you're tired of ponderously large and thoroughly undocumented
40 frameworks.
41
42 %package doc
43 Summary:        CodeIgniter documentation
44 Group:          Development/Languages/PHP
45
46 %description doc
47 CodeIgniter documentation.
48
49 %prep
50 %setup -q -n %{name}_%{version}
51 %patch0 -p1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_appdir}
56 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
57 cp -r user_guide/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
58
59 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
60 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
61
62 install -d $RPM_BUILD_ROOT%{_bindir}
63 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
64
65 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name index.html -delete
66
67 rm -rf $RPM_BUILD_ROOT%{_appdir}/application/{cache,core,helpers,hooks,libraries}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %banner -e %{name} <<-EOF
74 Please read INSTALL-PLD.txt to know how can use the users the installed CodeIgniter!
75 EOF
76
77 %files
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_bindir}/codeigniter-install
80
81 %dir %{_appdir}
82 %dir %{_appdir}/application
83 %dir %{_appdir}/application/config
84 %dir %{_appdir}/application/controllers
85 %dir %{_appdir}/application/errors
86 %dir %{_appdir}/application/language
87 %dir %{_appdir}/application/views
88 %dir %{_appdir}/system
89 %dir %{_appdir}/system/core
90 %dir %{_appdir}/system/database
91 %dir %{_appdir}/system/database/drivers
92 %dir %{_appdir}/system/fonts
93 %dir %{_appdir}/system/helpers
94 %dir %{_appdir}/system/language
95 %dir %{_appdir}/system/libraries
96
97 %{_appdir}/index.php
98 %{_appdir}/application/.htaccess
99 %{_appdir}/system/.htaccess
100
101 %{_appdir}/application/config/*
102 %{_appdir}/application/controllers/*
103 %{_appdir}/application/errors/*
104 %{_appdir}/application/language/*
105 %{_appdir}/application/views/*
106
107 %{_appdir}/system/core/*
108 %{_appdir}/system/database/DB*.php
109 %{_appdir}/system/database/drivers/*
110 %{_appdir}/system/fonts/*
111 %{_appdir}/system/helpers/*
112 %{_appdir}/system/language/*
113 %{_appdir}/system/libraries/*
114
115 %files doc
116 %defattr(644,root,root,755)
117 %doc %{_docdir}/%{name}-%{version}
This page took 0.133548 seconds and 3 git commands to generate.