]> git.pld-linux.org Git - packages/CodeIgniter-lib-smarty.git/commitdiff
- update to compatible with Smarty 3.1.x
authorZsolt Udvari <uzsolt@pld-linux.org>
Tue, 25 Oct 2011 05:36:31 +0000 (05:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    CodeIgniter-lib-smarty.spec -> 1.3
    Smarty_tpl.php -> 1.4

CodeIgniter-lib-smarty.spec
Smarty_tpl.php

index c391750921d5356d02b8b62971494ca7099d45f0..3e4cb94feb6b87aa9e7f5f1b0b2f6acd184e8847 100644 (file)
@@ -3,13 +3,13 @@
 %include       /usr/lib/rpm/macros.php
 Summary:       Use smarty template engine in CodeIgniter
 Name:          CodeIgniter-lib-%{shortname}
-Version:       1
+Version:       2
 Release:       0.1
 License:       GPL
 Group:         Development/Languages/PHP
 Source0:       Smarty_tpl.php
 Requires:      CodeIgniter >= 2.0.0
-Requires:      php-Smarty >= 3.0
+Requires:      php-Smarty >= 3.1
 Requires:      php-common >= 4:%{php_min_version}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
index d7d7839c8641228c7b0658bce15557d69c297eed..a21d3c937935df28433987606bb9043eca63b3cb 100644 (file)
@@ -10,18 +10,18 @@ class smarty_tpl extends Smarty {
     function smarty_tpl() {
         $this->Smarty();
         // templates folder
-        $this->template_dir=    APPPATH."views/templates";
+        $this->setTemplateDir(APPPATH."views/templates");
         // compiled templates folder
-        $this->compile_dir=     APPPATH."views/templates_c";
+       $this->setCompileDir(APPPATH."views/templates_c");
         // cache folder
-        $this->cache_dir=       APPPATH."views/cache";
+        $this->setCacheDir(APPPATH."views/cache");
         //config folder
-        $this->config_dir=      APPPATH."views/config";
+        $this->setConfigDir(APPPATH."views/config");
        //plugins folder
-       $this->plugins_dir = array(
+       $this->setPluginsDir(array(
                "/usr/share/php/Smarty3/plugins/",
                "/usr/share/php/Smarty3/sysplugins/"
-       );
+       ));
 
         // template recheck on
         $this->compile_check=   true;
This page took 0.077776 seconds and 4 git commands to generate.