]> git.pld-linux.org Git - packages/CodeIgniter-lib-smarty.git/commitdiff
- drop obsolete and outdated manual inclusion of rpm macros master
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 25 Jan 2020 13:57:33 +0000 (14:57 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 25 Jan 2020 13:57:33 +0000 (14:57 +0100)
CodeIgniter-lib-smarty.spec
Smarty_tpl.php

index c391750921d5356d02b8b62971494ca7099d45f0..d66810fa75f1c4d215381ac535e2c46bb9c17204 100644 (file)
@@ -1,15 +1,14 @@
 %define                php_min_version 5.2.4
 %define                shortname       smarty
 %define                php_min_version 5.2.4
 %define                shortname       smarty
-%include       /usr/lib/rpm/macros.php
 Summary:       Use smarty template engine in CodeIgniter
 Name:          CodeIgniter-lib-%{shortname}
 Summary:       Use smarty template engine in CodeIgniter
 Name:          CodeIgniter-lib-%{shortname}
-Version:       1
+Version:       2
 Release:       0.1
 License:       GPL
 Group:         Development/Languages/PHP
 Source0:       Smarty_tpl.php
 Requires:      CodeIgniter >= 2.0.0
 Release:       0.1
 License:       GPL
 Group:         Development/Languages/PHP
 Source0:       Smarty_tpl.php
 Requires:      CodeIgniter >= 2.0.0
-Requires:      php-Smarty >= 3.0
+Requires:      php-Smarty >= 3.1
 Requires:      php-common >= 4:%{php_min_version}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Requires:      php-common >= 4:%{php_min_version}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
index d7d7839c8641228c7b0658bce15557d69c297eed..a21d3c937935df28433987606bb9043eca63b3cb 100644 (file)
@@ -10,18 +10,18 @@ class smarty_tpl extends Smarty {
     function smarty_tpl() {
         $this->Smarty();
         // templates folder
     function smarty_tpl() {
         $this->Smarty();
         // templates folder
-        $this->template_dir=    APPPATH."views/templates";
+        $this->setTemplateDir(APPPATH."views/templates");
         // compiled templates folder
         // compiled templates folder
-        $this->compile_dir=     APPPATH."views/templates_c";
+       $this->setCompileDir(APPPATH."views/templates_c");
         // cache folder
         // cache folder
-        $this->cache_dir=       APPPATH."views/cache";
+        $this->setCacheDir(APPPATH."views/cache");
         //config folder
         //config folder
-        $this->config_dir=      APPPATH."views/config";
+        $this->setConfigDir(APPPATH."views/config");
        //plugins folder
        //plugins folder
-       $this->plugins_dir = array(
+       $this->setPluginsDir(array(
                "/usr/share/php/Smarty3/plugins/",
                "/usr/share/php/Smarty3/sysplugins/"
                "/usr/share/php/Smarty3/plugins/",
                "/usr/share/php/Smarty3/sysplugins/"
-       );
+       ));
 
         // template recheck on
         $this->compile_check=   true;
 
         // template recheck on
         $this->compile_check=   true;
This page took 0.080247 seconds and 4 git commands to generate.