]> git.pld-linux.org Git - packages/CharLS.git/blobdiff - CharLS-add_cmake_install_target.patch
- new URLs, updated to 1.1.0
[packages/CharLS.git] / CharLS-add_cmake_install_target.patch
diff --git a/CharLS-add_cmake_install_target.patch b/CharLS-add_cmake_install_target.patch
deleted file mode 100644 (file)
index bd96ffa..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8304f0d..88f0949 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -12,6 +12,11 @@ SET(CMAKE_CXX_FLAGS "-D NDEBUG -O3" )
- ENDIF(CMAKE_COMPILER_IS_GNUCC)
- ENDIF(NOT CMAKE_BUILD_TYPE)
-+SET( charls_HEADERS "colortransform.h"  "context.h" "decoderstrategy.h"  "encoderstrategy.h"  "interface.h"
-+    "losslesstraits.h"  "scan.h"    "streams.h" "config.h"          "contextrunmode.h"  "defaulttraits.h"
-+    "header.h"           "lookuptable.h"  "processline.h"      "util.h" "publictypes.h"
-+)
-+
- OPTION(charls_BUILD_SHARED_LIBS "Build CharLS with shared libraries." OFF)
- SET(BUILD_SHARED_LIBS ${charls_BUILD_SHARED_LIBS})
-@@ -21,3 +26,7 @@ add_library(CharLS header.cpp  interface.cpp  jpegls.cpp  )
- add_executable(charlstest test/main.cpp test/time.cpp test/util.cpp test/bitstreamdamage.cpp test/compliance.cpp test/performance.cpp test/dicomsamples.cpp)
- target_link_libraries (charlstest CharLS)
-+# Installs the header files into the {build_dir}/include/libcharls directory
-+install(FILES ${charls_HEADERS} DESTINATION include/CharLS)
-+
-+
This page took 0.073122 seconds and 4 git commands to generate.