]> git.pld-linux.org Git - packages/Carla.git/commitdiff
a bugfix from upstream
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 1 Mar 2018 08:47:07 +0000 (09:47 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 1 Mar 2018 09:02:24 +0000 (10:02 +0100)
Makes some LV2 plugins without our GUI actually usable.

Carla.spec
param_update.patch [new file with mode: 0644]

index fcb4a2ee1dc7862dd413a35bff4b5e8e089891e7..15c2c6f0f58cf1554c2cdb9f46469276ea27897d 100644 (file)
@@ -13,6 +13,7 @@ Source0:      https://github.com/falkTX/Carla/archive/%{tag}/%{name}-%{tag}.tar.gz
 # Source0-md5: 279acb33716327c82516d6edb8ff6d13
 Patch0:                pypkgdir.patch
 Patch1:                soundfonts_path.patch
+Patch2:                param_update.patch
 URL:           http://kxstudio.linuxaudio.org/Applications:Carla
 BuildRequires: Mesa-libGL-devel
 BuildRequires: Qt5Core-devel
@@ -63,6 +64,7 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__make} -j1 \
diff --git a/param_update.patch b/param_update.patch
new file mode 100644 (file)
index 0000000..8a30b87
--- /dev/null
@@ -0,0 +1,63 @@
+From afed293c3ea13ea68dc4bb3368021b43be8f3e32 Mon Sep 17 00:00:00 2001
+From: falkTX <falktx@gmail.com>
+Date: Sun, 25 Feb 2018 23:42:43 +0100
+Subject: [PATCH] Fix for built-in parameter widgets not always updating
+
+---
+ source/carla_skin.py           | 2 +-
+ source/carla_widgets.py        | 2 +-
+ source/widgets/paramspinbox.py | 8 ++++----
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/source/carla_skin.py b/source/carla_skin.py
+index 49eec8061..696690c92 100755
+--- a/source/carla_skin.py
++++ b/source/carla_skin.py
+@@ -1227,7 +1227,7 @@ def slot_knobCustomMenu(self):
+         else:
+             return
+-        self.sender().setValue(value)
++        sender.setValue(value, True)
+     #------------------------------------------------------------------
+diff --git a/source/carla_widgets.py b/source/carla_widgets.py
+index 4e43083c5..6013a1dcc 100755
+--- a/source/carla_widgets.py
++++ b/source/carla_widgets.py
+@@ -1409,7 +1409,7 @@ def slot_knobCustomMenu(self):
+         else:
+             return
+-        self.sender().setValue(value)
++        sender.setValue(value, True)
+     #------------------------------------------------------------------
+diff --git a/source/widgets/paramspinbox.py b/source/widgets/paramspinbox.py
+index ad89641c4..e7495923d 100644
+--- a/source/widgets/paramspinbox.py
++++ b/source/widgets/paramspinbox.py
+@@ -160,6 +160,9 @@ def setValue(self, value):
+         else:
+             vper = float(value - self.fMinimum) / div
++        if self.fValueCall is not None:
++            self.fValueCall(value)
++
+         QProgressBar.setValue(self, int(vper * 10000))
+     def setLabel(self, label):
+@@ -192,10 +195,7 @@ def handleMouseEventPos(self, pos):
+         elif value > self.fMaximum:
+             value = self.fMaximum
+-        if self.fValueCall is not None:
+-            self.fValueCall(value)
+-
+-        self.valueChanged.emit(value)
++        self.setValue(value)
+     def mousePressEvent(self, event):
+         if event.button() == Qt.LeftButton:
This page took 0.045015 seconds and 4 git commands to generate.