]> git.pld-linux.org Git - packages/CUnit.git/commitdiff
- rediffed
authorMarcin Krol <hawk@tld-linux.org>
Sun, 23 Jul 2023 13:07:08 +0000 (15:07 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 23 Jul 2023 13:07:08 +0000 (15:07 +0200)
CUnit-FHS.patch
CUnit-curses.patch
CUnit-libs.patch

index 5d1df41c6abbbe89100ceda9f1e634dfa8e3447c..3e404aa5ca696c756e526d441df592ffbc2e4d29 100644 (file)
@@ -1,28 +1,18 @@
---- CUnit-2.1-2/doc/headers/Makefile.am.orig   2010-10-14 11:22:01.000000000 +0200
-+++ CUnit-2.1-2/doc/headers/Makefile.am        2013-10-15 20:29:25.894114411 +0200
-@@ -1,6 +1,6 @@
- ## Process this file with automake to produce Makefile.in
--dochdrdir = $(prefix)/doc/@PACKAGE@/headers
-+dochdrdir = $(datarootdir)/doc/@PACKAGE@/headers
- INCLUDE_FILES = \
-       Automated.h \
---- CUnit-2.1-2/doc/Makefile.am.orig   2006-03-21 02:30:57.000000000 +0100
-+++ CUnit-2.1-2/doc/Makefile.am        2013-10-15 20:29:02.207448739 +0200
-@@ -1,8 +1,8 @@
- ## Process this file with automake to produce Makefile.in
+diff -urNp -x '*.orig' CUnit-2.1-3.org/CUnit/Sources/Test/Makefile.am CUnit-2.1-3/CUnit/Sources/Test/Makefile.am
+--- CUnit-2.1-3.org/CUnit/Sources/Test/Makefile.am     2023-07-23 15:06:33.863438862 +0200
++++ CUnit-2.1-3/CUnit/Sources/Test/Makefile.am 2023-07-23 15:06:33.980440529 +0200
+@@ -2,7 +2,7 @@
  
--docdir = $(prefix)/doc/@PACKAGE@
-+pkgdocdir = $(datarootdir)/doc/@PACKAGE@
+ if ENABLE_TEST
+ AM_CPPFLAGS = -I$(top_srcdir)/CUnit/Headers
+-testdir=${datadir}/@PACKAGE@/Test
++testdir=$(pkglibexecdir)/Test
  
--doc_DATA = \
-+pkgdoc_DATA = \
-       CUnit_doc.css \
-       error_handling.html \
-       fdl.html \
---- CUnit-2.1-2/Examples/AutomatedTest/Makefile.am.orig        2013-10-15 20:25:15.024124939 +0200
-+++ CUnit-2.1-2/Examples/AutomatedTest/Makefile.am     2013-10-15 20:33:42.807436964 +0200
+ test_PROGRAMS = test_cunit
+ test_cunit_SOURCES = test_cunit.c
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/AutomatedTest/Makefile.am CUnit-2.1-3/Examples/AutomatedTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/AutomatedTest/Makefile.am 2023-07-23 15:06:33.862438848 +0200
++++ CUnit-2.1-3/Examples/AutomatedTest/Makefile.am     2023-07-23 15:06:33.979440515 +0200
 @@ -1,6 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
@@ -31,8 +21,9 @@
  
  if ENABLE_EXAMPLES
  if ENABLE_AUTOMATED
---- CUnit-2.1-2/Examples/BasicTest/Makefile.am.orig    2013-10-15 20:25:15.027458272 +0200
-+++ CUnit-2.1-2/Examples/BasicTest/Makefile.am 2013-10-15 20:34:01.270769520 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/BasicTest/Makefile.am CUnit-2.1-3/Examples/BasicTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/BasicTest/Makefile.am     2023-07-23 15:06:33.863438862 +0200
++++ CUnit-2.1-3/Examples/BasicTest/Makefile.am 2023-07-23 15:06:33.979440515 +0200
 @@ -1,6 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
@@ -41,8 +32,9 @@
  
  if ENABLE_EXAMPLES
  if ENABLE_BASIC
---- CUnit-2.1-2/Examples/ConsoleTest/Makefile.am.orig  2013-10-15 20:25:15.027458272 +0200
-+++ CUnit-2.1-2/Examples/ConsoleTest/Makefile.am       2013-10-15 20:34:19.040768775 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/ConsoleTest/Makefile.am CUnit-2.1-3/Examples/ConsoleTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/ConsoleTest/Makefile.am   2023-07-23 15:06:33.863438862 +0200
++++ CUnit-2.1-3/Examples/ConsoleTest/Makefile.am       2023-07-23 15:06:33.979440515 +0200
 @@ -1,6 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
@@ -51,8 +43,9 @@
  
  if ENABLE_EXAMPLES
  if ENABLE_CONSOLE
---- CUnit-2.1-2/Examples/CursesTest/Makefile.am.orig   2013-10-15 20:25:15.027458272 +0200
-+++ CUnit-2.1-2/Examples/CursesTest/Makefile.am        2013-10-15 20:34:37.674101327 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/CursesTest/Makefile.am CUnit-2.1-3/Examples/CursesTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/CursesTest/Makefile.am    2023-07-23 15:06:33.863438862 +0200
++++ CUnit-2.1-3/Examples/CursesTest/Makefile.am        2023-07-23 15:06:33.980440529 +0200
 @@ -1,6 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
  
  if ENABLE_EXAMPLES
  if ENABLE_CURSES
---- CUnit-2.1-3/CUnit/Sources/Test/Makefile.am.orig    2018-04-14 20:13:35.236957272 +0200
-+++ CUnit-2.1-3/CUnit/Sources/Test/Makefile.am 2018-04-14 20:16:47.150288418 +0200
-@@ -2,7 +2,7 @@
+diff -urNp -x '*.orig' CUnit-2.1-3.org/doc/Makefile.am CUnit-2.1-3/doc/Makefile.am
+--- CUnit-2.1-3.org/doc/Makefile.am    2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/doc/Makefile.am        2023-07-23 15:06:33.979440515 +0200
+@@ -1,8 +1,8 @@
+ ## Process this file with automake to produce Makefile.in
  
- if ENABLE_TEST
- AM_CPPFLAGS = -I$(top_srcdir)/CUnit/Headers
--testdir=${datadir}/@PACKAGE@/Test
-+testdir=$(pkglibexecdir)/Test
+-docdir = $(prefix)/doc/@PACKAGE@
++pkgdocdir = $(datarootdir)/doc/@PACKAGE@
  
- test_PROGRAMS = test_cunit
- test_cunit_SOURCES = test_cunit.c
+-doc_DATA = \
++pkgdoc_DATA = \
+       CUnit_doc.css \
+       error_handling.html \
+       fdl.html \
+diff -urNp -x '*.orig' CUnit-2.1-3.org/doc/headers/Makefile.am CUnit-2.1-3/doc/headers/Makefile.am
+--- CUnit-2.1-3.org/doc/headers/Makefile.am    2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/doc/headers/Makefile.am        2023-07-23 15:06:33.979440515 +0200
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
++dochdrdir = $(datarootdir)/doc/@PACKAGE@/headers
+ INCLUDE_FILES = \
+       Automated.h \
index 876b45ccaf3957e237996885b4bbbc7567045097..396cff9b206c42fd7949c6dc65ceeaee0991c16b 100644 (file)
@@ -1,5 +1,6 @@
---- CUnit-2.1-2/CUnit/Sources/Curses/Curses.c.orig     2013-10-15 19:17:17.997629368 +0200
-+++ CUnit-2.1-2/CUnit/Sources/Curses/Curses.c  2013-10-15 19:30:33.654262646 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/CUnit/Sources/Curses/Curses.c CUnit-2.1-3/CUnit/Sources/Curses/Curses.c
+--- CUnit-2.1-3.org/CUnit/Sources/Curses/Curses.c      2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/CUnit/Sources/Curses/Curses.c  2023-07-23 15:06:33.413432452 +0200
 @@ -51,7 +51,7 @@
  #include <ctype.h>
  #include <assert.h>
index c71eb897c6b4e77f1f120b255467fd470e9b7601..a7d9fd041a904a5c314d53bb89af1d08fc301335 100644 (file)
@@ -1,5 +1,32 @@
---- CUnit-2.1-2/Examples/AutomatedTest/Makefile.am.orig        2010-10-14 10:43:09.000000000 +0200
-+++ CUnit-2.1-2/Examples/AutomatedTest/Makefile.am     2013-10-15 20:21:48.537466937 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/CUnit/Sources/Makefile.am CUnit-2.1-3/CUnit/Sources/Makefile.am
+--- CUnit-2.1-3.org/CUnit/Sources/Makefile.am  2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/CUnit/Sources/Makefile.am      2023-07-23 15:06:33.699436526 +0200
+@@ -69,6 +69,9 @@ libcunit_la_SOURCES =
+ libcunit_la_LIBADD = $(OBJECT_FILES_SHARED)
+ libcunit_la_LDFLAGS = -version-info @LIBTOOL_CURRENT@:@LIBTOOL_REVISION@:@LIBTOOL_AGE@
++if ENABLE_CURSES
++libcunit_la_LIBADD += -l$(CURSES_LIB)
++endif
+ if ENABLE_TEST
+ noinst_LIBRARIES = libcunit_test.a
+diff -urNp -x '*.orig' CUnit-2.1-3.org/CUnit/Sources/Test/Makefile.am CUnit-2.1-3/CUnit/Sources/Test/Makefile.am
+--- CUnit-2.1-3.org/CUnit/Sources/Test/Makefile.am     2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/CUnit/Sources/Test/Makefile.am 2023-07-23 15:06:33.698436512 +0200
+@@ -6,8 +6,7 @@ testdir=${datadir}/@PACKAGE@/Test
+ test_PROGRAMS = test_cunit
+ test_cunit_SOURCES = test_cunit.c
+-test_cunit_LDADD = ../libcunit_test.a
+-test_cunit_LDFLAGS = -L..
++test_cunit_LDADD = $(top_builddir)/CUnit/Sources/libcunit_test.a
+ INCLUDES = -DMEMTRACE -DCUNIT_BUILD_TESTS -DCUNIT_DO_NOT_DEFINE_UNLESS_BUILDING_TESTS
+ endif
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/AutomatedTest/Makefile.am CUnit-2.1-3/Examples/AutomatedTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/AutomatedTest/Makefile.am 2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/Examples/AutomatedTest/Makefile.am     2023-07-23 15:06:33.698436512 +0200
 @@ -8,8 +8,8 @@ if ENABLE_AUTOMATED
  example_PROGRAMS = AutomatedTest
  
@@ -11,8 +38,9 @@
  INCLUDES = -I..
  
  if ENABLE_CURSES
---- CUnit-2.1-2/Examples/BasicTest/Makefile.am.orig    2010-10-14 10:39:59.000000000 +0200
-+++ CUnit-2.1-2/Examples/BasicTest/Makefile.am 2013-10-15 20:22:26.284132020 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/BasicTest/Makefile.am CUnit-2.1-3/Examples/BasicTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/BasicTest/Makefile.am     2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/Examples/BasicTest/Makefile.am 2023-07-23 15:06:33.698436512 +0200
 @@ -8,8 +8,8 @@ if ENABLE_BASIC
  example_PROGRAMS = BasicTest
  
@@ -24,8 +52,9 @@
  INCLUDES = -I..
  
  if ENABLE_CURSES
---- CUnit-2.1-2/Examples/ConsoleTest/Makefile.am.orig  2010-10-14 10:42:08.000000000 +0200
-+++ CUnit-2.1-2/Examples/ConsoleTest/Makefile.am       2013-10-15 20:23:13.677463364 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/ConsoleTest/Makefile.am CUnit-2.1-3/Examples/ConsoleTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/ConsoleTest/Makefile.am   2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/Examples/ConsoleTest/Makefile.am       2023-07-23 15:06:33.698436512 +0200
 @@ -8,8 +8,8 @@ if ENABLE_CONSOLE
  example_PROGRAMS = ConsoleTest
  
@@ -37,8 +66,9 @@
  INCLUDES = -I..
  
  if ENABLE_CURSES
---- CUnit-2.1-2/Examples/CursesTest/Makefile.am.orig   2010-10-14 10:42:37.000000000 +0200
-+++ CUnit-2.1-2/Examples/CursesTest/Makefile.am        2013-10-15 20:23:46.394128658 +0200
+diff -urNp -x '*.orig' CUnit-2.1-3.org/Examples/CursesTest/Makefile.am CUnit-2.1-3/Examples/CursesTest/Makefile.am
+--- CUnit-2.1-3.org/Examples/CursesTest/Makefile.am    2014-04-24 02:54:45.000000000 +0200
++++ CUnit-2.1-3/Examples/CursesTest/Makefile.am        2023-07-23 15:06:33.698436512 +0200
 @@ -8,8 +8,8 @@ if ENABLE_CURSES
  example_PROGRAMS = CursesTest
  
  INCLUDES = -I..
  
  if ENABLE_CURSES
---- CUnit-2.1-2/CUnit/Sources/Test/Makefile.am.orig    2006-03-21 02:30:54.000000000 +0100
-+++ CUnit-2.1-2/CUnit/Sources/Test/Makefile.am 2013-10-15 20:41:40.950750230 +0200
-@@ -5,8 +5,7 @@
- test_PROGRAMS = test_cunit
- test_cunit_SOURCES = test_cunit.c
--test_cunit_LDADD = ../libcunit_test.a
--test_cunit_LDFLAGS = -L..
-+test_cunit_LDADD = $(top_builddir)/CUnit/Sources/libcunit_test.a
- INCLUDES = -I../../Headers -DMEMTRACE -DCUNIT_BUILD_TESTS -DCUNIT_DO_NOT_DEFINE_UNLESS_BUILDING_TESTS
- endif
---- CUnit-2.1-2/CUnit/Sources/Makefile.am.orig 2006-03-21 02:30:53.000000000 +0100
-+++ CUnit-2.1-2/CUnit/Sources/Makefile.am      2013-10-16 16:20:48.227781246 +0200
-@@ -69,6 +69,9 @@
- libcunit_la_LIBADD = $(OBJECT_FILES_SHARED)
- libcunit_la_LDFLAGS = -version-info @LIBTOOL_CURRENT@:@LIBTOOL_REVISION@:@LIBTOOL_AGE@
-+if ENABLE_CURSES
-+libcunit_la_LIBADD += -l$(CURSES_LIB)
-+endif
- if ENABLE_TEST
- noinst_LIBRARIES = libcunit_test.a
This page took 0.090371 seconds and 4 git commands to generate.