]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
- build shared lib
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Name:           colamd
3 Version:        2.6.0
4 Release:        0.2
5 License:        LGPL
6 Group:          Libraries
7 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/COLAMD-%{version}.tar.gz
8 # Source0-md5:  49e185756896c1e918a535ec409c48b9
9 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
10 Patch0:         %{name}-ufconfig.patch
11 Patch1:         %{name}-shared.patch
12 BuildRequires:  UFconfig
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The COLAMD column approximate minimum degree ordering algorithm
17 computes a permutation vector P such that the LU factorization of A
18 (:,P) tends to be sparser than that of A. The Cholesky factorization
19 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
20 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
21 COLAMD, available as a MATLAB-callable function. It constructs a
22 matrix M such that M'*M has the same pattern as A, and then uses
23 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
24 faster and generate better orderings than their MATLAB counterparts,
25 colmmd and symmmd.
26
27 %package devel
28 Summary:        Header files for colamd library
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       UFconfig
32
33 %description devel
34 Header files for colamd library.
35
36 %package static
37 Summary:        Static colamd library
38 Group:          Development/Libraries
39 Requires:       %{name}-devel = %{version}-%{release}
40
41 %description static
42 Static colamd library.
43
44 %prep
45 %setup -q -n COLAMD
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 %{__make} \
51         CC="%{__cc}" \
52         CFLAGS="%{rpmcflags}"
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -D colamd.h $RPM_BUILD_ROOT%{_includedir}/colamd.h
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README.txt
70 %attr(755,root,root) %{_libdir}/libcolamd.so.*.*.*
71
72 %files devel
73 %defattr(644,root,root,755)
74 %{_libdir}/libcolamd.la
75 %{_libdir}/libcolamd.so
76 %{_includedir}/colamd.h
77
78 %files static
79 %defattr(644,root,root,755)
80 %{_libdir}/libcolamd.a
This page took 0.062556 seconds and 3 git commands to generate.