]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
192033be670c66d63fdbe1dd83c958943228f996
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Summary(pl.UTF-8):      COLAMD - przybliżony algorytm minimalnego stopnia dla kolumn
3 Name:           COLAMD
4 Version:        2.7.1
5 Release:        2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/%{name}-%{version}.tar.gz
9 # Source0-md5:  de62fb5235499d1110b86751b0d4ca46
10 Patch0:         colamd-ufconfig.patch
11 Patch1:         colamd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
13 BuildRequires:  UFconfig
14 BuildRequires:  libtool >= 2:1.5
15 Obsoletes:      colamd
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The COLAMD column approximate minimum degree ordering algorithm
20 computes a permutation vector P such that the LU factorization of A
21 (:,P) tends to be sparser than that of A. The Cholesky factorization
22 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
23 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
24 COLAMD, available as a MATLAB-callable function. It constructs a
25 matrix M such that M'*M has the same pattern as A, and then uses
26 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
27 faster and generate better orderings than their MATLAB counterparts,
28 colmmd and symmmd.
29
30 %description -l pl.UTF-8
31 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
32 (COLAMD) oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
33 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
34 jest rzadszy niż A'*A. SYMAND to przybliżony algorytm porządkowania
35 minimalnego stopnia dla macierzy symetrycznych oparty na COLAMD,
36 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
37 że M'*M ma ten sam wzór co A, a następnie używa algorytmu COLAMD do
38 obliczenia porządku kolumn M. COLAMD i SYMAMD są szybsze i generują
39 lepsze uporządkowania niż ich odpowiedniki z MATLAB-a: colmmd i
40 symmmd.
41
42 %package devel
43 Summary:        Header files for colamd library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colamd
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       UFconfig
48 Obsoletes:      colamd-devel
49
50 %description devel
51 Header files for colamd library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki colamd.
55
56 %package static
57 Summary:        Static colamd library
58 Summary(pl.UTF-8):      Statyczna biblioteka colamd
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61 Obsoletes:      colamd-static
62
63 %description static
64 Static colamd library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka colamd.
68
69 %prep
70 %setup -q -n %{name}
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %{__make} \
76         CC="%{__cc}" \
77         CFLAGS="%{rpmcflags} -fPIC" \
78         libdir=%{_libdir}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} -C Lib install \
84         DESTDIR=$RPM_BUILD_ROOT \
85         libdir=%{_libdir}
86
87 install -D Include/colamd.h $RPM_BUILD_ROOT%{_includedir}/colamd.h
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.txt
98 %attr(755,root,root) %{_libdir}/libcolamd.so.*.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libcolamd.so
103 %{_libdir}/libcolamd.la
104 %{_includedir}/colamd.h
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libcolamd.a
This page took 0.02213 seconds and 2 git commands to generate.