]> git.pld-linux.org Git - packages/CGAL.git/blame - CGAL.spec
leave comment why CMAKE_BUILD_TYPE override is neccessary
[packages/CGAL.git] / CGAL.spec
CommitLineData
d4e9703c 1%define boost_version 1.32
d4e9703c 2Summary: Computational Geometry Algorithms Library
3Name: CGAL
b2d9afe8 4Version: 4.6
8db60ca1 5Release: 1
b2d9afe8 6License: GPLv3+ and LGPLv3+
d4e9703c 7Group: Libraries
b2d9afe8
AM
8Source0: https://gforge.inria.fr/frs/download.php/file/34705/%{name}-%{version}.tar.xz
9# Source0-md5: 65fa7e17cd654ef68da47df608000007
fcd3e9d3 10URL: http://www.cgal.org/
d4e9703c 11BuildRequires: blas-devel
23c63792 12BuildRequires: boost-devel >= %{boost_version}
b2d9afe8 13BuildRequires: cmake
23c63792 14BuildRequires: gmp-c++-devel
d4e9703c 15BuildRequires: gmp-devel
23c63792
ER
16BuildRequires: lapack-devel
17BuildRequires: mpfr-devel
d4e9703c 18BuildRequires: qt-devel >= 3.0
23c63792 19BuildRequires: sed >= 4.0
d4e9703c 20BuildRequires: zlib-devel
d4e9703c 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Libraries for CGAL applications. CGAL is a collaborative effort of
25several sites in Europe and Israel. The goal is to make the most
26important of the solutions and methods developed in computational
27geometry available to users in industry and academia in a C++ library.
28The goal is to provide easy access to useful, reliable geometric
29algorithms.
30
d4e9703c 31%package devel
32Summary: Development files and tools for CGAL applications
33Group: Development/Libraries
d4e9703c 34Requires: %{name} = %{version}-%{release}
35Requires: blas-devel
23c63792
ER
36Requires: boost-devel >= %{boost_version}
37Requires: gmp-c++-devel
38Requires: gmp-devel
d4e9703c 39Requires: lapack-devel
23c63792 40Requires: mpfr-devel
d4e9703c 41Requires: qt-devel
42Requires: zlib-devel
23c63792 43
d4e9703c 44%description devel
45The %{name}-devel package provides the headers files and tools you may
46need to develop applications using CGAL.
47
d4e9703c 48%package demos-source
49Summary: Examples and demos of CGAL algorithms
50Group: Documentation
51Requires: %{name}-devel = %{version}-%{release}
52
53%description demos-source
54The %{name}-demos-source package provides the sources of examples and
55demos of CGAL algorithms.
56
57
58%prep
59%setup -q
d4e9703c 60
61%build
b2d9afe8
AM
62install -d build
63cd build
f7efb94b
ER
64# override build type, because:
65# PLD is not a valid build type: only Release or Debug is allowed
66
67# XXX: what is ${CHANGE_SOVERSION} here?
b2d9afe8 68%cmake \
f7efb94b 69 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
b2d9afe8
AM
70 -DCGAL_INSTALL_LIB_DIR=%{_lib} \
71 -DCGAL_INSTALL_DOC_DIR= ${CHANGE_SOVERSION} \
72 ..
73
74%{__make}
d4e9703c 75
76%install
77rm -rf $RPM_BUILD_ROOT
b2d9afe8
AM
78%{__make} -C build install \
79 DESTDIR=$RPM_BUILD_ROOT
d4e9703c 80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
23c63792
ER
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
d4e9703c 86
87%files
88%defattr(644,root,root,755)
b2d9afe8
AM
89%doc AUTHORS LICENSE LICENSE.FREE_USE LICENSE.LGPL CHANGES
90%attr(755,root,root) %{_libdir}/libCGAL.so.*.*.*
91%attr(755,root,root) %ghost %{_libdir}/libCGAL.so.11
92%attr(755,root,root) %{_libdir}/libCGAL_Core.so.*.*.*
93%attr(755,root,root) %ghost %{_libdir}/libCGAL_Core.so.11
94%attr(755,root,root) %{_libdir}/libCGAL_ImageIO.so.*.*.*
95%attr(755,root,root) %ghost %{_libdir}/libCGAL_ImageIO.so.11
96%attr(755,root,root) %{_libdir}/libCGAL_Qt4.so.*.*.*
97%attr(755,root,root) %ghost %{_libdir}/libCGAL_Qt4.so.11
d4e9703c 98
99%files devel
100%defattr(644,root,root,755)
b2d9afe8
AM
101%attr(755,root,root) %{_bindir}/cgal_create_CMakeLists
102%attr(755,root,root) %{_bindir}/cgal_create_cmake_script
d4e9703c 103%{_includedir}/CGAL
b2d9afe8
AM
104%{_libdir}/CGAL
105%attr(755,root,root) %{_libdir}/libCGAL*.so
106%{_mandir}/man1/cgal_create_cmake_script.1*
This page took 0.083651 seconds and 4 git commands to generate.