]> git.pld-linux.org Git - packages/CEGUI.git/commitdiff
- fix building with ogre 1.12 auto/th/CEGUI-0.8.7-6
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 20 Oct 2019 09:33:52 +0000 (11:33 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 20 Oct 2019 09:33:52 +0000 (11:33 +0200)
- rel 6

CEGUI.spec
ogre1.12.patch [new file with mode: 0644]

index b91b1c77035834991e5757881fb88d76dd26683b..5d27cb733ea36f9e013de730ad43d23d9292aeaf 100644 (file)
@@ -10,7 +10,7 @@ Summary:      CEGUI - a free library providing windowing and widgets
 Summary(pl.UTF-8):     CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
 Name:          CEGUI
 Version:       0.8.7
-Release:       5
+Release:       6
 License:       LGPL v2.1+ (with MIT parts)
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
@@ -22,6 +22,7 @@ Patch1:               %{name}-glfw3.patch
 Patch3:                x32.patch
 Patch4:                cxx11.patch
 Patch5:                python2.patch
+Patch6:                ogre1.12.patch
 URL:           http://www.cegui.org.uk/
 BuildRequires: DevIL-devel
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 1.2.0}
@@ -464,6 +465,7 @@ Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %build
 install -d build
diff --git a/ogre1.12.patch b/ogre1.12.patch
new file mode 100644 (file)
index 0000000..b932862
--- /dev/null
@@ -0,0 +1,22 @@
+--- cegui-0.8.7/cmake/FindOgre.cmake~  2019-10-20 11:06:37.000000000 +0200
++++ cegui-0.8.7/cmake/FindOgre.cmake   2019-10-20 11:15:03.776472437 +0200
+@@ -249,7 +249,7 @@
+         endif ()
+     endif()
+-    file (STRINGS "${OGRE_H_PATH}/OgrePrerequisites.h" _CEGUIOGREVERSIONDEFINES REGEX ".*#define OGRE_VERSION_.*[0-9]+")
++    file (STRINGS "${OGRE_H_PATH}/OgreBuildSettings.h" _CEGUIOGREVERSIONDEFINES REGEX ".*#define OGRE_VERSION_.*[0-9]+")
+     foreach (ver MAJOR MINOR PATCH)
+         set (CEGUI_FOUND_OGRE_VERSION_${ver} 0)
+--- cegui-0.8.7/cegui/src/RendererModules/Ogre/Texture.cpp.orig        2016-04-23 20:19:40.000000000 +0200
++++ cegui-0.8.7/cegui/src/RendererModules/Ogre/Texture.cpp     2019-10-20 11:23:14.259789302 +0200
+@@ -243,7 +243,7 @@
+     // address the issue as close to the source of the problem as possible.
+     Ogre::PixelBox pb(area.getWidth(), area.getHeight(),
+                       1, Ogre::PF_A8R8G8B8, const_cast<void*>(sourceData));
+-    Ogre::Image::Box box(area.left(), area.top(), area.right(), area.bottom());
++    Ogre::Box box(area.left(), area.top(), area.right(), area.bottom());
+     d_texture->getBuffer()->blitFromMemory(pb, box);
+ }
This page took 0.086496 seconds and 4 git commands to generate.