]> git.pld-linux.org Git - packages/CEGUI.git/blobdiff - CEGUI.spec
Release 9 (by relup.sh)
[packages/CEGUI.git] / CEGUI.spec
index 6d15f7666dba622386a97a100b6671370316e3c3..1a3bee0a58285ca96c170e6c8b269d7af0356ea5 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without xercesc         # build XercesParser
-%bcond_without ogre            # build without Ogre renderer
+%bcond_with    ogre            # build without Ogre renderer
 %bcond_without opengl          # build without OpenGL renderer
 %bcond_with    directb         # unsupported by upstream
 %bcond_with    samples         # build samples
@@ -9,20 +9,29 @@
 Summary:       CEGUI - a free library providing windowing and widgets
 Summary(pl.UTF-8):     CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
 Name:          CEGUI
-Version:       0.8.4
-Release:       2
+Version:       0.8.7
+Release:       9
 License:       LGPL v2.1+ (with MIT parts)
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
-# Source0-md5: 344917301b5ed867a07575ee6a828667
-Source1:       http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
-# Source1-md5: 1096bf8c84bf6a22e8892ab9258c22f6
+# Source0-md5: cebcc95e205b9ad353db0d65b9b2d505
+Source1:       http://downloads.sourceforge.net/crayzedsgui/cegui-docs.%{version}.zip
+# Source1-md5: 5f3b19f82cf1e11b4406560b8e809f20
 Patch0:                pthread.patch
 Patch1:                %{name}-glfw3.patch
+Patch3:                x32.patch
+Patch4:                cxx11.patch
+Patch5:                python2.patch
+Patch6:                ogre1.12.patch
+Patch7:                ogre13.patch
 URL:           http://www.cegui.org.uk/
 BuildRequires: DevIL-devel
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 1.2.0}
 BuildRequires: FreeImage-devel
+BuildRequires: GLM
+BuildRequires: OpenGL-devel
+BuildRequires: SDL2-devel
+BuildRequires: SDL2_image-devel
 BuildRequires: SILLY-devel >= 0.1.0
 BuildRequires: boost-devel >= 1.36.0
 BuildRequires: boost-python-devel >= 1.36.0
@@ -32,6 +41,8 @@ BuildRequires:        doxygen
 BuildRequires: expat-devel
 BuildRequires: fribidi-devel
 BuildRequires: freetype-devel >= 2.0
+BuildRequires: glew-devel
+# for SampleFramework
 BuildRequires: glfw-devel
 BuildRequires: gtk+2-devel >= 2:2.4
 BuildRequires: irrlicht-devel >= 1.4
@@ -46,7 +57,7 @@ BuildRequires:        ois-devel >= 1.0.0
 %endif
 BuildRequires: pcre-devel >= 5.0
 BuildRequires: pkgconfig
-BuildRequires: python-devel
+BuildRequires: python-devel >= 2
 BuildRequires: rapidxml
 BuildRequires: sed >= 4.0
 BuildRequires: tinyxml-devel
@@ -183,6 +194,33 @@ Header files for CEGUI FreeImageImageCodec library.
 %description ImageCodec-FreeImage-devel -l pl.UTF-8
 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
 
+%package ImageCodec-SDL2
+Summary:       SDL2ImageCodec library for CEGUI
+Summary(pl.UTF-8):     Biblioteka SDL2ImageCodec dla CEGUI
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      SDL2
+
+%description ImageCodec-SDL2
+SDL2ImageCodec library for CEGUI.
+
+%description ImageCodec-SDL2 -l pl.UTF-8
+Biblioteka SDL2ImageCodec dla CEGUI
+
+%package ImageCodec-SDL2-devel
+Summary:       Header files for CEGUI SDL2ImageCodec library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki CEGUI SDL2ImageCodec
+Group:         Development/Libraries
+Requires:      %{name}-ImageCodec-SDL2 = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      SDL2-devel >= 0.1.0
+
+%description ImageCodec-SDL2-devel
+Header files for CEGUI SDL2ImageCodec library.
+
+%description ImageCodec-SDL2-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki CEGUI SDL2ImageCodec.
+
 %package ImageCodec-SILLY
 Summary:       SILLYImageCodec library for CEGUI
 Summary(pl.UTF-8):     Biblioteka SILLYImageCodec dla CEGUI
@@ -425,6 +463,11 @@ Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
 %setup -q -a 1 -n cegui-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 install -d build
@@ -466,7 +509,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc doc/README.orig
+%doc README.md
 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
@@ -525,6 +568,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
 
+%files ImageCodec-SDL2
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISDL2ImageCodec.so
+
+%files ImageCodec-SDL2-devel
+%defattr(644,root,root,755)
+%{_includedir}/cegui-0/%{name}/ImageCodecModules/SDL2
+
 %files ImageCodec-SILLY
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
This page took 0.130304 seconds and 4 git commands to generate.