]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
e7206faa41af20a075f687cb3f67b743d30711b4
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - gcc33 patch only for AC-branch
3 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
4 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
5 # - if You want have irrlight renderer enabled pass CC=athlon-pld-linux-g++ to configure
6 #       because irrlight.h test is compiled by CC
7 #
8 # Conditional build:
9 %bcond_with     xercesc
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.5.0
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}b.tar.gz
19 # Source0-md5:  b42322a33c6a06eede76b15f75694a17
20 Source1:        http://dl.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  e268b5812f146ee1ff9ba4c07ff501b7
22 Patch0:         %{name}-gcc33.patch
23 Patch1:         %{name}-link.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 BuildRequires:  FreeImage-devel
27 BuildRequires:  OpenGL-GLU-devel
28 BuildRequires:  OpenGL-glut-devel
29 BuildRequires:  SILLY-devel >= 0.1.0
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  corona-devel >= 1.0.2
33 BuildRequires:  expat-devel
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  irrlicht-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libxml2-devel >= 1:2.6
39 BuildRequires:  lua50-devel >= 5.0
40 BuildRequires:  pcre-devel >= 5.0
41 BuildRequires:  pkgconfig
42 %if %{with xercesc}
43 BuildRequires:  xerces-c-devel
44 BuildConflicts: xerces-c-devel >= 2.8.0
45 Conflicts:      xerces-c >= 2.8.0
46 %endif
47 # for irrlicht
48 BuildRequires:  xorg-lib-libXxf86vm-devel
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 CEGUI stands for Crazy Eddie's Gui System; a free library providing
53 windowing and widgets for graphics APIs / engines where such
54 functionality is not natively available, or severely lacking. The
55 library is object orientated, written in C++, and targeted at games
56 developers who should be spending their time creating great games, not
57 building GUI sub-systems!
58
59 %description -l pl.UTF-8
60 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
61 zapewniającą okienka i widgety dla graficznych API i silników tam,
62 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
63 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
64 skierowana dla programistów gier, którzy powinni spędzać czas na
65 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
66
67 %package devel
68 Summary:        Development files for CEGUI
69 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       freetype-devel >= 2.0
73 Requires:       libstdc++-devel
74 Requires:       pcre-devel >= 5.0
75
76 %description devel
77 CEGUI headers and documentation.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe i dokumentacja do CEGUI.
81
82 %prep
83 %setup -q -b 1
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --with-default-image-codec=FreeImageImageCodec \
95         --with-default-parser=LibxmlParser \
96 %if %{with xercesc}
97         --enable-xerces-c
98 %else
99         --disable-xerces-c
100 %endif
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog README
119 %attr(755,root,root) %{_libdir}/libCEGUI*.so.*.*.*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc documentation
124 %attr(755,root,root) %{_libdir}/libCEGUI*.so
125 %{_libdir}/libCEGUI*.la
126 %{_includedir}/%{name}
127 %{_pkgconfigdir}/CEGUI.pc
128 %{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.052654 seconds and 3 git commands to generate.