]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
5732e09dc9249a16ae0472c9539aef6071759e60
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_without  ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     directb         # unsupported by upstream
7 %bcond_with     samples         # build samples
8 #
9 Summary:        CEGUI - a free library providing windowing and widgets
10 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
11 Name:           CEGUI
12 Version:        0.8.4
13 Release:        3
14 License:        LGPL v2.1+ (with MIT parts)
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
17 # Source0-md5:  344917301b5ed867a07575ee6a828667
18 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
19 # Source1-md5:  1096bf8c84bf6a22e8892ab9258c22f6
20 Patch0:         pthread.patch
21 Patch1:         %{name}-glfw3.patch
22 Patch2:         %{name}-python.patch
23 URL:            http://www.cegui.org.uk/
24 BuildRequires:  DevIL-devel
25 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.2.0}
26 BuildRequires:  FreeImage-devel
27 BuildRequires:  GLM
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  SILLY-devel >= 0.1.0
30 BuildRequires:  boost-devel >= 1.36.0
31 BuildRequires:  boost-python-devel >= 1.36.0
32 BuildRequires:  cmake >= 2.8
33 BuildRequires:  corona-devel
34 BuildRequires:  doxygen
35 BuildRequires:  expat-devel
36 BuildRequires:  fribidi-devel
37 BuildRequires:  freetype-devel >= 2.0
38 BuildRequires:  glew-devel
39 # for SampleFramework
40 BuildRequires:  glfw-devel
41 BuildRequires:  gtk+2-devel >= 2:2.4
42 BuildRequires:  irrlicht-devel >= 1.4
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:1.5
45 BuildRequires:  libxml2-devel >= 1:2.6
46 BuildRequires:  lua51-devel >= 5.1
47 BuildRequires:  minizip-devel
48 %if %{with ogre}
49 BuildRequires:  ogre-devel >= 1.6.0
50 BuildRequires:  ois-devel >= 1.0.0
51 %endif
52 BuildRequires:  pcre-devel >= 5.0
53 BuildRequires:  pkgconfig
54 BuildRequires:  python-devel >= 2
55 BuildRequires:  rapidxml
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  tinyxml-devel
58 BuildRequires:  tolua++-devel
59 %{?with_xercesc:BuildRequires:  xerces-c-devel}
60 # for irrlicht renderer
61 BuildRequires:  xorg-lib-libXxf86vm-devel
62 %if %{with opengl}
63 BuildRequires:  GLM
64 BuildRequires:  OpenGL-GLU-devel
65 BuildRequires:  glew-devel
66 BuildRequires:  glfw-devel
67 %endif
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 CEGUI stands for Crazy Eddie's Gui System; a free library providing
72 windowing and widgets for graphics APIs / engines where such
73 functionality is not natively available, or severely lacking. The
74 library is object orientated, written in C++, and targeted at games
75 developers who should be spending their time creating great games, not
76 building GUI sub-systems!
77
78 %description -l pl.UTF-8
79 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
80 zapewniającą okienka i widgety dla graficznych API i silników tam,
81 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
82 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
83 skierowana dla programistów gier, którzy powinni spędzać czas na
84 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
85
86 %package devel
87 Summary:        Development files for CEGUI
88 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       freetype-devel >= 2.0
92 Requires:       libstdc++-devel
93 Requires:       pcre-devel >= 5.0
94
95 %description devel
96 CEGUI headers.
97
98 %description devel -l pl.UTF-8
99 Pliki nagłówkowe CEGUI.
100
101 %package docs
102 Summary:        Documentation files for CEGUI
103 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
104 Group:          Documentation
105 Requires:       %{name} = %{version}-%{release}
106
107 %description docs
108 CEGUI documentation.
109
110 %description docs -l pl.UTF-8
111 Dokumentacja CEGUI.
112
113 %package ImageCodec-Corona
114 Summary:        CoronaImageCodec library for CEGUI
115 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description ImageCodec-Corona
120 CoronaImageCodec library for CEGUI.
121
122 %description ImageCodec-Corona -l pl.UTF-8
123 Biblioteka CoronaImageCodec dla CEGUI
124
125 %package ImageCodec-Corona-devel
126 Summary:        Header files for CEGUI CoronaImageCodec library
127 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
128 Group:          Development/Libraries
129 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
130 Requires:       %{name}-devel = %{version}-%{release}
131 Requires:       corona-devel
132
133 %description ImageCodec-Corona-devel
134 Header files for CEGUI CoronaImageCodec library.
135
136 %description ImageCodec-Corona-devel -l pl.UTF-8
137 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
138
139 %package ImageCodec-DevIL
140 Summary:        DevILImageCodec library for CEGUI
141 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description ImageCodec-DevIL
146 DevILImageCodec library for CEGUI.
147
148 %description ImageCodec-DevIL -l pl.UTF-8
149 Biblioteka DevILImageCodec dla CEGUI
150
151 %package ImageCodec-DevIL-devel
152 Summary:        Header files for CEGUI DevILImageCodec library
153 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
154 Group:          Development/Libraries
155 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
156 Requires:       %{name}-devel = %{version}-%{release}
157 Requires:       DevIL-devel
158
159 %description ImageCodec-DevIL-devel
160 Header files for CEGUI DevILImageCodec library.
161
162 %description ImageCodec-DevIL-devel -l pl.UTF-8
163 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
164
165 %package ImageCodec-FreeImage
166 Summary:        FreeImageImageCodec library for CEGUI
167 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
168 Group:          Libraries
169 Requires:       %{name} = %{version}-%{release}
170
171 %description ImageCodec-FreeImage
172 FreeImageImageCodec library for CEGUI.
173
174 %description ImageCodec-FreeImage -l pl.UTF-8
175 Biblioteka FreeImageImageCodec dla CEGUI
176
177 %package ImageCodec-FreeImage-devel
178 Summary:        Header files for CEGUI FreeImageImageCodec library
179 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
180 Group:          Development/Libraries
181 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
182 Requires:       %{name}-devel = %{version}-%{release}
183 Requires:       FreeImage-devel
184
185 %description ImageCodec-FreeImage-devel
186 Header files for CEGUI FreeImageImageCodec library.
187
188 %description ImageCodec-FreeImage-devel -l pl.UTF-8
189 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
190
191 %package ImageCodec-SILLY
192 Summary:        SILLYImageCodec library for CEGUI
193 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       SILLY >= 0.1.0
197
198 %description ImageCodec-SILLY
199 SILLYImageCodec library for CEGUI.
200
201 %description ImageCodec-SILLY -l pl.UTF-8
202 Biblioteka SILLYImageCodec dla CEGUI
203
204 %package ImageCodec-SILLY-devel
205 Summary:        Header files for CEGUI SILLYImageCodec library
206 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
207 Group:          Development/Libraries
208 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
209 Requires:       %{name}-devel = %{version}-%{release}
210 Requires:       SILLY-devel >= 0.1.0
211
212 %description ImageCodec-SILLY-devel
213 Header files for CEGUI SILLYImageCodec library.
214
215 %description ImageCodec-SILLY-devel -l pl.UTF-8
216 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
217
218 %package Parser-Expat
219 Summary:        Expat-based XML parser module
220 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
221 Group:          Libraries
222 Requires:       %{name} = %{version}-%{release}
223
224 %description Parser-Expat
225 Expat-based XML parser module.
226
227 %description Parser-Expat -l pl.UTF-8
228 Moduł analizatora XML oparty na bibliotece Expat.
229
230 %package Parser-LibXML
231 Summary:        LibXML-based XML parser module
232 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       libxml2 >= 1:2.6
236
237 %description Parser-LibXML
238 LibXML-based XML parser module.
239
240 %description Parser-LibXML -l pl.UTF-8
241 Moduł analizatora XML oparty na bibliotece LibXML.
242
243 %package Parser-RapidXML
244 Summary:        RapidXML-based XML parser module
245 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
246 Group:          Libraries
247 Requires:       %{name} = %{version}-%{release}
248
249 %description Parser-RapidXML
250 RapidXML-based XML parser module.
251
252 %description Parser-RapidXML -l pl.UTF-8
253 Moduł analizatora XML oparty na bibliotece RapidXML.
254
255 %package Parser-TinyXML
256 Summary:        TinyXML-based XML parser module
257 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description Parser-TinyXML
262 TinyXML-based XML parser module.
263
264 %description Parser-TinyXML -l pl.UTF-8
265 Moduł analizatora XML oparty na bibliotece TinyXML.
266
267 %package Parser-Xerces
268 Summary:        Xerces-based XML parser module
269 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272
273 %description Parser-Xerces
274 Xerces-based XML parser module.
275
276 %description Parser-Xerces -l pl.UTF-8
277 Moduł analizatora XML oparty na bibliotece Xerces.
278
279 %package Renderer-DirectFB
280 Summary:        DirectFBRenderer library for CEGUI
281 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
282 Group:          Libraries
283 Requires:       %{name} = %{version}-%{release}
284 Requires:       DirectFB >= 1.2.0
285
286 %description Renderer-DirectFB
287 DirectFBRenderer library for CEGUI.
288
289 %description Renderer-DirectFB -l pl.UTF-8
290 Biblioteka DirectFBRenderer dla CEGUI
291
292 %package Renderer-DirectFB-devel
293 Summary:        Header files for CEGUI DirectFBRenderer library
294 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
295 Group:          Development/Libraries
296 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
297 Requires:       %{name}-devel = %{version}-%{release}
298 Requires:       DirectFB-devel >= 1.2.0
299
300 %description Renderer-DirectFB-devel
301 Header files for CEGUI DirectFBRenderer library.
302
303 %description Renderer-DirectFB-devel -l pl.UTF-8
304 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
305
306 %package Renderer-Irrlicht
307 Summary:        IrrlichtRenderer library for CEGUI
308 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
309 Group:          Libraries
310 Requires:       %{name} = %{version}-%{release}
311 Requires:       irrlicht >= 1.4
312
313 %description Renderer-Irrlicht
314 IrrlichtRenderer library for CEGUI.
315
316 %description Renderer-Irrlicht -l pl.UTF-8
317 Biblioteka IrrlichtRenderer dla CEGUI
318
319 %package Renderer-Irrlicht-devel
320 Summary:        Header files for CEGUI IrrlichtRenderer library
321 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
322 Group:          Development/Libraries
323 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
324 Requires:       %{name}-devel = %{version}-%{release}
325 Requires:       irrlicht-devel >= 1.4
326
327 %description Renderer-Irrlicht-devel
328 Header files for CEGUI IrrlichtRenderer library.
329
330 %description Renderer-Irrlicht-devel -l pl.UTF-8
331 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
332
333 %package Renderer-Ogre
334 Summary:        OgreRenderer library for CEGUI
335 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
336 Group:          Libraries
337 Requires:       %{name} = %{version}-%{release}
338 Obsoletes:      CEGUI-Ogre
339
340 %description Renderer-Ogre
341 OgreRenderer library for CEGUI.
342
343 %description Renderer-Ogre -l pl.UTF-8
344 Biblioteka OgreRenderer dla CEGUI
345
346 %package Renderer-Ogre-devel
347 Summary:        Header files for CEGUI OgreRenderer library
348 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
349 Group:          Development/Libraries
350 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
351 Requires:       %{name}-devel = %{version}-%{release}
352 Requires:       ogre-devel >= 1.6.0
353 Obsoletes:      CEGUI-Ogre-devel
354
355 %description Renderer-Ogre-devel
356 Header files for CEGUI OgreRenderer library.
357
358 %description Renderer-Ogre-devel -l pl.UTF-8
359 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
360
361 %package Renderer-OpenGL
362 Summary:        OpenGLRenderer library for CEGUI
363 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
364 Group:          Libraries
365 Requires:       %{name} = %{version}-%{release}
366 Obsoletes:      CEGUI-OpenGL
367
368 %description Renderer-OpenGL
369 OpenGLRenderer library for CEGUI.
370
371 %description Renderer-OpenGL -l pl.UTF-8
372 Biblioteka OpenGLRenderer dla CEGUI.
373
374 %package Renderer-OpenGL-devel
375 Summary:        Header files for CEGUI OpenGLRenderer library
376 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
377 Group:          Development/Libraries
378 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
379 Requires:       %{name}-devel = %{version}-%{release}
380 Requires:       OpenGL-GLU-devel
381 Requires:       OpenGL-glut-devel
382 Requires:       glew-devel
383 Obsoletes:      CEGUI-OpenGL-devel
384
385 %description Renderer-OpenGL-devel
386 Header files for CEGUI OpenGLRenderer library.
387
388 %description Renderer-OpenGL-devel -l pl.UTF-8
389 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
390
391 %package -n python-CEGUI
392 Summary:        Python binding for CEGUI
393 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
394 Group:          Libraries/Python
395 Requires:       %{name} = %{version}-%{release}
396
397 %description -n python-CEGUI
398 Python binding for CEGUI.
399
400 %description -n python-CEGUI -l pl.UTF-8
401 Wiązania Pythona do CEGUI.
402
403 %package -n python-CEGUI-Renderer-Ogre
404 Summary:        Python binding for CEGUI OgreRenderer library
405 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
406 Group:          Libraries/Python
407 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
408 Requires:       python-CEGUI = %{version}-%{release}
409
410 %description -n python-CEGUI-Renderer-Ogre
411 Python binding for CEGUI OgreRenderer library.
412
413 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
414 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
415
416 %package -n python-CEGUI-Renderer-OpenGL
417 Summary:        Python binding for CEGUI OpenGLRenderer library
418 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
419 Group:          Libraries/Python
420 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
421 Requires:       python-CEGUI = %{version}-%{release}
422
423 %description -n python-CEGUI-Renderer-OpenGL
424 Python binding for CEGUI OpenGLRenderer library.
425
426 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
427 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
428
429 %prep
430 %setup -q -a 1 -n cegui-%{version}
431 %patch0 -p1
432 %patch1 -p1
433 %patch2 -p1
434
435 %build
436 install -d build
437 cd build
438 %cmake .. \
439         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
440         -DCEGUI_BUILD_RENDERER_DIRECTFB:BOOL=%{?with_directfb:ON}%{!?with_directfb:OFF} \
441         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
442         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
443         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
444         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
445         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
446         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
447
448 %{__make} -j1
449
450 %install
451 rm -rf $RPM_BUILD_ROOT
452
453 %{__make} -C build install/fast \
454         DESTDIR=$RPM_BUILD_ROOT
455
456 %if %{without samples}
457 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
458 %endif
459
460 %clean
461 rm -rf $RPM_BUILD_ROOT
462
463 %post   -p /sbin/ldconfig
464 %postun -p /sbin/ldconfig
465
466 %post   Renderer-Irrlicht -p /sbin/ldconfig
467 %postun Renderer-Irrlicht -p /sbin/ldconfig
468 %post   Renderer-Ogre -p /sbin/ldconfig
469 %postun Renderer-Ogre -p /sbin/ldconfig
470 %post   Renderer-OpenGL -p /sbin/ldconfig
471 %postun Renderer-OpenGL -p /sbin/ldconfig
472
473 %files
474 %defattr(644,root,root,755)
475 %doc doc/README.orig
476 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
478 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
480 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
482 # plugins
483 %dir %{_libdir}/cegui-0.8
484 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
485
486 %files docs
487 %defattr(644,root,root,755)
488 %doc cegui-docs-%{version}/*
489
490 %files devel
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
493 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
494 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
495 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
496 %dir %{_includedir}/cegui-0
497 %dir %{_includedir}/cegui-0/%{name}
498 %{_includedir}/cegui-0/%{name}/*.h
499 %{_includedir}/cegui-0/%{name}/CommonDialogs
500 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
501 %dir %{_includedir}/cegui-0/%{name}/RendererModules
502 %{_includedir}/cegui-0/%{name}/ScriptModules
503 %{_includedir}/cegui-0/%{name}/WindowRendererSets
504 %{_includedir}/cegui-0/%{name}/XMLParserModules
505 %{_includedir}/cegui-0/%{name}/falagard
506 %{_includedir}/cegui-0/%{name}/widgets
507 %{_pkgconfigdir}/CEGUI-0.pc
508 %{_pkgconfigdir}/CEGUI-0-LUA.pc
509
510 %files ImageCodec-Corona
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
513
514 %files ImageCodec-Corona-devel
515 %defattr(644,root,root,755)
516 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
517
518 %files ImageCodec-DevIL
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
521
522 %files ImageCodec-DevIL-devel
523 %defattr(644,root,root,755)
524 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
525
526 %files ImageCodec-FreeImage
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
529
530 %files ImageCodec-FreeImage-devel
531 %defattr(644,root,root,755)
532 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
533
534 %files ImageCodec-SILLY
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
537
538 %files ImageCodec-SILLY-devel
539 %defattr(644,root,root,755)
540 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
541
542 %files Parser-Expat
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
545
546 %files Parser-LibXML
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
549
550 %files Parser-RapidXML
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
553
554 %files Parser-TinyXML
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
557
558 %files Parser-Xerces
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
561
562 %if %{with directfb}
563 %files Renderer-DirectFB
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
567
568 %files Renderer-DirectFB-devel
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
571 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
572 %endif
573
574 %files Renderer-Irrlicht
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
578
579 %files Renderer-Irrlicht-devel
580 %defattr(644,root,root,755)
581 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
582 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
583 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
584
585 %if %{with ogre}
586 %files Renderer-Ogre
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
590
591 %files Renderer-Ogre-devel
592 %defattr(644,root,root,755)
593 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
594 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
595 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
596 %endif
597
598 %if %{with opengl}
599 %files Renderer-OpenGL
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
602 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
603
604 %files Renderer-OpenGL-devel
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
607 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
608 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
609 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
610 %endif
611
612 %files -n python-CEGUI
613 %defattr(644,root,root,755)
614 %dir %{py_sitedir}/cegui-0.8
615 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
616
617 %if %{with ogre}
618 %files -n python-CEGUI-Renderer-Ogre
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
621 %endif
622
623 %if %{with opengl}
624 %files -n python-CEGUI-Renderer-OpenGL
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
627 %endif
This page took 0.106234 seconds and 2 git commands to generate.