]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
1da07df7157b3a78c2aefb1dbb4e13c5d6dd9053
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 #
5 # Conditional build:
6 %bcond_without  xercesc         # build XercesParser
7 %bcond_without  ogre            # build without Ogre renderer
8 %bcond_without  opengl          # build without OpenGL renderer
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.7.1
15 Release:        0.1
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  0a2815d5204e3c5510884ab62285da97
20 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  b6c1656d6b004c3dc11bf4b887fd5bd3
22 Patch0:         %{name}-link.patch
23 URL:            http://www.cegui.org.uk/
24 BuildRequires:  DevIL-devel
25 BuildRequires:  DirectFB-devel
26 BuildRequires:  FreeImage-devel
27 %if %{with opengl}
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 %endif
31 BuildRequires:  SILLY-devel >= 0.1.0
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  corona-devel >= 1.0.2
35 BuildRequires:  expat-devel
36 BuildRequires:  freetype-devel >= 2.0
37 BuildRequires:  glew-devel
38 BuildRequires:  irrlicht-devel >= 1.4
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  libxml2-devel >= 1:2.6
42 BuildRequires:  lua51-devel >= 5.1
43 %if %{with ogre}
44 BuildRequires:  ogre-devel >= 1.0.0
45 BuildRequires:  ois-devel
46 %endif
47 BuildRequires:  pcre-devel >= 5.0
48 BuildRequires:  pkgconfig
49 # for irrlicht renderer
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 %if %{with xercesc}
52 BuildRequires:  xerces-c-devel
53 %endif
54 Requires:       irrlicht >= 1.4
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 CEGUI stands for Crazy Eddie's Gui System; a free library providing
59 windowing and widgets for graphics APIs / engines where such
60 functionality is not natively available, or severely lacking. The
61 library is object orientated, written in C++, and targeted at games
62 developers who should be spending their time creating great games, not
63 building GUI sub-systems!
64
65 %description -l pl.UTF-8
66 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
67 zapewniającą okienka i widgety dla graficznych API i silników tam,
68 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
69 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
70 skierowana dla programistów gier, którzy powinni spędzać czas na
71 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
72
73 %package devel
74 Summary:        Development files for CEGUI
75 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       freetype-devel >= 2.0
79 Requires:       libstdc++-devel
80 Requires:       pcre-devel >= 5.0
81
82 %description devel
83 CEGUI headers.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe CEGUI.
87
88 %package docs
89 Summary:        Documentation files for CEGUI
90 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
91 Group:          Documentation
92 Requires:       %{name} = %{version}-%{release}
93
94 %description docs
95 CEGUI documentation.
96
97 %description docs -l pl.UTF-8
98 Dokumentacja CEGUI.
99
100 %package OPENGL
101 Summary:        OpenGLRenderer library for CEGUI
102 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
103 Group:          Libraries
104 Requires:       %{name} = %{version}-%{release}
105
106 %description OPENGL
107 OpenGLRenderer library for CEGUI.
108
109 %description OPENGL -l pl.UTF-8
110 Biblioteka OpenGLRenderer dla CEGUI.
111
112 %package OGRE
113 Summary:        OgreRenderer library for CEGUI
114 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
115 Group:          Libraries
116 Requires:       %{name} = %{version}-%{release}
117
118 %description OGRE
119 OgreRenderer library for CEGUI.
120
121 %description OGRE -l pl.UTF-8
122 Biblioteka OgreRenderer dla CEGUI
123
124 %prep
125 %setup -q -a 1
126 %patch0 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --with-default-image-codec=FreeImageImageCodec \
136         --with-default-xml-parser=LibxmlParser \
137         %{!?with_samples:--disable-samples} \
138         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
139         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
140         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc doc/README
159 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
160 # plugins
161 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
162 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
163 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
164 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
165 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
166 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
167 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
168 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
169 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
170 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
171 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
172 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
173 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
174 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
175 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
176 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
177 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
178 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
179 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
180 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
181 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
182 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
183 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
184 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
185 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
186 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
187
188 %files docs
189 %defattr(644,root,root,755)
190 %doc docs/CEGUI-DOCS-%{version}
191 %dir %{_datadir}/%{name}
192 %dir %{_datadir}/%{name}/xml_schemas
193 %{_datadir}/%{name}/xml_schemas/*.xsd
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
198 %{_libdir}/libCEGUIBase.la
199 # plugins - but as their headers are included...
200 %{_libdir}/libCEGUICoronaImageCodec.la
201 %{_libdir}/libCEGUIDevILImageCodec.la
202 %{_libdir}/libCEGUIExpatParser.la
203 %{_libdir}/libCEGUIFalagardWRBase.la
204 %{_libdir}/libCEGUIFreeImageImageCodec.la
205 %{_libdir}/libCEGUIIrrlichtRenderer.la
206 %{_libdir}/libCEGUILibxmlParser.la
207 %{_libdir}/libCEGUILuaScriptModule.la
208 %{_libdir}/libCEGUISILLYImageCodec.la
209 %{_libdir}/libCEGUITGAImageCodec.la
210 %{_libdir}/libCEGUITinyXMLParser.la
211 %{_libdir}/libCEGUIXercesParser.la
212 %{_libdir}/libCEGUItoluapp.la
213 %{_includedir}/%{name}
214 %{_pkgconfigdir}/CEGUI.pc
215 %{_pkgconfigdir}/CEGUI-OPENGL.pc
216 %{_pkgconfigdir}/CEGUI-OGRE.pc
217
218 %if %{with opengl}
219 %files OPENGL
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
222 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
223 %{_libdir}/libCEGUIOpenGLRenderer.la
224 %endif
225
226 %if %{with ogre}
227 %files OGRE
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
230 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so
231 %{_libdir}/libCEGUIOgreRenderer.la
232 %endif
This page took 0.079961 seconds and 2 git commands to generate.