]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
1c62045f57bec1a528bd2d0dd80a3d75b8783b74
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tolua++
3 # - separate packages for plugins
4 #
5 # Conditional build:
6 %bcond_without  xercesc         # build XercesParser
7 %bcond_without  ogre            # build without Ogre renderer
8 %bcond_without  opengl          # build without OpenGL renderer
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.7.5
15 Release:        4
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  38c79d1fdfaaa10f481c99a2ac479516
20 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  cdf59df7503f752a70eea4081eaac6ef
22 Patch0:         %{name}-new-tinyxml.patch
23 Patch1:         %{name}-gcc.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 BuildRequires:  DirectFB-devel >= 1.2.0
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  SILLY-devel >= 0.1.0
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 BuildRequires:  corona-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  freetype-devel >= 2.0
34 BuildRequires:  gtk+2-devel >= 2:2.4
35 BuildRequires:  irrlicht-devel >= 1.4
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libxml2-devel >= 1:2.6
39 BuildRequires:  lua51-devel >= 5.1
40 %if %{with ogre}
41 BuildRequires:  ogre-devel >= 1.6.0
42 BuildRequires:  ois-devel
43 %endif
44 BuildRequires:  pcre-devel >= 5.0
45 BuildRequires:  pkgconfig
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  tinyxml-devel
48 # for irrlicht renderer
49 BuildRequires:  xorg-lib-libXxf86vm-devel
50 %if %{with opengl}
51 BuildRequires:  OpenGL-GLU-devel
52 BuildRequires:  OpenGL-glut-devel
53 BuildRequires:  glew-devel
54 %endif
55 %if %{with xercesc}
56 BuildRequires:  xerces-c-devel
57 %endif
58 Requires:       irrlicht >= 1.4
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 CEGUI stands for Crazy Eddie's Gui System; a free library providing
63 windowing and widgets for graphics APIs / engines where such
64 functionality is not natively available, or severely lacking. The
65 library is object orientated, written in C++, and targeted at games
66 developers who should be spending their time creating great games, not
67 building GUI sub-systems!
68
69 %description -l pl.UTF-8
70 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
71 zapewniającą okienka i widgety dla graficznych API i silników tam,
72 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
73 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
74 skierowana dla programistów gier, którzy powinni spędzać czas na
75 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
76
77 %package devel
78 Summary:        Development files for CEGUI
79 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       freetype-devel >= 2.0
83 Requires:       libstdc++-devel
84 Requires:       pcre-devel >= 5.0
85
86 %description devel
87 CEGUI headers.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe CEGUI.
91
92 %package docs
93 Summary:        Documentation files for CEGUI
94 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
95 Group:          Documentation
96 Requires:       %{name} = %{version}-%{release}
97
98 %description docs
99 CEGUI documentation.
100
101 %description docs -l pl.UTF-8
102 Dokumentacja CEGUI.
103
104 %package Ogre
105 Summary:        OgreRenderer library for CEGUI
106 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description Ogre
111 OgreRenderer library for CEGUI.
112
113 %description Ogre -l pl.UTF-8
114 Biblioteka OgreRenderer dla CEGUI
115
116 %package Ogre-devel
117 Summary:        Header files for CEGUI OgreRenderer library
118 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
119 Group:          Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       ogre-devel >= 1.6.0
122
123 %description Ogre-devel
124 Header files for CEGUI OgreRenderer library.
125
126 %description Ogre-devel -l pl.UTF-8
127 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
128
129 %package OpenGL
130 Summary:        OpenGLRenderer library for CEGUI
131 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
132 Group:          Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description OpenGL
136 OpenGLRenderer library for CEGUI.
137
138 %description OpenGL -l pl.UTF-8
139 Biblioteka OpenGLRenderer dla CEGUI.
140
141 %package OpenGL-devel
142 Summary:        Header files for CEGUI OpenGLRenderer library
143 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
144 Group:          Development/Libraries
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       OpenGL-GLU-devel
147 Requires:       OpenGL-glut-devel
148 Requires:       glew-devel
149
150 %description OpenGL-devel
151 Header files for CEGUI OpenGLRenderer library.
152
153 %description OpenGL-devel -l pl.UTF-8
154 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
155
156 %prep
157 %setup -q -a 1
158 %patch0 -p1
159 %patch1 -p1
160
161 sed -i -e 's/lua5\.1/lua51/' acinclude.m4
162
163 %build
164 %{__libtoolize}
165 %{__aclocal}
166 %{__autoconf}
167 %{__autoheader}
168 %{__automake}
169 %configure \
170         --with-default-image-codec=FreeImageImageCodec \
171         --with-default-xml-parser=LibxmlParser \
172         %{!?with_samples:--disable-samples} \
173         --enable-ogre-renderer%{!?with_ogre:=no} \
174         --enable-opengl-renderer%{!?with_opengl:=no} \
175         --enable-xerces-c%{!?with_xercesc:=no}
176
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %{__make} install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post   -p /sbin/ldconfig
189 %postun -p /sbin/ldconfig
190
191 %files
192 %defattr(644,root,root,755)
193 %doc doc/README
194 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
195 # plugins
196 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
197 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
198 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
199 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
200 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
201 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
202 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
203 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
204 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
205 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
206 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
207 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
208 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
209 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
210 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
211 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
212 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec-%{version}.so
213 %attr(755,root,root) %{_libdir}/libCEGUISTBImageCodec.so
214 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
215 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
216 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
217 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
218 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
219 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
220 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
221 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
222
223 %files docs
224 %defattr(644,root,root,755)
225 %doc docs
226 %dir %{_datadir}/%{name}
227 %dir %{_datadir}/%{name}/xml_schemas
228 %{_datadir}/%{name}/xml_schemas/*.xsd
229
230 %files devel
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
233 %{_libdir}/libCEGUIBase.la
234 # plugins - but as their headers are included...
235 %{_libdir}/libCEGUIDevILImageCodec.la
236 %{_libdir}/libCEGUIExpatParser.la
237 %{_libdir}/libCEGUIFalagardWRBase.la
238 %{_libdir}/libCEGUIFreeImageImageCodec.la
239 %{_libdir}/libCEGUIIrrlichtRenderer.la
240 %{_libdir}/libCEGUILibxmlParser.la
241 %{_libdir}/libCEGUILuaScriptModule.la
242 %{_libdir}/libCEGUISILLYImageCodec.la
243 %{_libdir}/libCEGUISTBImageCodec.la
244 %{_libdir}/libCEGUITGAImageCodec.la
245 %{_libdir}/libCEGUITinyXMLParser.la
246 %{_libdir}/libCEGUIXercesParser.la
247 %{_libdir}/libCEGUItoluapp.la
248 %dir %{_includedir}/%{name}
249 %{_includedir}/%{name}/CEGUI*.h
250 %{_includedir}/%{name}/ImageCodecModules
251 %dir %{_includedir}/%{name}/RendererModules
252 %{_includedir}/%{name}/RendererModules/Irrlicht
253 %{_includedir}/%{name}/ScriptingModules
254 %{_includedir}/%{name}/WindowRendererSets
255 %{_includedir}/%{name}/XMLParserModules
256 %{_includedir}/%{name}/elements
257 %{_includedir}/%{name}/falagard
258 %{_pkgconfigdir}/CEGUI.pc
259
260 %if %{with ogre}
261 %files Ogre
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-%{version}.so
264
265 %files Ogre-devel
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer.so
268 %{_libdir}/libCEGUIOgreRenderer.la
269 %{_includedir}/%{name}/RendererModules/Ogre
270 %{_pkgconfigdir}/CEGUI-OGRE.pc
271 %endif
272
273 %if %{with opengl}
274 %files OpenGL
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
277
278 %files OpenGL-devel
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
281 %{_libdir}/libCEGUIOpenGLRenderer.la
282 %{_includedir}/%{name}/RendererModules/OpenGL
283 %{_pkgconfigdir}/CEGUI-OPENGL.pc
284 %endif
This page took 0.076895 seconds and 2 git commands to generate.