]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
06ab5e7785f488fb123b3f5f2b2805234a399824
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - gcc33 patch only for AC-branch
3 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
4 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
5 #
6 # Conditional build:
7 %bcond_without  xercesc         # build XercesParser
8 %bcond_with     ogre            # build samples with ogre3d
9 %bcond_with     samples         # build samples
10 #
11 Summary:        CEGUI - a free library providing windowing and widgets
12 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
13 Name:           CEGUI
14 Version:        0.6.0
15 Release:        1
16 License:        LGPL v2.1+ (with MIT parts)
17 Group:          Libraries
18 Source0:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19 # Source0-md5:  a7772b20a4e3530298e3e28c4eaec1bb
20 Source1:        http://dl.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21 # Source1-md5:  8abece86ea0b8a52737579ac2e801978
22 Patch0:         %{name}-gcc33.patch
23 Patch1:         %{name}-link.patch
24 Patch2:         %{name}-irrlicht.patch
25 URL:            http://www.cegui.org.uk/
26 BuildRequires:  DevIL-devel
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 BuildRequires:  SILLY-devel >= 0.1.0
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  corona-devel >= 1.0.2
34 BuildRequires:  expat-devel
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  irrlicht-devel >= 1.4
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 1:2.6
40 BuildRequires:  lua50-devel >= 5.0
41 BuildRequires:  pcre-devel >= 5.0
42 BuildRequires:  pkgconfig
43 %if %{with ogre}
44 BuildRequires:  ois-devel
45 BuildRequires:  ogre-devel
46 %endif
47 # for irrlicht renderer
48 BuildRequires:  xorg-lib-libXxf86vm-devel
49 Requires:       irrlicht >= 1.4
50 %if %{with xercesc}
51 BuildRequires:  xerces-c-devel
52 %endif
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 CEGUI stands for Crazy Eddie's Gui System; a free library providing
57 windowing and widgets for graphics APIs / engines where such
58 functionality is not natively available, or severely lacking. The
59 library is object orientated, written in C++, and targeted at games
60 developers who should be spending their time creating great games, not
61 building GUI sub-systems!
62
63 %description -l pl.UTF-8
64 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
65 zapewniającą okienka i widgety dla graficznych API i silników tam,
66 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
67 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
68 skierowana dla programistów gier, którzy powinni spędzać czas na
69 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
70
71 %package devel
72 Summary:        Development files for CEGUI
73 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       freetype-devel >= 2.0
77 Requires:       libstdc++-devel
78 Requires:       pcre-devel >= 5.0
79
80 %description devel
81 CEGUI headers.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe CEGUI.
85
86 %package docs
87 Summary:        Documentation files for CEGUI
88 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
89 Group:          Documentation
90 Requires:       %{name} = %{version}-%{release}
91
92 %description docs
93 CEGUI documentation.
94
95 %description docs -l pl.UTF-8
96 Dokumentacja CEGUI.
97
98
99 %prep
100 %setup -q -b 1
101 %patch0 -p1
102 #%patch1 -p1
103 #%patch2 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --with-default-image-codec=FreeImageImageCodec \
113         --with-default-parser=LibxmlParser \
114         %{!?with_samples:--disable-samples} \
115         %{!?with_ogre:--without-ogre-renderer} \
116         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog README
135 %attr(755,root,root) %{_libdir}/libCEGUI*.so.*
136 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
137 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
138 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
139 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
140 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
141 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
142 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
143 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
144 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
145 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
146 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
147 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
148
149 %files docs
150 %doc documentation
151 %dir %{_datadir}/%{name}
152 %dir %{_datadir}/%{name}/XMLRefSchema
153 %{_datadir}/%{name}/XMLRefSchema/*.xsd
154 %{_datadir}/%{name}/XMLRefSchema/Readme.txt
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
159 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
160 %{_libdir}/libCEGUI*.la
161 %{_includedir}/%{name}
162 %{_pkgconfigdir}/CEGUI.pc
163 %{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.277419 seconds and 3 git commands to generate.