]> git.pld-linux.org Git - packages/BackupPC.git/blob - BackupPC.spec
- started update to 2.1.0 (based on Michał Panasiewicz
[packages/BackupPC.git] / BackupPC.spec
1 # TODO:
2 # - make it simply build...
3 # - make pre/post for apache
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        A high-performance, enterprise-grade system for backing up PCs
6 Summary(pl):    Wysoko wydajny, profesjonalnej klasy system do kopii zapasowych z PC
7 Name:           backuppc
8 Version:        2.1.0
9 Release:        0.1
10 License:        GPL
11 Group:          Networking/Utilities
12 Source0:        http://dl.sourceforge.net/backuppc/BackupPC-%{version}.tar.gz
13 # Source0-md5:  4e201f00842c88cf241e0429643c6ec4
14 URL:            http://backuppc.sourceforge.net/
15 #BuildRequires: fakeroot
16 BuildRequires:  perl-base
17 BuildRequires:  perl-devel >= 1:5.6.0
18 BuildRequires:  perl-Compress-Zlib
19 BuildRequires:  perl-Digest-MD5
20 Requires:       samba-clients
21 # lets check if it's really needed
22 #Requires:      sperl
23 Requires:       tar > 1.13
24 Requires:       webserver
25 Obsoletes:      BackupPC
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _backuppcdir    %{_datadir}/%{name}
30
31 %description
32 BackupPC is disk based and not tape based. This particularity allows
33 features not found in any other backup solution:
34 - Clever pooling scheme minimizes disk storage and disk I/O. Identical
35   files across multiple backups of the same or different PC are stored
36   only once (using hard links), resulting in substantial savings in disk
37   storage and disk writes.
38 - Optional compression provides additional reductions in storage. CPU
39   impact of compression is low since only new files (those not already
40   in the pool) need to be compressed.
41 - A powerful http/cgi user interface allows administrators to view log
42   files, configuration, current status and allows users to initiate and
43   cancel backups and browse and restore files from backups very quickly.
44 - No client-side software is needed. On WinXX the SMB protocol is
45   used. On Linux or unix clients, rsync or tar (over ssh/rsh/NFS) can be
46   used.
47 - Flexible restore options. Single files can be downloaded from any
48   backup directly from the CGI interface. Zip or Tar archives for
49   selected files or directories can also be downloaded from the CGI
50   interface.
51 - BackupPC supports mobile environments where laptops are only
52   intermittently connected to the network and have dynamic IP addresses
53   (DHCP).
54 - Flexible configuration parameters allow multiple backups to be
55   performed in parallel.
56 - and more to discover in the manual...
57
58 %description -l pl
59 BackupPC jest oparty na dyskach, a nie ta¶mach. Ta osobliwo¶æ daje
60 mo¿liwo¶ci, których nie maj± inne rozwi±zania problemu kopii
61 zapasowych:
62 - Inteligentny schemat ¶ci±gania minimalizuje zajmowane miejsce i
63   ilo¶æ operacji wej¶cia/wyj¶cia na dysku. Takie same pliki s±
64   przechowywane tylko raz (przy u¿yciu twardych dowi±zañ), co daje
65   znacz±c± oszczêdno¶æ w miejscu na dysku i czasie zapisu.
66 - Opcjonalna kompresja pozwala na dalsze ograniczenie rozmiaru.
67   Obci±¿enie procesora jest ma³e, poniewa¿ tylko nowe pliki musz± byæ
68   kompresowane.
69 - Potê¿ny interfejs u¿ytkownika HTTP/CGI pozwala administratorom
70   przegl±daæ pliki logów, konfiguracjê i aktualny stan oraz u¿ytkownikom
71   rozpoczynaæ lub przerywaæ tworzenie kopii oraz szybko przegl±daæ i
72   odtwarzaæ pliki z kopii zapasowych.
73 - Nie jest wymagane oprogramowanie po stronie klienta. Na WinXX
74   u¿ywany jest protokó³ SMB. Na klientach linuksowych lub uniksowych
75   mo¿na u¿ywaæ rsynca lub tara (po ssh/rsh/NFS).
76 - Dostêpne s± elastyczne opcje odzyskiwania. Mo¿na ¶ci±gaæ pojedyncze
77   pliki z kopii bezpo¶rednio z interfejsu CGI. Tak¿e archiwa zip lub tar
78   z wybranymi plikami lub katalogami mog± byæ ¶ci±gane z poziomu
79   interfejsu CGI.
80 - BackupPC obs³uguje ¶rodowiska przeno¶ne, gdzie laptopy s± pod³±czane
81   do sieci tylko z przerwami i maj± dynamiczne adresy IP (z DHCP).
82 - Elastyczna konfiguracja parametrów pozwala na wykonywanie wielu
83   kopii równolegle.
84 - Wiele wiêcej mo¿na odkryæ w manualu...
85
86 %prep
87 %setup -q -n BackupPC-%{version}
88 #%patch0 -p1
89
90 %build
91 sed -i -e 's#!/bin/perl#!%{__perl}#' configure.pl
92 sed -i -e 's#!/bin/perl#!%{__perl}#' {bin,cgi-bin,doc}/*
93 sed -i -e 's#!/bin/perl#!%{__perl}#' */src/*
94 sed -i -e 's#!/bin/perl#!%{__perl}#' */*/*/*.pm
95
96 pod2man --section=8 --center="BackupPC manual" doc/BackupPC.pod backuppc.8
97 perl -e "s/.IX Title.*/.SH NAME\nbackuppc \\- BackupPC manual/g" -p -i.tmp backuppc.8
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,%{name},httpd/httpd.conf} \
102         $RPM_BUILD_ROOT%{_var}/lib/%{name}/pc/localhost
103
104 # Does not work, yet... some voodoo-magic is needed
105 #echo "y" | fakeroot DEBIANDEST=$RPM_BUILD_ROOT configure.pl
106 %{__perl} configure.pl \
107         --batch \
108         --bin-path perl=%{__perl} \
109         --bin-path tar=/bin/tar \
110         --bin-path smbclient=/usr/bin/smbclient \
111         --bin-path nmblookup=/usr/bin/nmblookup \
112         --bin-path rsync=/usr/bin/rsync \
113         --bin-path ping=/bin/ping \
114         --bin-path df=/bin/df \
115         --bin-path ssh=/usr/bin/ssh \
116         --bin-path sendmail=/usr/sbin/sendmail \
117         --bin-path hostname=/bin/hostname \
118         --bin-path split=/usr/bin/split \
119         --bin-path cat=/bin/cat \
120         --bin-path gzip=/bin/gzip \
121         --bin-path bzip2=/usr/bin/bzip2 \
122         --cgi-dir %{_backuppcdir}/www/cgi-bin \
123         --data-dir %{_var}/lib/%{name} \
124         --dest-dir $RPM_BUILD_ROOT \
125         --hostname localhost \
126         --html-dir %{_backuppcdir}/www/html \
127         --html-dir-url /BackupPC \
128         --install-dir %{_backuppcdir} \
129         --uid-ignore
130 #       --config-path %{_sysconfdir}/backuppc \
131
132 #mv -f $RPM_BUILD_ROOT/var/lib/backuppc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}/backuppc
133 #mv -f $RPM_BUILD_ROOT%{_datadir}/backuppc/cgi-bin/BackupPC_Admin $RPM_BUILD_ROOT%{_datadir}/backuppc/cgi-bin/index.cgi
134 #install conf/hosts $RPM_BUILD_ROOT%{_sysconfdir}/backuppc
135 #install debian/localhost.pl $RPM_BUILD_ROOT%{_sysconfdir}/backuppc
136 #install debian/apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/93_backuppc.conf
137
138 # Cleanups:
139 #rm -f $RPM_BUILD_ROOT%{_datadir}/backuppc/doc/*
140 #rmdir $RPM_BUILD_ROOT/var/lib/backuppc/conf
141
142 # Linking cgi:
143 #cd $RPM_BUILD_ROOT%{_datadir}/backuppc/cgi-bin
144 #ln -s ../image
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %doc doc/*.html
152 #%attr(750,root,root) %dir %{_sysconfdir}/backuppc
153 #%config(noreplace) %verify(not md5 size mtime) %attr(640,root,root) %{_sysconfdir}/backuppc/*
154 #%config(noreplace) %verify(not md5 size mtime) %attr(640,root,root) %{_sysconfdir}/httpd/httpd.conf/93_backuppc.conf
155 #%attr(755,root,root) %{_bindir}/*
156 #%attr(750,root,root) %dir %{_var}/lib/backuppc
157 #%{_mandir}/man?/*
This page took 0.05025 seconds and 4 git commands to generate.