]> git.pld-linux.org Git - packages/BTF.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 9 Jan 2012 19:46:44 +0000 (19:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    BTF-shared.patch -> 1.1
    BTF-ufconfig.patch -> 1.1
    BTF.spec -> 1.1

BTF-shared.patch [new file with mode: 0644]
BTF-ufconfig.patch [new file with mode: 0644]
BTF.spec [new file with mode: 0644]

diff --git a/BTF-shared.patch b/BTF-shared.patch
new file mode 100644 (file)
index 0000000..85b80d4
--- /dev/null
@@ -0,0 +1,63 @@
+--- BTF/Lib/Makefile.orig      2012-01-09 19:34:18.460060583 +0100
++++ BTF/Lib/Makefile   2012-01-09 20:11:23.916801765 +0100
+@@ -15,14 +15,17 @@
+ all: library
+-library: libbtf.a
++library: libbtf.la
+ OBJ = btf_order.o btf_maxtrans.o btf_strongcomp.o \
+     btf_l_order.o btf_l_maxtrans.o btf_l_strongcomp.o
+-libbtf.a: $(OBJ)
+-      $(ARCHIVE)  libbtf.a $(OBJ)
+-      - $(RANLIB) libbtf.a
++libbtf.la: $(OBJ)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -o libbtf.la -rpath $(libdir) $(OBJ:.o=.lo)
++
++install: libbtf.la
++      install -d $(DESTDIR)$(libdir)
++      libtool --mode=install cp libbtf.la $(DESTDIR)$(libdir)/libbtf.la
+ $(OBJ): $(INC)
+@@ -32,31 +35,31 @@
+ #-------------------------------------------------------------------------------
+ btf_order.o: ../Source/btf_order.c
+-      $(C) -c $(I) $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) $< -o $@
+ btf_maxtrans.o: ../Source/btf_maxtrans.c
+-      $(C) -c $(I) $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) $< -o $@
+ btf_strongcomp.o: ../Source/btf_strongcomp.c
+-      $(C) -c $(I) $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) $< -o $@
+ #-------------------------------------------------------------------------------
+ btf_l_order.o: ../Source/btf_order.c
+-      $(C) -c $(I) -DDLONG $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) -DDLONG $< -o $@
+ btf_l_maxtrans.o: ../Source/btf_maxtrans.c
+-      $(C) -c $(I) -DDLONG $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) -DDLONG $< -o $@
+ btf_l_strongcomp.o: ../Source/btf_strongcomp.c
+-      $(C) -c $(I) -DDLONG $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $(I) -DDLONG $< -o $@
+ #-------------------------------------------------------------------------------
+ purge: distclean
+ distclean: clean
+-      - $(RM) libbtf.a 
++      - $(RM) libbtf.la 
+ clean:
+       - $(RM) $(CLEAN)
diff --git a/BTF-ufconfig.patch b/BTF-ufconfig.patch
new file mode 100644 (file)
index 0000000..a9df4f0
--- /dev/null
@@ -0,0 +1,31 @@
+--- BTF/Makefile.orig  2011-12-08 21:00:31.000000000 +0100
++++ BTF/Makefile       2012-01-09 19:06:48.286671996 +0100
+@@ -6,7 +6,7 @@
+ default: library
+-include ../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+ library:
+       ( cd Lib ; $(MAKE) )
+--- BTF/Lib/Makefile.orig      2011-12-08 18:36:11.000000000 +0100
++++ BTF/Lib/Makefile   2012-01-09 19:34:01.893393361 +0100
+@@ -2,7 +2,7 @@
+ ccode: all
+-include ../../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+ # for testing only:
+ # TEST = -DTESTING
+@@ -11,7 +11,7 @@
+ INC = ../Include/btf.h ../Include/btf_internal.h
+-I = -I../Include -I../../UFconfig
++I = -I../Include
+ all: library
diff --git a/BTF.spec b/BTF.spec
new file mode 100644 (file)
index 0000000..7672d1d
--- /dev/null
+++ b/BTF.spec
@@ -0,0 +1,94 @@
+Summary:       BTF: permutation to block triangular form
+Summary(pl.UTF-8):     BTF - permutacja do postaci blokowo trójkątnej
+Name:          BTF
+Version:       1.1.3
+Release:       1
+License:       LGPL v2.1+
+Group:         Libraries
+Source0:       http://www.cise.ufl.edu/research/sparse/btf/%{name}-%{version}.tar.gz
+# Source0-md5: cd8f2e52a3618da471fbb60342a96915
+Patch0:                %{name}-ufconfig.patch
+Patch1:                %{name}-shared.patch
+URL:           http://www.cise.ufl.edu/research/sparse/btf/
+BuildRequires: UFconfig >= 3.7.0
+BuildRequires: libtool >= 2:1.5
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+BTF permutes an unsymmetric matrix (square or rectangular) into its
+block upper triangular form (more precisely, it computes a
+Dulmage-Mendelsohn decomposition). BTF is required by the KLU package.
+
+%description -l pl.UTF-8
+BTF permutuje macierz niesymetryczną (kwadratową lub prostokątną) do
+postaci górnej blokowo trójkątnej (ściślej mówiąc, oblicza rozkład
+Dulmage'a-Mendelsohna). Pakiet BTF jest wymagany przez pakiet KLU.
+
+%package devel
+Summary:       Header files for BTF library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki BTF
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      UFconfig >= 3.7.0
+
+%description devel
+Header files for BTF library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki BTF.
+
+%package static
+Summary:       Static BTF library
+Summary(pl.UTF-8):     Statyczna biblioteka BTF
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static BTF library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka BTF.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__make} \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags}" \
+       LDFLAGS="%{rpmldflags}" \
+       libdir=%{_libdir}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_includedir}/btf
+
+%{__make} -C Lib install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       libdir=%{_libdir}
+
+install Include/*.h $RPM_BUILD_ROOT%{_includedir}/btf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc README.txt Doc/ChangeLog
+%attr(755,root,root) %{_libdir}/libbtf.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libbtf.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libbtf.so
+%{_libdir}/libbtf.la
+%{_includedir}/btf
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libbtf.a
This page took 0.146317 seconds and 4 git commands to generate.