]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- converted to UTF-8
[packages/Atlas-C++.git] / Atlas-C++.spec
1 # TODO:
2 # add tutorial subpackage
3 Summary:        C++ reference implementation of the Atlas protocol
4 Summary(pl.UTF-8):   Implementacja protokołu Atlas
5 Name:           Atlas-C++
6 Version:        0.6.0
7 Release:        0.2
8 Epoch:          1
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
12 # Source0-md5:  1343d74747a831f2b7b080a51cb4747a
13 Patch0:         %{name}-link.patch
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  bzip2-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool >= 2:1.5
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
24 communications layer designed to be used in the WorldForge MMORPG
25 gaming system. This library is suitable for linking to either clients
26 or servers.
27
28 %description -l pl.UTF-8
29 Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
30 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
31 tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
32
33 %package devel
34 Summary:        Header files for Atlas-C++ development
35 Summary(pl.UTF-8):   Pliki nagłówkowe do biblioteki Atlas-C++
36 Group:          Development/Libraries
37 Requires:       %{name} = %{epoch}:%{version}-%{release}
38 Requires:       libstdc++-devel
39 # libAtlasFilters additionally R: bzip2-devel,zlib-devel
40
41 %description devel
42 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
43 communications layer designed to be used in the WorldForge MMORPG
44 gaming system. This library is suitable for linking to either clients
45 or servers.
46
47 This package contains the header files needed to develop programs that
48 use these Atlas-C++
49
50 %description devel -l pl.UTF-8
51 Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
52 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
53 tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
54
55 Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
56 używających bibliotek Atlas-C++.
57
58 %package static
59 Summary:        Static libraries for Atlas-C++ development
60 Summary(pl.UTF-8):   Statyczne biblioteki Atlas-C++
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
63
64 %description static
65 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
66 communications layer designed to be used in the WorldForge MMORPG
67 gaming system. This library is suitable for linking to either clients
68 or servers.
69
70 This package contains the static Atlas-C++ libraries.
71
72 %description static -l pl.UTF-8
73 Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
74 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
75 tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
76
77 Pakiet zawiera statyczne biblioteki Atlas-C++.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoheader}
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         --enable-static
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS ChangeLog NEWS README
108 %attr(755,root,root) %{_bindir}/atlas_convert
109 %attr(755,root,root) %{_libdir}/libAtlas*.so.*.*.*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libAtlas*.so
114 %{_libdir}/libAtlas*.la
115 %{_includedir}/Atlas*
116 %{_pkgconfigdir}/atlascpp*.pc
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libAtlas*.a
This page took 0.097281 seconds and 3 git commands to generate.