]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
d2c952882926a5fb5f4dc5aec3d54bb5346545c2
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 Summary:        Atari 800 Emulator
7 Summary(pl):    Emulator Atari 800
8 Name:           Atari800
9 Version:        1.3.2
10 Release:        1
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
14 # Source0-md5:  8fcd251a3757270c02519ad7b86b7caa
15 # NOTE: ROMs probably can be redistributed only in original XF25 archive
16 Source1:        http://joy.sophics.cz/www/xf25.zip
17 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  XFree86-devel
22 %{?with_svga:BuildRequires:     svgalib-devel}
23 %if %{with license_agreement}
24 BuildRequires:  unzip
25 %endif
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         specflags       -fomit-frame-pointer
30
31 %description
32 This is Atari 800, 800XL, 130XE and 5200 emulator.
33
34 %description -l pl
35 To jest emulator Atari 800, 800XL, 130XE i 5200.
36
37 %package common
38 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
39 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
40 Group:          Applications/Emulators
41 Obsoletes:      Atari800
42 %if %{without license_agreement}
43 Requires(post): unzip
44 %endif
45
46 %description common
47 This is Atari 800, 800XL, 130XE and 5200 emulator.
48
49 This package contains common files for both svgalib and X11 versions
50 of Atari800.
51 %if %{without license_agreement}
52 Note: because of license problems we had to include whole X-Former
53 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
54 license_agreement)
55 %endif 
56
57 %description common -l pl
58 To jest emulator Atari 800, 800XL, 130XE i 5200.
59
60 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
61 oraz X11.
62 %if %{without license_agreement}
63 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
64 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
65 przebuduj pakiet z opcja --with license_agreement.
66 %endif
67
68 %package svga
69 Summary:        Atari 800 Emulator - svgalib version
70 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
71 License:        GPL
72 Group:          Applications/Emulators
73 Requires:       %{name}-common = %{version}
74
75 %description svga
76 This is Atari 800, 800XL, 130XE and 5200 emulator.
77
78 This package contains Atari800 executable file configured for svgalib
79 with sound and joystick support.
80
81 %description svga -l pl
82 To jest emulator Atari 800, 800XL, 130XE i 5200.
83
84 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
85 svgalib z obs³ug± d¼wiêku i joysticka.
86
87 %package x11
88 Summary:        Atari 800 Emulator - X Window version
89 Summary(pl):    Emulator Atari 800 - wersja pod X Window
90 License:        GPL
91 Group:          Applications/Emulators
92 Requires:       %{name}-common = %{version}
93
94 %description x11
95 This is Atari 800, 800XL, 130XE and 5200 emulator.
96
97 This package contains Atari800 executable file configured for X11 with
98 sound and joystick support.
99
100 %description x11 -l pl
101 To jest emulator Atari 800, 800XL, 130XE i 5200.
102
103 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
104 obs³ug± d¼wiêku i joysticka.
105
106 %package SDL
107 Summary:        Atari 800 Emulator - SDL version
108 Summary(pl):    Emulator Atari 800 - wersja pod SDL
109 License:        GPL
110 Group:          Applications/Emulators
111 Requires:       %{name}-common = %{version}
112
113 %description SDL
114 This is Atari 800, 800XL, 130XE and 5200 emulator.
115
116 This package contains Atari800 executable file configured for SDL with
117 sound and joystick support.
118
119 %description SDL -l pl
120 To jest emulator Atari 800, 800XL, 130XE i 5200.
121
122 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
123 obs³ug± d¼wiêku i joysticka.
124
125 %prep
126 %setup -q -n atari800-%{version}
127
128 %build
129 cd src
130
131 CFLAGS="%{rpmcflags}"
132
133 %if %{with svga}
134 %configure \
135         --target=svgalib \
136         --disable-VERY_SLOW \
137         --enable-NO_CYCLE_EXACT \
138         --enable-CRASH_MENU \
139         --enable-MONITOR_BREAK \
140         --enable-MONITOR_HINTS \
141         --enable-MONITOR_ASSEMBLER \
142         --enable-COMPILED_PALETTE \
143         --enable-SNAILMETER \
144         --disable-SVGA_SPEEDUP \
145         --enable-USE_CURSORBLOCK \
146         --disable-JOYMOUSE \
147         --enable-LINUX_JOYSTICK \
148         --enable-SOUND \
149         --enable-NO_VOL_ONLY \
150         --enable-NO_CONSOL_SOUND \
151         --disable-SERIO_SOUND \
152         --enable-NOSNDINTER \
153         --disable-CLIP \
154         --disable-STEREO \
155         --disable-BUFFERED_LOG \
156         --enable-SET_LED \
157         --enable-NO_LED_ON_SCREEN
158
159 %{__make}
160
161 mv -f atari800 atari800-svga
162
163 %{__make} clean
164 %endif
165
166 %configure \
167         --target=sdl \
168         --disable-VERY_SLOW \
169         --enable-NO_CYCLE_EXACT \
170         --enable-CRASH_MENU \
171         --enable-MONITOR_BREAK \
172         --enable-MONITOR_HINTS \
173         --enable-MONITOR_ASSEMBLER \
174         --enable-COMPILED_PALETTE \
175         --enable-SNAILMETER \
176         --enable-LINUX_JOYSTICK \
177         --enable-SOUND \
178         --enable-NO_VOL_ONLY \
179         --enable-NO_CONSOL_SOUND \
180         --disable-SERIO_SOUND \
181         --enable-NOSNDINTER \
182         --disable-CLIP \
183         --disable-STEREO \
184         --disable-BUFFERED_LOG \
185         --enable-SET_LED \
186         --enable-NO_LED_ON_SCREEN
187
188 %{__make}
189
190 mv -f atari800 atari800-SDL
191
192 %{__make} clean
193
194 %configure \
195         --target=shm \
196         --disable-VERY_SLOW \
197         --enable-NO_CYCLE_EXACT \
198         --enable-CRASH_MENU \
199         --enable-MONITOR_BREAK \
200         --enable-MONITOR_HINTS \
201         --enable-MONITOR_ASSEMBLER \
202         --enable-COMPILED_PALETTE \
203         --enable-SNAILMETER \
204         --enable-LINUX_JOYSTICK \
205         --enable-SOUND \
206         --enable-NO_VOL_ONLY \
207         --enable-NO_CONSOL_SOUND \
208         --disable-SERIO_SOUND \
209         --enable-NOSNDINTER \
210         --disable-CLIP \
211         --disable-STEREO
212
213 %{__make}
214
215 mv -f atari800 atari800-x11
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
220
221 %if %{with svga}
222 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
223 %endif
224 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
225 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
226 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
227 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
228
229 %if %{with license_agreement}
230 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
231 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
232 %else
233 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
234 %endif
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %if %{without license_agreement}
240 %post common
241 cd %{_datadir}/atari800
242 if [ "`echo *.rom`" = "*.rom" ]; then
243         umask 022
244         unzip -q -L xf25.zip
245         rm -f xf25.doc xf25.exe
246 fi
247 %endif
248
249 %files common
250 %defattr(644,root,root,755)
251 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
252 %attr(755,root,root) %{_bindir}/atari800
253 %{_datadir}/atari800
254 %{_mandir}/man1/atari800.1*
255
256 %files x11
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_bindir}/atari800-x11
259
260 %files SDL
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/atari800-SDL
263
264 %if %{with svga}
265 %files svga
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_bindir}/atari800-svga
268 %endif
This page took 0.189381 seconds and 2 git commands to generate.