]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
98497a882273b770d0c095608347a3edcc573a7b
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 Summary:        Atari 800 Emulator
7 Summary(pl):    Emulator Atari 800
8 Name:           Atari800
9 Version:        1.3.2
10 Release:        1
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
14 # Source0-md5:  8fcd251a3757270c02519ad7b86b7caa
15 # NOTE: ROMs probably can be redistributed only in original XF25 archive
16 Source1:        http://joy.sophics.cz/www/xf25.zip
17 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  XFree86-devel
22 %{?with_svga:BuildRequires:     svgalib-devel}
23 %if %{with license_agreement}
24 BuildRequires:  unzip
25 %endif
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         specflags       -fomit-frame-pointer
30
31 %description
32 This is Atari 800, 800XL, 130XE and 5200 emulator.
33
34 %description -l pl
35 To jest emulator Atari 800, 800XL, 130XE i 5200.
36
37 %package common
38 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
39 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
40 Group:          Applications/Emulators
41 Obsoletes:      Atari800
42 %if %{without license_agreement}
43 Requires(post): unzip
44 %endif
45
46 %description common
47 This is Atari 800, 800XL, 130XE and 5200 emulator.
48
49 This package contains common files for both svgalib and X11 versions
50 of Atari800.
51 %if %{without license_agreement}
52 Note: because of license problems we had to include whole X-Former
53 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
54 license_agreement)
55 %endif 
56
57 %description common -l pl
58 To jest emulator Atari 800, 800XL, 130XE i 5200.
59
60 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
61 oraz X11.
62 %if %{without license_agreement}
63 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
64 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
65 przebuduj pakiet z opcja --with license_agreement.
66 %endif
67
68 %package svga
69 Summary:        Atari 800 Emulator - svgalib version
70 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
71 License:        GPL
72 Group:          Applications/Emulators
73 Requires:       %{name}-common = %{version}
74
75 %description svga
76 This is Atari 800, 800XL, 130XE and 5200 emulator.
77
78 This package contains Atari800 executable file configured for svgalib
79 with sound and joystick support.
80
81 %description svga -l pl
82 To jest emulator Atari 800, 800XL, 130XE i 5200.
83
84 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
85 svgalib z obs³ug± d¼wiêku i joysticka.
86
87 %package x11
88 Summary:        Atari 800 Emulator - X Window version
89 Summary(pl):    Emulator Atari 800 - wersja pod X Window
90 License:        GPL
91 Group:          Applications/Emulators
92 Requires:       %{name}-common = %{version}
93
94 %description x11
95 This is Atari 800, 800XL, 130XE and 5200 emulator.
96
97 This package contains Atari800 executable file configured for X11 with
98 sound and joystick support.
99
100 %description x11 -l pl
101 To jest emulator Atari 800, 800XL, 130XE i 5200.
102
103 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
104 obs³ug± d¼wiêku i joysticka.
105
106 %package SDL
107 Summary:        Atari 800 Emulator - SDL version
108 Summary(pl):    Emulator Atari 800 - wersja pod SDL
109 License:        GPL
110 Group:          Applications/Emulators
111 Requires:       %{name}-common = %{version}
112
113 %description SDL
114 This is Atari 800, 800XL, 130XE and 5200 emulator.
115
116 This package contains Atari800 executable file configured for SDL with
117 sound and joystick support.
118
119 %description SDL -l pl
120 To jest emulator Atari 800, 800XL, 130XE i 5200.
121
122 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
123 obs³ug± d¼wiêku i joysticka.
124
125 %prep
126 %setup -q -n atari800-%{version}
127
128 %build
129 cd src
130 cp -f /usr/share/automake/config.sub .
131
132
133 CFLAGS="%{rpmcflags}"
134
135 %if %{with svga}
136 %configure \
137         --target=svgalib \
138         --disable-VERY_SLOW \
139         --enable-NO_CYCLE_EXACT \
140         --enable-CRASH_MENU \
141         --enable-MONITOR_BREAK \
142         --enable-MONITOR_HINTS \
143         --enable-MONITOR_ASSEMBLER \
144         --enable-COMPILED_PALETTE \
145         --enable-SNAILMETER \
146         --disable-SVGA_SPEEDUP \
147         --enable-USE_CURSORBLOCK \
148         --disable-JOYMOUSE \
149         --enable-LINUX_JOYSTICK \
150         --enable-SOUND \
151         --enable-NO_VOL_ONLY \
152         --enable-NO_CONSOL_SOUND \
153         --disable-SERIO_SOUND \
154         --enable-NOSNDINTER \
155         --disable-CLIP \
156         --disable-STEREO \
157         --disable-BUFFERED_LOG \
158         --enable-SET_LED \
159         --enable-NO_LED_ON_SCREEN
160
161 %{__make}
162
163 mv -f atari800 atari800-svga
164
165 %{__make} clean
166 %endif
167
168 %configure \
169         --target=sdl \
170         --disable-VERY_SLOW \
171         --enable-NO_CYCLE_EXACT \
172         --enable-CRASH_MENU \
173         --enable-MONITOR_BREAK \
174         --enable-MONITOR_HINTS \
175         --enable-MONITOR_ASSEMBLER \
176         --enable-COMPILED_PALETTE \
177         --enable-SNAILMETER \
178         --enable-LINUX_JOYSTICK \
179         --enable-SOUND \
180         --enable-NO_VOL_ONLY \
181         --enable-NO_CONSOL_SOUND \
182         --disable-SERIO_SOUND \
183         --enable-NOSNDINTER \
184         --disable-CLIP \
185         --disable-STEREO \
186         --disable-BUFFERED_LOG \
187         --enable-SET_LED \
188         --enable-NO_LED_ON_SCREEN
189
190 %{__make}
191
192 mv -f atari800 atari800-SDL
193
194 %{__make} clean
195
196 %configure \
197         --target=shm \
198         --disable-VERY_SLOW \
199         --enable-NO_CYCLE_EXACT \
200         --enable-CRASH_MENU \
201         --enable-MONITOR_BREAK \
202         --enable-MONITOR_HINTS \
203         --enable-MONITOR_ASSEMBLER \
204         --enable-COMPILED_PALETTE \
205         --enable-SNAILMETER \
206         --enable-LINUX_JOYSTICK \
207         --enable-SOUND \
208         --enable-NO_VOL_ONLY \
209         --enable-NO_CONSOL_SOUND \
210         --disable-SERIO_SOUND \
211         --enable-NOSNDINTER \
212         --disable-CLIP \
213         --disable-STEREO
214
215 %{__make}
216
217 mv -f atari800 atari800-x11
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
222
223 %if %{with svga}
224 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
225 %endif
226 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
227 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
228 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
229 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
230
231 %if %{with license_agreement}
232 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
233 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
234 %else
235 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
236 %endif
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241 %if %{without license_agreement}
242 %post common
243 cd %{_datadir}/atari800
244 if [ "`echo *.rom`" = "*.rom" ]; then
245         umask 022
246         unzip -q -L xf25.zip
247         rm -f xf25.doc xf25.exe
248 fi
249 %endif
250
251 %files common
252 %defattr(644,root,root,755)
253 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
254 %attr(755,root,root) %{_bindir}/atari800
255 %{_datadir}/atari800
256 %{_mandir}/man1/atari800.1*
257
258 %files x11
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_bindir}/atari800-x11
261
262 %files SDL
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_bindir}/atari800-SDL
265
266 %if %{with svga}
267 %files svga
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_bindir}/atari800-svga
270 %endif
This page took 0.053011 seconds and 2 git commands to generate.