]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- release 2
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 #
5 Summary:        Atari 800 Emulator
6 Summary(pl.UTF-8):      Emulator Atari 800
7 Name:           Atari800
8 Version:        2.2.1
9 Release:        2
10 License:        GPL v2+ (Atari800), distributable if unmodified (xf25 with ROMs)
11 Group:          Applications/Emulators
12 Source0:        http://downloads.sourceforge.net/atari800/atari800-%{version}.tar.gz
13 # Source0-md5:  57c0b44207934c6109e64a56c2c83de0
14 # NOTE: ROMs probably can be redistributed only in original XF25 archive
15 Source1:        http://joy.sophics.cz/www/xf25.zip
16 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
17 Source2:        %{name}-chooser
18 URL:            http://atari800.atari.org/
19 BuildRequires:  SDL-devel
20 BuildRequires:  automake
21 %if %{with license_agreement}
22 BuildRequires:  unzip
23 %endif
24 BuildRequires:  xorg-lib-libXext-devel
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         specflags       -fomit-frame-pointer
29
30 %description
31 This is Atari 800, 800XL, 130XE and 5200 emulator.
32
33 %description -l pl.UTF-8
34 To jest emulator Atari 800, 800XL, 130XE i 5200.
35
36 %package common
37 Summary:        Atari 800 Emulator - common files for SDL and X11 versions
38 Summary(pl.UTF-8):      Emulator Atari 800 - pliki wspólne dla wersji SDL oraz X11
39 Group:          Applications/Emulators
40 Obsoletes:      Atari800
41 %if !%{with license_agreement}
42 Requires(post): unzip
43 %endif
44
45 %description common
46 This is Atari 800, 800XL, 130XE and 5200 emulator.
47
48 This package contains common files for both SDL and X11 versions
49 of Atari800.
50 %if !%{with license_agreement}
51 Note: because of license problems we had to include whole X-Former
52 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
53 license_agreement)
54 %endif 
55
56 %description common -l pl.UTF-8
57 To jest emulator Atari 800, 800XL, 130XE i 5200.
58
59 Ten pakiet zawiera pliki wspólne dla wersji działających pod SDL
60 oraz X11.
61 %if !%{with license_agreement}
62 Uwaga: z powodu problemów z licencją musieliśmy załączyć całą paczkę
63 z emulatorem X-Former (xf25.zip). Jeśli jej nie chcesz w pakiecie -
64 przebuduj pakiet z opcja --with license_agreement.
65 %endif
66
67 %package x11
68 Summary:        Atari 800 Emulator - X Window version
69 Summary(pl.UTF-8):      Emulator Atari 800 - wersja dla systemu X Window
70 License:        GPL
71 Group:          Applications/Emulators
72 Requires:       %{name}-common = %{version}-%{release}
73
74 %description x11
75 This is Atari 800, 800XL, 130XE and 5200 emulator.
76
77 This package contains Atari800 executable file configured for X11 with
78 sound and joystick support.
79
80 %description x11 -l pl.UTF-8
81 To jest emulator Atari 800, 800XL, 130XE i 5200.
82
83 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
84 obsługą dźwięku i joysticka.
85
86 %package SDL
87 Summary:        Atari 800 Emulator - SDL version
88 Summary(pl.UTF-8):      Emulator Atari 800 - wersja SDL
89 License:        GPL
90 Group:          Applications/Emulators
91 Requires:       %{name}-common = %{version}-%{release}
92 Obsoletes:      Atari800-svga
93
94 %description SDL
95 This is Atari 800, 800XL, 130XE and 5200 emulator.
96
97 This package contains Atari800 executable file configured for SDL with
98 sound and joystick support.
99
100 %description SDL -l pl.UTF-8
101 To jest emulator Atari 800, 800XL, 130XE i 5200.
102
103 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
104 obsługą dźwięku i joysticka.
105
106 %prep
107 %setup -q -n atari800-%{version}
108
109 %build
110 cd src
111 rm config.sub
112 cp -f /usr/share/automake/config.sub .
113
114 %configure \
115         --target=sdl \
116         --enable-crashmenu \
117         --disable-stereosound
118
119 %{__make}
120
121 mv -f atari800 atari800-SDL
122
123 %{__make} clean
124
125 %configure \
126         --target=shm \
127         --enable-crashmenu \
128         --disable-stereosound
129
130 %{__make}
131
132 mv -f atari800 atari800-x11
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
137
138 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
139 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
140 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
141 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
142
143 %if %{with license_agreement}
144 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
145 %{__rm} $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
146 %else
147 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
148 %endif
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %if !%{with license_agreement}
154 %post common
155 cd %{_datadir}/atari800
156 if [ "`echo *.rom`" = "*.rom" ]; then
157         umask 022
158         unzip -q -L xf25.zip
159         rm -f xf25.doc xf25.exe
160 fi
161 %endif
162
163 %files common
164 %defattr(644,root,root,755)
165 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
166 %attr(755,root,root) %{_bindir}/atari800
167 %{_datadir}/atari800
168 %{_mandir}/man1/atari800.1*
169
170 %files x11
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/atari800-x11
173
174 %files SDL
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/atari800-SDL
This page took 0.062812 seconds and 3 git commands to generate.