]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- BR: am
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 Summary:        Atari 800 Emulator
7 Summary(pl):    Emulator Atari 800
8 Name:           Atari800
9 Version:        1.3.6
10 Release:        1
11 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
12 Group:          Applications/Emulators
13 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
14 # Source0-md5:  98b58d26aabeedb124233787677c32c3
15 # NOTE: ROMs probably can be redistributed only in original XF25 archive
16 Source1:        http://joy.sophics.cz/www/xf25.zip
17 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
18 Source2:        %{name}-chooser
19 URL:            http://atari800.atari.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  automake
23 %{?with_svga:BuildRequires:     svgalib-devel}
24 %if %{with license_agreement}
25 BuildRequires:  unzip
26 %endif
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags       -fomit-frame-pointer
31
32 %description
33 This is Atari 800, 800XL, 130XE and 5200 emulator.
34
35 %description -l pl
36 To jest emulator Atari 800, 800XL, 130XE i 5200.
37
38 %package common
39 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
40 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
41 Group:          Applications/Emulators
42 Obsoletes:      Atari800
43 %if %{without license_agreement}
44 Requires(post): unzip
45 %endif
46
47 %description common
48 This is Atari 800, 800XL, 130XE and 5200 emulator.
49
50 This package contains common files for both svgalib and X11 versions
51 of Atari800.
52 %if %{without license_agreement}
53 Note: because of license problems we had to include whole X-Former
54 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
55 license_agreement)
56 %endif 
57
58 %description common -l pl
59 To jest emulator Atari 800, 800XL, 130XE i 5200.
60
61 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
62 oraz X11.
63 %if %{without license_agreement}
64 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
65 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
66 przebuduj pakiet z opcja --with license_agreement.
67 %endif
68
69 %package svga
70 Summary:        Atari 800 Emulator - svgalib version
71 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
72 License:        GPL
73 Group:          Applications/Emulators
74 Requires:       %{name}-common = %{version}
75
76 %description svga
77 This is Atari 800, 800XL, 130XE and 5200 emulator.
78
79 This package contains Atari800 executable file configured for svgalib
80 with sound and joystick support.
81
82 %description svga -l pl
83 To jest emulator Atari 800, 800XL, 130XE i 5200.
84
85 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
86 svgalib z obs³ug± d¼wiêku i joysticka.
87
88 %package x11
89 Summary:        Atari 800 Emulator - X Window version
90 Summary(pl):    Emulator Atari 800 - wersja pod X Window
91 License:        GPL
92 Group:          Applications/Emulators
93 Requires:       %{name}-common = %{version}
94
95 %description x11
96 This is Atari 800, 800XL, 130XE and 5200 emulator.
97
98 This package contains Atari800 executable file configured for X11 with
99 sound and joystick support.
100
101 %description x11 -l pl
102 To jest emulator Atari 800, 800XL, 130XE i 5200.
103
104 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
105 obs³ug± d¼wiêku i joysticka.
106
107 %package SDL
108 Summary:        Atari 800 Emulator - SDL version
109 Summary(pl):    Emulator Atari 800 - wersja pod SDL
110 License:        GPL
111 Group:          Applications/Emulators
112 Requires:       %{name}-common = %{version}
113
114 %description SDL
115 This is Atari 800, 800XL, 130XE and 5200 emulator.
116
117 This package contains Atari800 executable file configured for SDL with
118 sound and joystick support.
119
120 %description SDL -l pl
121 To jest emulator Atari 800, 800XL, 130XE i 5200.
122
123 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
124 obs³ug± d¼wiêku i joysticka.
125
126 %prep
127 %setup -q -n atari800-%{version}
128
129 %build
130 cd src
131 rm config.sub
132 cp -f /usr/share/automake/config.sub .
133
134 CFLAGS="%{rpmcflags}"
135
136 %if %{with svga}
137 %configure \
138         --target=svgalib \
139         --disable-VERY_SLOW \
140         --enable-NO_CYCLE_EXACT \
141         --enable-CRASH_MENU \
142         --enable-MONITOR_BREAK \
143         --enable-MONITOR_HINTS \
144         --enable-MONITOR_ASSEMBLER \
145         --enable-COMPILED_PALETTE \
146         --enable-SNAILMETER \
147         --disable-SVGA_SPEEDUP \
148         --enable-USE_CURSORBLOCK \
149         --disable-JOYMOUSE \
150         --enable-LINUX_JOYSTICK \
151         --enable-SOUND \
152         --enable-NO_VOL_ONLY \
153         --enable-NO_CONSOL_SOUND \
154         --disable-SERIO_SOUND \
155         --enable-NOSNDINTER \
156         --disable-CLIP \
157         --disable-STEREO \
158         --disable-BUFFERED_LOG \
159         --enable-SET_LED \
160         --enable-NO_LED_ON_SCREEN
161
162 %{__make}
163
164 mv -f atari800 atari800-svga
165
166 %{__make} clean
167 %endif
168
169 %configure \
170         --target=sdl \
171         --disable-VERY_SLOW \
172         --enable-NO_CYCLE_EXACT \
173         --enable-CRASH_MENU \
174         --enable-MONITOR_BREAK \
175         --enable-MONITOR_HINTS \
176         --enable-MONITOR_ASSEMBLER \
177         --enable-COMPILED_PALETTE \
178         --enable-SNAILMETER \
179         --enable-LINUX_JOYSTICK \
180         --enable-SOUND \
181         --enable-NO_VOL_ONLY \
182         --enable-NO_CONSOL_SOUND \
183         --disable-SERIO_SOUND \
184         --enable-NOSNDINTER \
185         --disable-CLIP \
186         --disable-STEREO \
187         --disable-BUFFERED_LOG \
188         --enable-SET_LED \
189         --enable-NO_LED_ON_SCREEN
190
191 %{__make}
192
193 mv -f atari800 atari800-SDL
194
195 %{__make} clean
196
197 %configure \
198         --target=shm \
199         --disable-VERY_SLOW \
200         --enable-NO_CYCLE_EXACT \
201         --enable-CRASH_MENU \
202         --enable-MONITOR_BREAK \
203         --enable-MONITOR_HINTS \
204         --enable-MONITOR_ASSEMBLER \
205         --enable-COMPILED_PALETTE \
206         --enable-SNAILMETER \
207         --enable-LINUX_JOYSTICK \
208         --enable-SOUND \
209         --enable-NO_VOL_ONLY \
210         --enable-NO_CONSOL_SOUND \
211         --disable-SERIO_SOUND \
212         --enable-NOSNDINTER \
213         --disable-CLIP \
214         --disable-STEREO
215
216 %{__make}
217
218 mv -f atari800 atari800-x11
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
223
224 %if %{with svga}
225 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
226 %endif
227 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
228 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
229 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
230 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
231
232 %if %{with license_agreement}
233 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
234 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
235 %else
236 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
237 %endif
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %if %{without license_agreement}
243 %post common
244 cd %{_datadir}/atari800
245 if [ "`echo *.rom`" = "*.rom" ]; then
246         umask 022
247         unzip -q -L xf25.zip
248         rm -f xf25.doc xf25.exe
249 fi
250 %endif
251
252 %files common
253 %defattr(644,root,root,755)
254 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
255 %attr(755,root,root) %{_bindir}/atari800
256 %{_datadir}/atari800
257 %{_mandir}/man1/atari800.1*
258
259 %files x11
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_bindir}/atari800-x11
262
263 %files SDL
264 %defattr(644,root,root,755)
265 %attr(755,root,root) %{_bindir}/atari800-SDL
266
267 %if %{with svga}
268 %files svga
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_bindir}/atari800-svga
271 %endif
This page took 0.201629 seconds and 3 git commands to generate.