]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- simplified new bconds
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 %ifnarch %{ix86} alpha ppc
7 %undefine       with_svga
8 %endif
9 Summary:        Atari 800 Emulator
10 Summary(pl):    Emulator Atari 800
11 Name:           Atari800
12 Version:        1.3.1
13 Release:        3
14 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
15 Group:          Applications/Emulators
16 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
17 # Source0-md5:  02c824a4648732a3646d377ee02efd7d
18 # NOTE: ROMs probably can be redistributed only in original XF25 archive
19 Source1:        http://joy.sophics.cz/www/xf25.zip
20 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
21 Source2:        %{name}-chooser
22 URL:            http://atari800.atari.org/
23 BuildRequires:  SDL-devel
24 BuildRequires:  XFree86-devel
25 %if %{with svga}
26 BuildRequires:  svgalib-devel
27 %endif
28 %if %{with license_agreement}
29 BuildRequires:  unzip
30 %endif
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags       -fomit-frame-pointer
35
36 %description
37 This is Atari 800, 800XL, 130XE and 5200 emulator.
38
39 %description -l pl
40 To jest emulator Atari 800, 800XL, 130XE i 5200.
41
42 %package common
43 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
44 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
45 Group:          Applications/Emulators
46 Obsoletes:      Atari800
47 %if %{without license_agreement}
48 Requires(post): unzip
49 %endif
50
51 %description common
52 This is Atari 800, 800XL, 130XE and 5200 emulator.
53
54 This package contains common files for both svgalib and X11 versions
55 of Atari800.
56 %if %{without license_agreement}
57 Note: because of license problems we had to include whole X-Former
58 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
59 license_agreement)
60 %endif 
61
62 %description common -l pl
63 To jest emulator Atari 800, 800XL, 130XE i 5200.
64
65 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
66 oraz X11.
67 %if %{without license_agreement}
68 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
69 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
70 przebuduj pakiet z opcja --with license_agreement.
71 %endif
72
73 %package svga
74 Summary:        Atari 800 Emulator - svgalib version
75 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
76 License:        GPL
77 Group:          Applications/Emulators
78 Requires:       %{name}-common = %{version}
79
80 %description svga
81 This is Atari 800, 800XL, 130XE and 5200 emulator.
82
83 This package contains Atari800 executable file configured for svgalib
84 with sound and joystick support.
85
86 %description svga -l pl
87 To jest emulator Atari 800, 800XL, 130XE i 5200.
88
89 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
90 svgalib z obs³ug± d¼wiêku i joysticka.
91
92 %package x11
93 Summary:        Atari 800 Emulator - X Window version
94 Summary(pl):    Emulator Atari 800 - wersja pod X Window
95 License:        GPL
96 Group:          Applications/Emulators
97 Requires:       %{name}-common = %{version}
98
99 %description x11
100 This is Atari 800, 800XL, 130XE and 5200 emulator.
101
102 This package contains Atari800 executable file configured for X11 with
103 sound and joystick support.
104
105 %description x11 -l pl
106 To jest emulator Atari 800, 800XL, 130XE i 5200.
107
108 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
109 obs³ug± d¼wiêku i joysticka.
110
111 %package SDL
112 Summary:        Atari 800 Emulator - SDL version
113 Summary(pl):    Emulator Atari 800 - wersja pod SDL
114 License:        GPL
115 Group:          Applications/Emulators
116 Requires:       %{name}-common = %{version}
117
118 %description SDL
119 This is Atari 800, 800XL, 130XE and 5200 emulator.
120
121 This package contains Atari800 executable file configured for SDL with
122 sound and joystick support.
123
124 %description SDL -l pl
125 To jest emulator Atari 800, 800XL, 130XE i 5200.
126
127 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
128 obs³ug± d¼wiêku i joysticka.
129
130 %prep
131 %setup -q -n atari800-%{version}
132
133 %build
134 cd src
135
136 CFLAGS="%{rpmcflags}"
137
138 %if %{with svga}
139 %configure \
140         --target=svgalib \
141         --disable-VERY_SLOW \
142         --enable-NO_CYCLE_EXACT \
143         --enable-CRASH_MENU \
144         --enable-MONITOR_BREAK \
145         --enable-MONITOR_HINTS \
146         --enable-MONITOR_ASSEMBLER \
147         --enable-COMPILED_PALETTE \
148         --enable-SNAILMETER \
149         --disable-SVGA_SPEEDUP \
150         --enable-USE_CURSORBLOCK \
151         --disable-JOYMOUSE \
152         --enable-LINUX_JOYSTICK \
153         --enable-SOUND \
154         --enable-NO_VOL_ONLY \
155         --enable-NO_CONSOL_SOUND \
156         --disable-SERIO_SOUND \
157         --enable-NOSNDINTER \
158         --disable-CLIP \
159         --disable-STEREO \
160         --disable-BUFFERED_LOG \
161         --enable-SET_LED \
162         --enable-NO_LED_ON_SCREEN
163
164 %{__make}
165
166 mv -f atari800 atari800-svga
167
168 %{__make} clean
169 %endif
170
171 %configure \
172         --target=sdl \
173         --disable-VERY_SLOW \
174         --enable-NO_CYCLE_EXACT \
175         --enable-CRASH_MENU \
176         --enable-MONITOR_BREAK \
177         --enable-MONITOR_HINTS \
178         --enable-MONITOR_ASSEMBLER \
179         --enable-COMPILED_PALETTE \
180         --enable-SNAILMETER \
181         --enable-LINUX_JOYSTICK \
182         --enable-SOUND \
183         --enable-NO_VOL_ONLY \
184         --enable-NO_CONSOL_SOUND \
185         --disable-SERIO_SOUND \
186         --enable-NOSNDINTER \
187         --disable-CLIP \
188         --disable-STEREO \
189         --disable-BUFFERED_LOG \
190         --enable-SET_LED \
191         --enable-NO_LED_ON_SCREEN
192
193 %{__make}
194
195 mv -f atari800 atari800-SDL
196
197 %{__make} clean
198
199 %configure \
200         --target=shm \
201         --disable-VERY_SLOW \
202         --enable-NO_CYCLE_EXACT \
203         --enable-CRASH_MENU \
204         --enable-MONITOR_BREAK \
205         --enable-MONITOR_HINTS \
206         --enable-MONITOR_ASSEMBLER \
207         --enable-COMPILED_PALETTE \
208         --enable-SNAILMETER \
209         --enable-LINUX_JOYSTICK \
210         --enable-SOUND \
211         --enable-NO_VOL_ONLY \
212         --enable-NO_CONSOL_SOUND \
213         --disable-SERIO_SOUND \
214         --enable-NOSNDINTER \
215         --disable-CLIP \
216         --disable-STEREO
217
218 %{__make}
219
220 mv -f atari800 atari800-x11
221
222 %install
223 rm -rf $RPM_BUILD_ROOT
224 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
225
226 %if %{with svga}
227 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
228 %endif
229 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
230 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
231 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
232 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
233
234 %if %{with license_agreement}
235 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
236 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
237 %else
238 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
239 %endif
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %if %{without license_agreement}
245 %post common
246 cd %{_datadir}/atari800
247 unzip -q -L xf25.zip
248 %endif
249
250 %files common
251 %defattr(644,root,root,755)
252 %doc DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST
253 %doc DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
254 %attr(755,root,root) %{_bindir}/atari800
255 %{_datadir}/atari800
256 %{_mandir}/man1/atari800.1*
257
258 %files x11
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_bindir}/atari800-x11
261
262 %files SDL
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_bindir}/atari800-SDL
265
266 %if %{with svga}
267 %files svga
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_bindir}/atari800-svga
270 %endif
This page took 0.05504 seconds and 3 git commands to generate.